Google miui 1.6.24 camera not working

Discussion in 'Other Devices' started by cplovero, Jun 26, 2011.

  1. cplovero

    cplovero Members

    Trophy Points:
    0
    My camera does not work properly on miui 1.6.24. I did a factory reset as well before flashing the newest version. Every time I use it, my phone either freezes completely or it "cannot connect to camera." Anyone else having this issue?
  2. Google Adsense

  3. srkoza

    srkoza Members

    Trophy Points:
    36
    maybe try flashing from froyo install a root and flash again?? ive had bad installs before sometimes the internet wouldnt work i learned how to fix that, sometimes i would get bootloops n stuff had to play around but now its way more stable
  4. cyberon

    cyberon Members

    Trophy Points:
    40
    Same here, using Vignette atm!
  5. just4sky

    just4sky Members

    Trophy Points:
    0
    Same with mine.

    Sent from my Nexus One using the miuiandroid.com forum app
  6. cyberon

    cyberon Members

    Trophy Points:
    40
    Replaced the miuicamera with cm7 one, and it works fine! :)
  7. slifin

    slifin Members

    Trophy Points:
    11
    can you post the apk? and where do I place it? Is there way of replacing the miui one with a patched working version? Would like to stick with the miui version if at all possible
  8. MarcC

    MarcC Members

    Trophy Points:
    11
    Did you wipe your caches before installing? I don't have any issues with the camera on my Nexus One using the latest build.
  9. cyberon

    cyberon Members

    Trophy Points:
    40
    Download CM7 rom, extract it, system/app/camera.apk, copy it to your system/app/ using rootexplorer, set permissions and then reboot.

    If it doesn`t show, install the apk from the sdcard!

    Yep, wiping my caches didn`t work, so i did a fresh install and the issue remains.

    This issue is happening for at least for a month!

    Did you try taking a bunch a photos in a short period of time?
  10. MarcC

    MarcC Members

    Trophy Points:
    11
    Ok, I reproduced the same problem, here is the output from the phone's log (/dev/log/system) around the moment it rebooted:

    --------- beginning of /dev/log/system
    06-29 13:16:06.602 D/QualcommCameraHardware( 97): initDefaultParameters X
    06-29 13:16:06.602 D/QualcommCameraHardware( 97): createInstance: X created hardware=0x26d10
    06-29 13:16:06.602 I/StagefrightPlayer( 97): setDataSource('/system/media/audio/ui/camera_click.ogg')
    06-29 13:16:06.612 I/StagefrightPlayer( 97): setDataSource('/system/media/audio/ui/VideoRecord.ogg')
    06-29 13:16:06.632 D/QualcommCameraHardware( 97): stopPreview: E
    06-29 13:16:06.632 D/QualcommCameraHardware( 97): stopPreviewInternal E: 0
    06-29 13:16:06.632 D/QualcommCameraHardware( 97): stopPreviewInternal X: 0
    06-29 13:16:06.632 D/QualcommCameraHardware( 97): stopPreview: X
    06-29 13:16:06.632 D/QualcommCameraHardware( 97): release E
    06-29 13:16:06.632 D/mm-camera-ctrlcmd( 97): config_proc_CAMERA_STOP_SNAPSHOT: received CAMERA_STOP_SNAPSHOT!, ctrl->state = 0
    06-29 13:16:06.632 D/mm-camera-ctrlcmd( 97): config_proc_CAMERA_STOP_SNAPSHOT: invalid state 0
    06-29 13:16:06.632 E/mm-camera 8x-vfe( 97): Received VFE Stop ACK!!! ctrlCmd is NULL
    06-29 13:16:06.642 D/QualcommCameraHardware( 97): deinitRaw E
    06-29 13:16:06.642 D/QualcommCameraHardware( 97): deinitRaw X
    06-29 13:16:06.882 D/QualcommCameraHardware( 97): dlclose(libqcamera)
    06-29 13:16:06.953 D/QualcommCameraHardware( 97): release X
    06-29 13:16:06.953 D/QualcommCameraHardware( 97): ~QualcommCameraHardware E
    06-29 13:16:06.953 D/QualcommCameraHardware( 97): ~QualcommCameraHardware X
    06-29 13:16:06.973 I/talk ( 464): supported front camera id: -1
    06-29 13:16:06.973 I/talk ( 464): supported back camera id: 0
    06-29 13:16:08.204 I//system/bin/fsck_msdos( 92): 2086 files, 3745640 free (3033562 clusters)
    06-29 13:16:13.459 I//system/bin/fsck_msdos( 92): ***** FILE SYSTEM WAS MODIFIED *****
    06-29 13:16:13.459 I/logwrapper( 92): /system/bin/fsck_msdos terminated by exit(4)
    06-29 13:16:13.459 W/Vold ( 92): Filesystem modified - rechecking (pass 2)
    06-29 13:16:13.469 I/PackageManager( 123): Updating external media status from unmounted to mounted
  11. cyberon

    cyberon Members

    Trophy Points:
    40
    Already left a logcat on miui.com, send yours also, lets see if they take a look at it!
  12. MarcC

    MarcC Members

    Trophy Points:
    11
    See my updated post. I'm Googling this and finding some posters suggesting experimenting with alternative kernels. This sucks. Maybe this should be moved to the Bugs section of the forum?
  13. MarcC

    MarcC Members

    Trophy Points:
    11
    On a hunch, I tried wiping my phone and installing QND's version of MIUI (http://db.communityrelease.com/release_display.asp?ReleaseID=526). Once I did that, I tried rapidly taking a few pics, and I can't reproduce the problem I experienced previously, but I am getting a new error about not being able to connect to the camera... Could it be some kind of memory leak?
  14. cyberon

    cyberon Members

    Trophy Points:
    40
    I am also getting that error here!

    Sent from my Nexus One using Tapatalk
  15. nephron

    nephron Members

    Trophy Points:
    16
  16. marconiglio

    marconiglio Members

    Trophy Points:
    11
    I had the same issue soon after upgrade: it recognized only the front camera while normally it doesn't...
    I've made a force close from settings->system->applications->All->Camera
    Rebooted.. all is fine

    Sent from my GT-I9000 using the miui-dev.com Forums App
  17. cyberon

    cyberon Members

    Trophy Points:
    40
    1.7.1, fixed the issues. :)

Share Our Site