New SGS2 2.5.11 - unfortunately, the process com.android.phone has stopped

Discussion in 'Bugs' started by žuža, May 13, 2012.

  1. žuža

    žuža Members

    Trophy Points:
    11
    Hi.

    I have huge problem :-/ I had version 2.4.20 before and suddenly (today) my phone kept rebooting on and on, couldn't stop it.
    So I thought I would solve this problem if I download 2.5.11 version. I did that, copy to SD (over card reader, cause I couldn't do it over phone), I've cleared dalvik and partition cache and install new zip version.

    Now I have new problem after installing 2.5.11 version. When I turn it on, I need to enter code of my phone (that's ok), but it doesn't read my SIM card (to ask me for PIN, to log on to network).. and it keeps showing me alert "unfortunately, the process com.android.phone has stopped" and I can't do anything.. even copy catlog and send it over wi-fi or something.

    I could only make screenshot (see attachment)

    What to do?

    regards,
    žuža

    Attached Files:

  2. Google Adsense

  3. iBotPeaches

    iBotPeaches Script Gatekeeper Staff Member

    Trophy Points:
    335
    Have you tried wiping /dalvik and /cache and re-flashing?
  4. žuža

    žuža Members

    Trophy Points:
    11
    I did. That didn't solve the problem :-(
  5. SavageBrat

    SavageBrat Members

    Trophy Points:
    18
    Give this a try,,
    wipe the cache
    wipe divak
    then go to mounts and storage- format system
    factory reset
    then install you rom..
  6. žuža

    žuža Members

    Trophy Points:
    11
    which means i'll lose all my data .. :(
  7. dyleck

    dyleck Members

    Trophy Points:
    23
    I have the same issue however not 100 percent of the time. I had to keep rebooting until it works again. Wiping cache and dalvik cache does not help.
  8. SavageBrat

    SavageBrat Members

    Trophy Points:
    18
    This is true but I just offered a suggestion as I do the same thing every week but at least it eliminates 85% of the headaches caused by not properly flashing the rom (though it may work for some just wiping the cache/divak as each phone is different) the other 12% are the know issues with MIUI, like lag on the lock-screen with old wallpaper sometimes appearing,moving apps to ext.SD and the other bugs but that will be corrected in time, the other 8% is caused by me..trying new things.. but would you rather try what I suggested and see if it corrects your problem or live with the fc's. :rolleyes:
  9. žuža

    žuža Members

    Trophy Points:
    11
    well "thanx" for advice ..
    I did format system and I did factory reset. Now when I want to install zip from sdcard I'm getting error:

    Code:
    -- Installing: /sdcard/MIUI/miuiandroid_GT-I9100-2.5.11.zip
    Finding update package...
    Opening update package...
    Installing update...
    assert failed: getprop("ro.product.device") == "GT-I9100" ||    getprop("ro.product.device") == "GT-I9100" ||    getprop("ro.product.device") == "galaxys2" ||    getprop("ro.product.device") == "galaxys2" ||   
    E:Error in /sdcard/MIUI/miuiandroid_GT-I9100-2.5.11.zip
    (Status 7)
    Installation aborted.
  10. SavageBrat

    SavageBrat Members

    Trophy Points:
    18
    does your phone reboot ok, and sorry for the headache..re-download the rom you may have gotten a bad one..
  11. žuža

    žuža Members

    Trophy Points:
    11
    I've tried different versions of miui rom.. problem is still there! Installation aborted.

    Now I'm totally pissed off.
  12. iBotPeaches

    iBotPeaches Script Gatekeeper Staff Member

    Trophy Points:
    335
    That error means your phone isn't one of those models. I would restore a backup, then re-trigger a re-flash.
  13. žuža

    žuža Members

    Trophy Points:
    11
    I don't have backup ..
  14. phantom9k

    phantom9k Members

    Trophy Points:
    23
  15. žuža

    žuža Members

    Trophy Points:
    11
    I couldn't back it up ..
  16. Acid

    Acid Scripting Ninja Staff Member

    Trophy Points:
    140
    Nandroid backup in recovery? MIUI Backup? There's a lot of tools to make a backup before wipe.

    This error:
    Code:
    assert failed: getprop("ro.product.device") == "GT-I9100" ||    getprop("ro.product.device") == "GT-I9100" ||    getprop("ro.product.device") == "galaxys2" ||    getprop("ro.product.device") == "galaxys2" ||
    E:Error in /sdcard/MIUI/miuiandroid_GT-I9100-2.5.11.zip
    means that you either do not have the right device to flash or.. after you wiped /system you don't have build.prop in /system so the getprop function fails. It tries to read the file which doesn't exist.
    If so you can try disabling assert scripting in recovery (just search for this function) or... you can open miuiandroid_GT-I9100-2.5.11.zip (but without unpacking!!) and open file /META-INF/com/google/android/updater-script in text editor (Notepad++) and delete first 2 lines:
    Code:
    assert(getprop("ro.product.device") == "GT-I9100" ||
          getprop("ro.build.product") == "GT-I9100" || getprop("ro.product.device") == "galaxys2" || getprop("ro.build.product") == "galaxys2");
    
    Save and put file back to zip. This should allow you to install zip.
  17. boxcarracer81

    boxcarracer81 Members

    Trophy Points:
    75
    I would start over all again. Download stock firmware of sammy's page www.sammobile.com or xda. Root with cf-root, download Miui en flash in cwm, after complete wipes. You've lost your data already so there is no harm in doing it this way.. :cool:
    Abdul Fatah Shieryar likes this.
  18. Angelo

    Angelo Members

    Trophy Points:
    50
    I got the same problem just now...this is very annoying....same phone and out of the blue got this problem. Had to factory reset...oh and by the way, before installing v 2.5.11 on my sgs2 I did do a factory reset already.....please fix this kind of stability issues
  19. žuža

    žuža Members

    Trophy Points:
    11
    I did that, now the problem is gone. Thanx.

Share Our Site