New [21.03.03] [21.03.11] Mi 10T - Audio does not work when connected to a car via bluetooth


Black_SunVRN

Members
Mar 11, 2021
4
5
Hello everyone. I apologize in advance for my english.
I found out such a problem - when the device is connected to the car via bluetooth, the connection status is "Connected (except audio)". If I disable AAC for this connection, the checkbox will still return to the "Enabled" status when I close settings. When I try to change the audio codec in developer mode, the changes are also not saved and are reset to "default" after close dev. settings. Car of 2020, this problem did not arise on the stable rom. I also tried to delete the connection, restart the phone and car media center - to no avail. The only problem is with this connection, the headphones work without problems.
 

gello94

Members
Jun 13, 2021
5
13
I have the same problem! I Tried to force the SBC driver as default but it keeps changing on AAC and the only solution was to downgrade to miui 12.1. I will try a custom rom as Lineage OS now. But this is so crazy that i can't use official MIUI 12.5 to connect to my car multimedia system.
 

gello94

Members
Jun 13, 2021
5
13
Hello everyone. I apologize in advance for my english.
I found out such a problem - when the device is connected to the car via bluetooth, the connection status is "Connected (except audio)". If I disable AAC for this connection, the checkbox will still return to the "Enabled" status when I close settings. When I try to change the audio codec in developer mode, the changes are also not saved and are reset to "default" after close dev. settings. Car of 2020, this problem did not arise on the stable rom. I also tried to delete the connection, restart the phone and car media center - to no avail. The only problem is with this connection, the headphones work without problems.

Is this problem solved? Or is it still there? If solved wich version did the job? My only solution was to go back on miui 12.1.2