New 3.10.25 SGS2 - no usb connection (again!)

Discussion in 'Bugs' started by markyboy, Oct 28, 2013.

  1. markyboy

    markyboyMembers

    Mar 22, 2012
    41
    2
    18
    Male
    As per my previous thread (http://xiaomi.eu/community/threads/sgs2-no-usb-mounting.22141/), this problem seems to have reappeared.

    On 3/10/25 and the release prior, I can charge via USB but no data connection. The Storage setting for Ask On Connection is still on, but the connection is not registering. No USB icon in the status bar.

    The solution in previous thread was simply to wait for a fix. I'd hoped 3.10.25 would do same, but sadly not.
     
  2. sk1887

    sk1887Members

    Oct 5, 2013
    20
    3
    13
    Male
    what kernel do you use? one thing i'd try is to check if you can mount usb storage in recovery
     
  3. markyboy

    markyboyMembers

    Mar 22, 2012
    41
    2
    18
    Male
    Still a problem on MIUI 3.11.1 Hoping someone else is running MIUI on SGS2 and can confirm this behaviour.

    My original post was about USB mount failing on my Dell PC at work. To test further I tried connecting my phone to my macbook at home this morning, using a different cable. Result is the same. USB charge happens, but nothing to indicate the phone is recognised as a usb storage device.

    Kernel is 3.0.31-Siyah-s2.v6.0b4+ I believe that’s what comes bundled with MIUI, but not 100% sure.

    I tried restarting to CWM download mode – macbook didn’t show any sign of a storage device being available. But I am not sure this is what you meant.
     
  4. sk1887

    sk1887Members

    Oct 5, 2013
    20
    3
    13
    Male
    You must try Reboot into ClockWorkMod recovery. Then select mounts and storage, and choose mount usb. I am sure you can do this as you flashed the rom :)
    If it still fails, consider a usb port replacement. you could also test if adb works.
     
  5. markyboy

    markyboyMembers

    Mar 22, 2012
    41
    2
    18
    Male
    I've never had to mount my phone via usb from cwm, or if I did it was a long time ago and I've forgotten. So thanks for the tip. Anyway, plugged in to my Macbook Pro, booted to cwm and tried it - no dice. Guess my USB connection is broken.

    Might be time to upgrade to a newer phone anyway.
     
  6. sk1887

    sk1887Members

    Oct 5, 2013
    20
    3
    13
    Male
    come on :) you can still try to change the usb port. it's about 15€ from UK. I had to look for this when my usb port was bent down and the phone would stay in charge mode forever.
     
  7. markyboy

    markyboyMembers

    Mar 22, 2012
    41
    2
    18
    Male
    I've already done repairs on my sgs1 when the home button died. And not long ago I replaced the headphone jack on my sgs2, but got something wrong so now it doesn't vibrate, and the phone ear speaker doesn't work so I have to take calls with headphones in or put it on speaker phone. What can I say - these phones aren't toddler proof, and being a Dad to a nearly 3-year old, I'm a little too time poor to keep repairing this phone.

    Not helping is that ES File Explorer can no longer connect to my windows media pc shares (it used to work fine). Right now I have no simple way of transferring music to or from my phone... :( But that's a separate issue.
     
  8. sk1887

    sk1887Members

    Oct 5, 2013
    20
    3
    13
    Male
    Poor you :(
    I understand why you think of purchasing a new phone then.
    By the way in the meanwhile you could try transferring files from pc using wireless connection. es explorer does this job just fine.
     

Share Our Site