adb problem during twrp install


swifteh

Members
Mar 19, 2012
8
25
Hi all, apologies if this is in the wrong place. Looking for some advice. I have not really dabbled in rooting or flashing for around 10 years so im super rusty and cautious. I have a Mi 10T Lite from the UK Xiaomi store. I would like to flash the Xiaomi.EU ROM for custom themes so i have successfully unlocked my bootloader and now at the install twrp step im coming across powershell not detecting any devices.

Im sure i have the correct drivers installed, im trying with usb debugging enabled and disabled, im trying with usb 3.0 ports on my comp and a usb 2.0 adapter hub and nothing is working. My fear is that im missing something blatantly obvious thats probably staring me in the face xD


Any help will be much appreciated, thank you.


Ryan
 

Attachments

  • 1.png
    1.png
    73.5 KB · Views: 124
  • 2.png
    2.png
    1.4 MB · Views: 123
  • 3.png
    3.png
    1.4 MB · Views: 115

m@c|-|oR

Members
Sep 5, 2020
359
67
Did you make sure that USB debugging is enabled in developer options?
Does your PCs file Explorer recognize your phone as an external drive?
Did you try to boot in fastboot?
What dialog does the fastboot devices return:(in fastboot mode)?
Had the similar issue with mine Mi 10, solved by ticking all of the above.

Послато са Mi 10 помоћу Тапатока
 

Mark F

Members
Aug 15, 2020
640
102
Also, try using a command prompt instead of power shell. You can go into Dev options and revoke old connections too.
 

swifteh

Members
Mar 19, 2012
8
25
Sorry i forgot to say, the phone is in fastboot mode while trying all these things. Just tried command prompt and i get the same result, like theres nothing there. Can someone point me towards the latest drivers for Mi 10T Lite please? Cant help but feel i have a driver problem. Thanks so much for your replies so far guys.

EDIT: I attached pics to my original post of what the powershell was saying, cant you guys see them?
 

swifteh

Members
Mar 19, 2012
8
25
Послато са Mi 10 помоћу Тапатока


C:\Users\ryan1>adb devices
List of devices attached


C:\Users\ryan1>adb devices
List of devices attached


C:\Users\ryan1>


First time with usb debugging, second time without so no matter what, this is all i get with powershell and command prompt:(
 

m@c|-|oR

Members
Sep 5, 2020
359
67
Mate, type fastboot devices and tell us what dialog does it return.
adb devices in fastboot mode doesn't work. adb devices works in twrp mode or in system booted up.

Послато са Mi 10 помоћу Тапатока
 

swifteh

Members
Mar 19, 2012
8
25
Ok i get a result with the fastboot devices command, it says;

PS C:\adb> fastboot devices
697349a5 fastboot
PS C:\adb>
 

m@c|-|oR

Members
Sep 5, 2020
359
67
This means that your PC has recognized your phone.
Save your TWRP.img file into your fastboot folder and flash it
fastboot flash recovery TWRPwhateveryounamedit.img
Then, type fastboot reboot TWRPwhateveryounamedit.img.
Be patient, it might take a while for TWRP to boot.

Послато са Mi 10 помоћу Тапатока
 

swifteh

Members
Mar 19, 2012
8
25
Thank you so much for your help mate, twrp has flashed successfully however when i type in fastboot reboot twrp.img i get this massive wall of text

C:\adb> fastboot reboot twrp.img
usage: fastboot [ <option> ] <command>

commands:
update <filename> reflash device from update.zip
flashall flash boot, system, vendor and if found,
recovery
flash <partition> [ <filename> ] write a file to a flash partition
flashing lock locks the device. Prevents flashing partitions
flashing unlock unlocks the device. Allows user to flash any partition except the ones that are related to bootloader
flashing lock_critical Prevents flashing bootloader related partitions
flashing unlock_critical Enables flashing bootloader related partitions
flashing get_unlock_ability Queries bootloader to see if the device is unlocked
erase <partition> erase a flash partition
format[:[<fs type>][:[<size>]] <partition> format a flash partition.
Can override the fs type and/or
size the bootloader reports.
getvar <variable> display a bootloader variable
boot <kernel> [ <ramdisk> ] download and boot kernel
flash:raw boot <kernel> [ <ramdisk> ] create bootimage and flash it
devices list all connected devices
continue continue with autoboot
reboot [bootloader] reboot device, optionally into bootloader
reboot-bootloader reboot device into bootloader
help show this help message

options:
-w erase userdata and cache (and format
if supported by partition type)
-u do not first erase partition before
formatting
-s <specific device> specify device serial number
or path to device port
-l with "devices", lists device paths
-p <product> specify product name
-c <cmdline> override kernel commandline
-i <vendor id> specify a custom USB vendor id
-b <base_addr> specify a custom kernel base address.
default: 0x10000000
-n <page size> specify the nand page size.
default: 2048
-S <size>[K|M|G] automatically sparse files greater
than size. 0 to disable
 

swifteh

Members
Mar 19, 2012
8
25
I think i will just leave it for now till i can get more confidence in what im doing, im scared i do something didasterous lol. Thank you all for your time today its most appreciated!
 

m@c|-|oR

Members
Sep 5, 2020
359
67
Alright, this indicates wrong syntax.
Not very familiar with your particular device. You might try fastboot reboot recovery twrp.img or fastboot reboot recovery, whichever is working.
I mean, you now need to boot to your twrp in order to flash the rom.

Послато са Mi 10 помоћу Тапатока
 

m@c|-|oR

Members
Sep 5, 2020
359
67
I think i will just leave it for now till i can get more confidence in what im doing, im scared i do something didasterous lol. Thank you all for your time today its most appreciated!
As you wish, but you're only a step away from the goal.

Послато са Mi 10 помоћу Тапатока
 

m@c|-|oR

Members
Sep 5, 2020
359
67
Now, I am in a similar situation.
After changing job, I got another PC and now, when I want to flash the newer TWRP I have a strange situation - ADB recognizes the phone when it's on.
adb devices returns a device code (the PC and the phone are communicating)
adb reboot fastboot is rebooting the phone in TWRP which is trying to start fastboot
When I reboot the phone in fastboot manually,
fastboot devices doesn't give back anything - the PC and the phone are not communicating.

I have adb driver installed, I have USB driver installed.
WTF?

EDIT:
adb reboot bootloader reboots the phone into fastboot.

So, in conclusion, the adb is recognizing the phone and it's working alright, while fastboot is not.
 
Last edited:

geoorg

Members
Sep 28, 2020
1,783
297
Now, I am in a similar situation.
After changing job, I got another PC and now, when I want to flash the newer TWRP I have a strange situation - ADB recognizes the phone when it's on.
adb devices returns a device code (the PC and the phone are communicating)
adb reboot fastboot is rebooting the phone in TWRP which is trying to start fastboot
When I reboot the phone in fastboot manually,
fastboot devices doesn't give back anything - the PC and the phone are not communicating.

I have adb driver installed, I have USB driver installed.
WTF?

EDIT:
adb reboot bootloader reboots the phone into fastboot.

So, in conclusion, the adb is recognizing the phone and it's working alright, while fastboot is not.
A wise man once said "you're only a step away from the goal" ;)

You only need to install fastboot drivers and you're done.
 
  • Like
Reactions: m@c|-|oR