apktool build errors

Discussion in 'Mi General' started by Rune Gangstø, Apr 14, 2013.

  1. Rune Gangstø

    Jul 5, 2012
    17
    0
    11
    Hi!

    I am trying to modify a couple of apk files, just to try out a few things, but I am not able to recompile them. I have tried to add the framework-miui-res.apk and framework-res.apk with the apktool if command. I have also chekced that I have the latest aapt file, found in this file at google code: apktool-install-linux-r05-ibot.tar.bz2....

    I red something about a dummy framework. I found some links in the translation guide, but only the apktool.yml was found, the other link (dropbox link) seems to be down. Is this something I need, where can I find it?
    I have tried to search for this problem with google, but I have not found anything that helped me.

    Anyone got an idea what I do wrong?

    I am trying to recompile the v5 version, latest.


    This is an example of FM.apk. Some of the apk files seems to compile fine, but most of them end up like this. This applies to the framework-miui-res.apk as well.
    Code:
    I: Smaling...
    I: Building resources...
    I: Building apk file...
    Exception in thread "main" brut.androlib.AndrolibException: brut.directory.PathNotExist: apktool.yml
        at brut.androlib.Androlib.readMetaFile(Androlib.java:164)
        at brut.androlib.Androlib.build(Androlib.java:183)
        at brut.androlib.Androlib.build(Androlib.java:176)
        at brut.apktool.Main.cmdBuild(Main.java:228)
        at brut.apktool.Main.main(Main.java:79)
    Caused by: brut.directory.PathNotExist: apktool.yml
        at brut.directory.AbstractDirectory.getFileInput(AbstractDirectory.java:103)
        at brut.androlib.Androlib.readMetaFile(Androlib.java:160)
        ... 4 more
    Thank you
     
  2. 1982Strand

    1982StrandMembers

    Apr 2, 2011
    204
    10
    40
    PathNoExist: apktool.yml is a directory error. Apktool can't find the folder where apktool.yml is, so you're entering a wrong command..
    when you recompile, you should point to the folder you decompiled to, not the apk itself
     
  3. jwchips

    jwchipsMembers

    Sep 22, 2011
    78
    5
    18
  4. I've the same problem and i can't solve it !
    I'm trying to translate miui V5 for Ascend P1 into italian , but whit this problem i can't compile any apk.
    Help me please! Sorry for my bad English ;)
     
  5. iBotPeaches

    iBotPeachesScript Gatekeeper

    Oct 31, 2011
    3,811
    1,113
    335
    Kansas
    Your doing something wrong, and everything is answered here, so keep reading it.
     

Share Our Site