Battery drain for RILJ

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by kazin08, Sep 19, 2014.

  1. kazin08

    kazin08Members

    Jul 17, 2014
    97
    14
    20
    Male
    hi to all, sorry for the new thread but i need your help.

    This happen after go back to the partition table, i was using Linaro cm mod, and then i want to go back to have the 2 partitions. I used MiFlash to do the repartition, and in cwm use dload, that format all mi phone.
    Then i install the Ivans ROM 4.4.4 and get that issue, and not only with that ROM. every ROM CM, WIUI, MIUI, etc. RILJ it's always on, my phone never get into deep sleep.

    This it's mi problem and i can't fix it, so i need help.

    thanks!
     
  2. kazin08

    kazin08Members

    Jul 17, 2014
    97
    14
    20
    Male
    So, i continue with this issue =( nobody know how to fix it?

    now only appear in ROMs except of MIUI ROMs. Any ideas? i try everything, full wipe, flash, fastboot, all. This issue keep.
    and only appear when mobile data is enabled, with wifi my phone get deep sleep.

    Screenshot_2014-11-12-22-32-39.pngScreenshot_2014-11-12-22-32-48.pngScreenshot_2014-11-12-22-33-11.png

    thanks.
     
  3. XperianPro

    XperianProMembers

    Oct 26, 2013
    648
    217
    80
    Male
    I dont know but today I got only two hour screen time i think its because of mobile data I normally dont use but not sure.
     
  4. kazin08

    kazin08Members

    Jul 17, 2014
    97
    14
    20
    Male
    i'm i out of ideas, i can't fix it :/

    why only happen with data enabled? and all ROMs except MIUI?

    when you install a Fastboot ROM, and install another, need to configure something?
     
  5. XperianPro

    XperianProMembers

    Oct 26, 2013
    648
    217
    80
    Male
    Well I cant tell but it might be connected with new baseband because I reflashed my phone completly a week ago(and I assume you too?),I advise you flash older baseband and report if it worked.

    Baseband = modem
     
  6. kazin08

    kazin08Members

    Jul 17, 2014
    97
    14
    20
    Male
    Yeah, i'm try, but i'm keep looking fot all modems.

    It's okey the modem files have the same date and the same bytes?
     
  7. kazin08

    kazin08Members

    Jul 17, 2014
    97
    14
    20
    Male
    well, in my search, i see the process "com.google.process.location" it's always on. I stop it but it start again. I've switch off location service., so i dont know how to stop it. I think this is the wakelock problem.

    in the pictures i saw a "radio active" i don't know what it's but it isn't the signal, it's the wakelock.
    Screenshot_2014-11-20-10-03-35.pngScreenshot_2014-11-20-10-03-39.pngScreenshot_2014-11-20-10-03-46.png
     

Share Our Site