Boot Loop :-(

Discussion in 'Redmi Pro' started by jimbobbly, Sep 4, 2017.

  1. jimbobbly

    jimbobblyMembers

    Sep 4, 2017
    4
    0
    1
    Male
    Can anybody help fix my redmi pro?

    Was using xiaomi.eu weekly version with no problems, but phone without warning entered a boot loop and I can't fix it.

    - can enter fastboot using power + vol.down
    - can upload twrp.img, but phone won't boot it (goes into boot loop)
    - have tried using SP Flash tool to flash china developer and stable official roms
    - SP appears to flash successfully (using a custom cust.img), but goes into boot loop again

    Is there anything else I can try?

    Thanks
     
  2. Nxkealen

    NxkealenMembers

    Feb 16, 2017
    127
    44
    40
    Male
  3. jimbobbly

    jimbobblyMembers

    Sep 4, 2017
    4
    0
    1
    Male
    Thanks Nxkealen,

    I have tried with both the fastboot roms (stable and developer) which can be downloaded from the official site.

    I can flash either of them using SP Flash tool (with a different cust.img) or MiFlash, but still get stuck in a boot loop.

    I can unlock the bootloader (check with fastboot getvar), and upload a twrp.img, but nothing boots! All I see is the 'mi' logo for several seconds, then the phone vibrates and reboots into an infinite loop.

     
  4. sid_aj

    sid_ajMembers

    Oct 23, 2017
    2
    0
    1
    Male
    @jimbobbly were you able to fix this? My phone did the same yesterday out of the blue and is now stuck on the MI logo.
     
  5. jimbobbly

    jimbobblyMembers

    Sep 4, 2017
    4
    0
    1
    Male
    No, I tried many times, but could never get away from the Mi logo. In the end I sent it back to the online shop where I bought it from, and they have apparently sent it back to Xiaomi.
     
  6. sid_aj

    sid_ajMembers

    Oct 23, 2017
    2
    0
    1
    Male
    That is bad. I honestly don't care if the phone never works again, but I am desperate to get my photos and videos off it. I was stupid enough to capture my little one's videos with the phone and not backing them up. But then who would have thought that their phone would never reboot after being switched off on a flight. Did you have any luck getting data from the phone? If yes, can you share how you did it? Thanks.
     
  7. ronlkh

    ronlkhMembers

    Oct 6, 2016
    2
    0
    13
    Male
    Flash root


    Sent from my Redmi Pro using Tapatalk
     
  8. jimbobbly

    jimbobblyMembers

    Sep 4, 2017
    4
    0
    1
    Male
    I tried 'flashing root', but it always went back to the same boot loop.

    I could get access through fastboot, but I don't think that's enough to extract data. Fortunately I didn't have anything important on it, but from now on I will use an sd card.

    My phone is currently with xiaomi - waiting to hear whether they can fix it or not. (and how much they will charge for it).
     
  9. BaSiC71

    BaSiC71Members

    Nov 2, 2017
    2
    0
    1
    Male
    Hi everyone, I have the same problem for months and tried the same solutions, nothing can do.

    At the begening I've been able to boot (sometimes !!) but i had crashes. Now I can go sometime to the loading page for 5 or 10 seconds then the phone reboot...

    I know that i've lost the IMEI numbers... I've tried to fix it beacause I though the program is crashing at the IMEI loading (???) but I've not been able to do it with some tutorials...

    I'm despited, I loved my Redmi, it's a very good smartphone but I think i'll never fix it...
     
  10. Alastor1111

    Nov 13, 2017
    2
    0
    1
    Male
    After flashing in Sp Flash tools, i opened my phone, disconnected battery and side buttons (+,-, power button). Then reconnected flat cables for battery and side buttons. Turn on the phone, and its booted in system :)
     
  11. BaSiC71

    BaSiC71Members

    Nov 2, 2017
    2
    0
    1
    Male
    @Alastor1111Good idea, i've Just tried and i was near to boot, the loading screen is active a few time. But i still have crash before the full loading.

    Now the strange thing is that I can start booting only when charger is plugged, when unpluggeg i have the logo then crash. I'm asking to myself if i would have a battry or voltage issu and how to solve it...
     
  12. Alastor1111

    Nov 13, 2017
    2
    0
    1
    Male
    If you can open your phone, try to check contact on battery, change battery, check charging port if it's lose contact. Flash only preloader first, then flash all files from scatter file.txt.
     

Share Our Site