Brandnew unit won't power up after working just one day


Jul 31, 2013
2
0
11
#1
Got it as a gift from my friend in HK.
Plugged it in and it worked like charm on first day.
However, next day it would not power up.
I notice there is a blue light flashing in the front of the unit. But there is nothing seen on the TV.
Tried to push all combinations of button on the remote but it seems dead in the water with no pluses.
Can some one please shed me some light on this? It is frustrating that this thing only worked one day. Oh, one more thing on first night when prompted I upgraded the unit with the latest updates or something. I also measured the voltage on the remote battery it seems low 3V.
Any help is greatly appreciated.
Newbie here
 
Feb 25, 2012
62
46
28
#2
Did you use the whole battery till it shut down? If so, try to remove the battery, plug in your charger. Wait till the phone starts and then put in your battery again. If it's not the battery, tri to reset your phone with the miflash tool (search hear in the forum).
 
Jul 31, 2013
2
0
11
#3
Did you use the whole battery till it shut down? If so, try to remove the battery, plug in your charger. Wait till the phone starts and then put in your battery again. If it's not the battery, tri to reset your phone with the miflash tool (search hear in the forum).
Thanks Dude,

But it is a Xiaomi Mi internet TV Box not a phone.

I think it is the usb power adapter that has gone bad. Tested with a digital voltmeter, it was putting out only ~3v and fluctuating.
So, I tested it with my cellphone usb charger and the box booted up, but then it kept rebooting. Then I went to have a look at the output amp on both adapters. I figure the Mi box needs a 5V 2A power supply and my cellphone charger is rated only 1A.
Not sure if this is the problem, but I already ordered a new 2A power supply and will test it out.
Keeping my fingers crossed!
 
Jan 7, 2014
2
0
21
#4
Thanks Dude,

But it is a Xiaomi Mi internet TV Box not a phone.

I think it is the usb power adapter that has gone bad. Tested with a digital voltmeter, it was putting out only ~3v and fluctuating.
So, I tested it with my cellphone usb charger and the box booted up, but then it kept rebooting. Then I went to have a look at the output amp on both adapters. I figure the Mi box needs a 5V 2A power supply and my cellphone charger is rated only 1A.
Not sure if this is the problem, but I already ordered a new 2A power supply and will test it out.
Keeping my fingers crossed!

I have similar problem. My Mi box keeps restart itself sometimes, do you think is the power adapter?
 
Nov 18, 2014
10
0
11
#5
Got it as a gift from my friend in HK.
Plugged it in and it worked like charm on first day.
However, next day it would not power up.
I notice there is a blue light flashing in the front of the unit. But there is nothing seen on the TV.
Tried to push all combinations of button on the remote but it seems dead in the water with no pluses.
Can some one please shed me some light on this? It is frustrating that this thing only worked one day. Oh, one more thing on first night when prompted I upgraded the unit with the latest updates or something. I also measured the voltage on the remote battery it seems low 3V.
Any help is greatly appreciated.
Newbie here

If this is a "JailBreak" Mi-Box, NEVER update it (you can update 3rd party apps, but not MI).