Bricked Redmi Note 2


Jul 22, 2015
71
13
20
#1
My redmi note 2 was like this after i fastboot flash global rom thrpugh miflash.


Then i tried to unbricked it by using sp flash tool. I got detected as preloader usb vcom port at ports (com & lpt). But i click the download button after selecting scatter loading file from latest global rom, it just stays like this.

Without no progress bar at all. What am i suppose to do? Service centre here wont entertain my problem since i imported this phone. I cant send to reseller to fix it now because im out of state.

Edit: i cant boot into fastboot or recovery. It will go into the first pic.

Sent from my 2014811 using Tapatalk
 
Jul 22, 2015
71
13
20
#3
What recovery do you have installed?

Enviado desde mi MI 3W mediante Tapatalk
Stock recovery. I flash the unbricked rom for redmi note 2 from needrom site through sp flash tool.. Got it boot up okay.. But imei gone.. Dont remember if the was one before when i bought it.. I update to stable china rom 6.7.3 and manage to update to 7.0.6 stable china.. But when i update to stable china 7.2, the white blue lines came back. Same thing happened when i update to latest stable rom. So now im stuck with stable china 7.0.6. Its fine if im using this phone,, im okay with english. But since my mum use the phobe,, she prefer our native language which only supported in global rom.. Eu rom also dont have the language. Why do you think i cant flash to stable global rom even when i tried with twrp.. Charging works when in white stripes state.. My redmi note 2 model is 2015052.

Sent from my 2014811 using Tapatalk
 
Jul 22, 2015
71
13
20
#5
Try to redownload the latest fastboot global, and select flash all when flashing with MiFlash..

If that doesn't work flash the latest fastboot that works ok, and then flash the latest stable zip.
I did that first. The latest stable global and China, both flash all using mi flash. Doesn't work. Not sure where to get older version fastboot ROM. I did googled. One thing I noticed when im trying to backup through twrp, the only partition exist is system, nvram, data, recovery. I've never saw nvram when I was messing with my redmi 2. It was always boot, recovery, system, data, cache.

Is it because of mediatek?

Sent from my 2014811 using Tapatalk