New Bt Media Remotes: Skipping Not Working?


Jun 5, 2018
2
0
3
#1
Hi All,
I tried several bluetooth media remotes (one pretending to be a keyboard, one not, a third is actually a game controller). Play/Pause, Vol+/Vol- always works, but skip forward/backward never. Tested in several apps, for instance Amazon Music, Podcast Addict. Is that a MIUI problem? Would need it to skip tracks/podcasts while driving in the car without fiddling with the phone.

System:
Xiaomi Redmi 3 (not the Note)
Bootloader unlocked
Android 5.1.1 LMY47V
Sec patch level 2017-01-01
MIUI Version MIUI Global 9.5 | Stable 9.5.2.0 (LAIMIFA)
Kernel version 3.10.49-perf-g8f97f0
 
Jun 5, 2018
2
0
3
#2
Just a little update:
- All media remotes work on my Samsung Galaxy Tab 10.1 2014
- When I use the app Button Mapper, it can learn new button presses. In this function, it displays the registered button code when a button on a remote is pressed. For instance, if I press Vol+ (which works), then it recognises this as "Volume Up (24)" or something like this (I can't remember the key codes exactly). However, when I press skip / next / previous track, it just says something like "Unknown (0)" for both keys (forward and backward / next-previous track).
- Remembering back, when I tried bluetooth headphones with such buttons, then actually skipping always did work.

Thus, it might be something specific to this version of Android or Miui. I guess I just have bad luck here...

Best wishes,
Andre