New Buttons away, apps without any response - MI2


Feb 25, 2013
14
0
11
#1
Hello, i have a Mi2, ROM 3.5.3 and lot of apps time to time do not response, I can tap on it how mutch I want and nothing-it happen just sometimes, tried to make a logcat but with no result-will try again..
But there is another bug, sometimes the buttons, and icons disappear after the first bug-screenshots added
Hoping you can help me, not nice to see this phone not responding
 

Attachments

Acid

Scripting Ninja
Staff member
Aug 20, 2011
2,726
744
247
#3
It works for me. Did you do something unusual? Maybe install gapps?


Wysłane z MI 2
 
Feb 25, 2013
14
0
11
#4
No, the only "bigger" thing was changing some icons, over the theme folder..for me it works too, just sometimes these bugs apear..and i figured out, that most time the apps dont response after a notification..for example from facebook manager, i tap on the statusbar notification and nothing..then i tap on the app icon and it works. But sometimes the apps just wont start(example whatsapp, facebook, 9gag..)
 
Feb 25, 2013
14
0
11
#6
No :/ I want to try make a complete wipe, but then the problems were not so often, sometimes they come back for a while and nothing works, but i figured out, for me it just helps lock and unlock the phone, then are the most apps running, when not, lock and unlock helps..Maybe i make a complete wipe, but sincerely-I dont know how to make a complete whipe, i think both partitions(im getting lost in this :D )
 

ingbrzy

Xiaomi.eu Multilang leader
Staff member
Feb 11, 2012
8,813
20,625
322
#7
No :/ I want to try make a complete wipe, but then the problems were not so often, sometimes they come back for a while and nothing works, but i figured out, for me it just helps lock and unlock the phone, then are the most apps running, when not, lock and unlock helps..Maybe i make a complete wipe, but sincerely-I dont know how to make a complete whipe, i think both partitions(im getting lost in this :D )
you dont need make a full wipe of both /system partitions.. you need just wipe shared /data partition... just with simply wipe in MiRecovery... or use MiFlash... and install our ROM..
 
Feb 26, 2013
347
100
65
#10
kottel & Really_Wacky

Maybe ingbrzy is right and this can be an issue related to updater software. But to discard other things that maybe interfering in your diagnostics you may consider do a full backup and make an full wipe and try JLB ROM's that supposed to be more stable or the latest version avaliable of MIUI.

Please share your results:D
 
May 26, 2013
125
18
28
#11
What exactly do you mean by JLB rom? I only have my device for a week so i dont really understand what you mean :) I dont understand how a full wipe of the data partition can help? If it is ROM related should i wipe my system partitions?

Would it help if i made a logcat? i can easly do this since it happens every 10min :p but i dont know if you will see anything on it. And the first days i didnt have any problems i think i was at 3.5.31 at that moment. Maybe i should try to flash back to that first?
 
Feb 25, 2013
14
0
11
#12
Just wiped the data partition and cache, flashed MIUI over MiRecovery, then restored my backup..so far is all ok(just was getting a google play error, while updating/installing apps-deleted and re-entered account and all is good)
If a problem appears, i will inform you here.
And to the logcat, try it, I was not so lucky :) And with a logcat app I just dont see any problem there..
 
Feb 25, 2013
14
0
11
#13
And on your place, I would not downgrade the ROM-It was all ok for me too, and then the problem apear. When i was changing just to the other (older) system partition it was the same. So maybe it is really just the shared partiton.
 
Feb 26, 2013
347
100
65
#14
Really_Wacky

JLB and developers ROM

Weekly MIUI releases their ROM updates with bugfixes and other things that you can read in the changelog, but this ROM is the developer's version.

JLB otherwise is a more stable version of the ROM, but it's updated less often then developer version, could have less bugs etc.

The link to all ROM versions it's here
http://en.miui.com/thread-1885-1-1.html

You should consider to use CWM, it's more usefull and flexible that stock recovery, besides it's allow to wipe cache or Dalvik Cache.

Since you don't know your problem, the diagnostic should be easier if you keep away anything that could interfeer like the data partition, mods, tweaks and this kind of stuff to help you find and isolate the problem.

Logicat and other things may be helpful to developers or Xiaomi stuff, I'm just an user/modder of my ROM's and devices.
 
May 26, 2013
125
18
28
#15
Ok i installed clockworkmod recovery :) I wanted to do this from the beginning but ingbrzy advised against it for new users.

On my ZTE skate i allways used to do these wipes when i installed a new rom do i still do all of these:

”wipe factory/data > Yes”
”wipe cache > Yes”
”advanced > wipe dalvik cache> Yes”

”mounts and storage format /system” (I asume this is actually system 1)
”mounts and storage format /system1” (And this system 2)

I allready like that when i install a ROM it asks me what partition to write it to :) I am used to clockworkmod so i think i will keep using this instaid of the updater app :) And nandroid backups offcourse. Will it allways ask to disable recovery flash on system 1 and 2? Why does it even ask that doesnt the recovery go on the recovery partition not on system 1 or 2.

Anyway i did the 3 wipes above and installed "MIUI v5 Multi Lang 3.6.14" 2 times i am now restoring my backup i will let you know how it turns out :)

An other question i've read that you cant downgrade in some cases, when you have a nandroid of an older version cant you just restore that?

@Kottel: Did you perhaps update your keyboard?
 
May 26, 2013
125
18
28
#16
I think installing this caused the problem not sure tough :) its pretty enoying that there comes a red line under everything i type so i want to update the keyboard but i think its going to come back, i will just use it a day like this if i dont have the problem i will try to flash the keyboard if it comes back i know what the problem is.

https://play.google.com/store/apps/details?id=com.google.android.inputmethod.latin
 
Feb 26, 2013
347
100
65
#17
I think installing this caused the problem not sure tough :) its pretty enoying that there comes a red line under everything i type so i want to update the keyboard but i think its going to come back, i will just use it a day like this if i dont have the problem i will try to flash the keyboard if it comes back i know what the problem is.

https://play.google.com/store/apps/details?id=com.google.android.inputmethod.latin
Really_Wacky

I tested this keyboard for almost 1 week but didn't have any problems, but it's lack of resources make me back to the first 4.2 Stock keyboard, and in the latest version of WIUI Wajk put the optimized version of the same keyboard. I'm glad that you've found the problem.
 
Feb 25, 2013
14
0
11
#18
For me it is not so mutch the keyboard, I am using Swype, for a test I will change now to Android keyboard.
My problems are still there, facebook lags, cant open messenger app, when opening a link, blank icons..jeez o_O
 
May 26, 2013
125
18
28
#20
Actually, I am using the stock Android keyboard, and I have no problems..lets see how long it will be so :)

I just installed google keyboard from the link above still no problems, i hope they stay away!

I think doing the wipes in clockworkmod solved it :) if i where you i would also install clockworkmod its easy to install and it has a lot of nice features :)
 
May 26, 2013
125
18
28
#23
The problem is back :( the first time i notice is mostly when i am using facebook when i cant open notifications. When that happens i know my keyboard wont show up when sending messages and my buttons will be gone when i want to reboot.


I've allready had to reboot 3 times now in 1 hour it is really pissing me off and ruining the whole phone expirience.

I cant make a Logcat eighter since i dont have the drivers for the MI2 installed and and i cant find them anywhere. Adb keeps saying -waiting for device-

Sent from my MI 2