Can't Boot After Flashing Via Fastboot Mode


Feb 6, 2017
so, i tried this guide
"[Guide] Unlocking the Mi4c Bootloader without verification by Xiaomi"

firstly, i'm on latest official dev rom. then i tried "fastboot oem edl" and it succeed. then i tried to flash "libra_images 6.1.7 20151221.0000 11_5 1_cn_b09dac7 0a0" via fastboot mode. it also says success on miflash software. when i tried to boot it up. it shows nothing. just blank screen. tried to boot it up several times. hold the power button for 2 minutes or more. and still nothing happen. tried to enter fastboot. also give me nothing.
when i plug it to my laptop. still detected as RELINK HS-USB QDLoader 9008 (COM11). tried to google it. it says that my phone is on download mode. don't know what to do. then i tried to flash latest official stable fastboot rom via miflash. goes succeed. but still. my phone cannot reboot. just blank screen. and when i connect it to my laptop. it detected as RELINK HS-USB QDLoader 9008 (COM11) on device manager.

so? what happen to my phone. and what is the solution?

sorry, no link. have not reach 10 post

edited :
resolved after holding power button + vol down for few minutes. entered fastboot mode. and then it could powered up like normal. i feel dump at this state.
Last edited: