New Can't Set Apn: Access Point Name Settings Are Not Available For This User

Discussion in 'Bugs' started by SirJohnDoe, Apr 14, 2015.

  1. SirJohnDoe

    SirJohnDoeMembers

    Apr 29, 2014
    2
    0
    11
    Male
    Device: Xiaomi Mi2s
    Version: 5.4.10

    Just did a fresh install of this version (using MiFlash), after having Mokee rom for a while. But everything works except setting the APN. I already tried rebooting, taking the sim out and putting it in again (with reboots), turning off data and enabling it after 30 secs, changing mode (3g-->2g), etc. but I still can't do anything about it. Anyone got a suggestion?

    [​IMG]
     
  2. SirJohnDoe

    SirJohnDoeMembers

    Apr 29, 2014
    2
    0
    11
    Male
    It took a few hours, but I figured it out.

    Step 1. Root your Xiaomi (I used this guide: http://www.cnet.com/how-to/how-to-easily-root-an-android-device/), if it says it's already rooted, but it isn't, just re-root it.
    Step 2. Install a root file manager
    Step 3. Open it, and go to the root (Should have folders like acct, bin, cache, config, data etc.)
    Step 4. Go to Data --> Data --> com.android.providers.telephony --> databases
    Step 5. Delete the telephony.db file
    Step 6. Your phone will give 1 or 2 errors, but the file will be generated anew and you can add an APN (even if it still displays the message).
     
  3. villy skov

    villy skovMembers

    Aug 25, 2014
    5
    0
    11
    Male
    I have the same error, The phone is rooted, Kingo ROOT said Root Succeeded

    On my MI2S there is no folder in Data -->

    If i try to create a folder then "operation failed". Run Android 5.02 and MIUI 5.4.24

    Any suggestions, really need data.
     
  4. villy skov

    villy skovMembers

    Aug 25, 2014
    5
    0
    11
    Male
    Great, it was a root tool problem.

    Now it works with this method.

    Thanks to SirJohnDoe, you made my day and week!!!
     

Share Our Site