Clock Not Updating, Alarm Not Ringing


64KRAM

Members
Dec 19, 2016
27
15
Yes the Miui Clock is not working in my case, which is already a system app.

Both Miui Clock and Google Clock alarms didn't work this morning.

I already tried the following, but none have worked:

Settings > Battery & Performance > Manage apps battery usage > Off (also I have set apps individually to Off)
Settings > Battery & Performance > Power > Battery Saver > Off
Settings > Permissions > Autostart > Apps have been set to to autostart
Settings > Additional Settings > Developer Options > Memory optimization > Off
Settings > Additional Settings > Developer Options > Miui optimization > Off

There is only other setting I can see that may be affecting this, but I have yet to test this:

Settings > Battery & Performance > Power > (Settings Button) > Clear cache when device is locked.

This was set to 30 minutes. I have now turned it off. I will report back if this makes a difference.

Locking apps in the task list is not a suitable fix as it is still possible to close them by manually swiping.

Also I confirm I have no 3rd party battery saving apps installed. No Greenify, Amplify etc.
 
  • Like
Reactions: Stefano131270

AsadP

Members
Oct 26, 2016
131
40
Try to dirty flash the same version ROM on top and try an alarm straight away.
 

ingbrzy

Xiaomi.eu ROM leader
Staff member
Feb 11, 2012
11,039
322
I guess you are using any "Ultra super mega real magic battery saver app" like Greenify and others ***
 
Last edited:
  • Like
Reactions: AsadP

doppelganger

Members
Dec 9, 2016
5
13
I'm facing the same problem on my Redmi 3S (land) on last week's ROM.
I turn my phone into airplane mode over night and the alarm doesn't start in the morning.

I can't speak for the others, but I don't have any "Ultra super mega real magic battery saver app" installed.
I'm curious what 64KRAM's experiment with "Clear cache when device is locked" will bring.

My current workaround is to use the Google clock app, which gives reliable alarms (with the correct autostart etc. settings).
I'd very much prefer to have a working system clock app though...
 

64KRAM

Members
Dec 19, 2016
27
15
I will let you know if I wake up on time tomorrow :)

I also don't use any battery saving apps, as I have already said.

Battery life is great on this phone, even with all Miui power saving off, very impressive!
 

64KRAM

Members
Dec 19, 2016
27
15
For the last two days the Miui alarm has worked with this setting disabled:
  • Settings > Battery & Performance > Power > (Settings Button) > Clear cache when device is locked = Never
I'll test for another week to make sure. Hopefully it is the fix we have been looking for.

If you're experiencing alarm problems try this setting!

I'm trying to find information about what this setting does specifically, but I haven't found anything yet. Eg: does this completely close apps after [x] minutes of the screen being locked? How does this work with other Miui settings like app battery saver, autostart etc?

Maybe this setting could be affecting other app notifications?
 
Last edited:

UnderTheGun

Members
Jan 22, 2017
57
20
Same problem here :(...
Redmi 4 prime and Xiaomi.EU 8.1 / 8.1.3.0

No greenify, no amplify.
Already tried all possible solution...
 

doppelganger

Members
Dec 9, 2016
5
13
@64KRAM Did the mentioned setting help with the Google or MIUI clock for you?
I have also tried it out but it didn't fix my MIUI clock (and my Google clock has always been working...).

I have some doubts about applying very "global" settings like "Miui optimization > Off"...
 

64KRAM

Members
Dec 19, 2016
27
15
Me too, if turning off Miui Optimization had solved the problem I would have considered it a bug, not a permanent fix.

Please see my previous response - it has been 3 days now and my alarm has worked every morning.

However I haven't turned any of the other power settings back on yet.

I will continue to test, and have my old Moto G2 next to my bed as a backup alarm clock, just in case!
 

Voyager

Members
Dec 20, 2016
8
15
I read of some other solution. Installing WSM-Tools for Xposed. There should be an option called Alarmtime-Fix. Allow Alarmtime-Fix in Autostart. This worked for some people.
 

UnderTheGun

Members
Jan 22, 2017
57
20
I guess, crossing the finger, I solved!
This morning alarm clock worked, finally!!
I had already tried all solutions proposal: turn off every battery saver and optimization etc etc...but what worked for me is:
1)Turn ON "Miui optimization" under developer option
2) back to default Miui theme (I know, it's crazy!)

Now I have to investigate on what options I can reset to ON and if this morning was just a lucky coincidence. :)

Back soon.
 

64KRAM

Members
Dec 19, 2016
27
15
This morning it stopped working again - my alarm was set for 6:00am, but it only appeared / started ringing when I manually turned on the screen at 6:12am.

The only thing that has changed is I rebooted the phone yesterday. No settings have been changed, no apps installed or uninstalled.

I now have every power saving and memory management option I can find switched off and it still doesn't work.

Back to square one...

@Voyager - thank you for the suggestion, I will give it a go!
 

64KRAM

Members
Dec 19, 2016
27
15
I installed the WSM-Tools APK but it says it isn't compatible with the Mi5s: "WSM is not (yet) compatible with Android SDK version 23 or your processor architecture (arm64-v8a)". So I didn't install the flashable .zip, for fear I'd end up in a boot loop...

But I was able to use the app to download the "Alarmtime-Fix" module, which can be activated in Xposed.

I'm going to re-enable all other options now, as they obviously haven't fixed the problem.

Let's see what happens in the morning!
 
Last edited:

64KRAM

Members
Dec 19, 2016
27
15
Unfortunately it did not fix the MIUI clock alarm.

However it did fix the Google clock for me, so I at least have a reliable alarm clock now.

I have given up on trying to fix the MIUI alarm clock, and will also be doing a full wipe when the next non-buggy ROM is released.
 

doppelganger

Members
Dec 9, 2016
5
13
I did a full wipe and flashed the latest ROM last weekend. And surprisingly, the MIUI alarm has worked every morning since then. I didn't even need to apply special settings to the app...
 

Michel Merlin

Members
Sep 3, 2020
2
3
SOLVED!
Turned off background app battery optimization
THIS did work for me! Thanks a lot.
My system:
Phone: Redmi Note 7​
Android 10 QKQ1.190910.002​
MIUI version: MIUI Global 11.0.1 Stable 11.0.1(QFGMIXM)​
How I fixed it:
Android > Home > Settings > Battery and performance > App battery saver > Clock​
In this "Clock" item:
- "Battery saver (recommended)" was checked.​
- "No restrictions" is what I selected instead.​
Versailles, Thu 03 Sep 2020 16:51:35 +0200