Confirmed Ethernet Adapter Doesn't Work

Discussion in 'Xiaomi Mi Box / Mi TV' started by toot-217, Jan 26, 2017.

  1. toot-217

    toot-217Members

    Dec 24, 2016
    5
    0
    13
    Male
    Hey guys,

    Couple of weeks ago I got my Mibox (MDZ-16-AB) and I've to say its a nice piece of hardware, almost everything works like I expected.

    Now I wanted to attach a USB - Ethernet adapter to my box, because my WiFi isn't the best one (crappy provider restricted Router) and bought a first device from Anker, (similar to this one:
    https://www.anker.com/products/A7522012
    (article-no: AK-848061018783)

    But no big surpise, it was incompatible and weht back to amazon.

    Also it didn't work with my LG G3 or Nexus 10 (both running Android 6).


    After that I started to do some research and I came up with the info, that a adapter with a specific chipset, to be exact the Asix AX88772, should be the best choice.

    So i ordered an adapter from the (for me unknown at the moment) company ugreen:
    https://www.amazon.com/Ugreen-Network-Adapter-Windows-B00LLUEJF0/dp/B00LLUEJF0

    Interesting, it worked on my Nexus 10, but not on my other two devices.
    It seemed that the adapter hasn't got any power connected to my Mibox, the status LEDs for the Ethernet connection stayed dark, not even the USB hub worked.
    Weird behavior, but I spend no second thought on this and shipped the device back to Amazon.

    So, i was still looking for a working adapter and i got slightly frustrated, how can it be so difficult?

    I went to amazon.com (actually I'm from Germany, but there are hardly an useful reviews regarding the compatibility with a Mibox) and started searching.

    There was a box, also from.ugreen which had many different, but reliable appearing reviews, many mentioning the Mibox:
    https://www.amazon.com/UGREEN-1000Mbps-Gigabit-Ethernet-Compatible/dp/B00LLUEJFU

    This time I was sure, this is gonna be a adapter, which will work as I imagined, so I orderered it and held it two days later in my hands.

    But when I attach t to the Mibox and the Ethernet cable, theres again no light on the status LEDs, and USB hub isn't working too.

    I don't know what else I could try, this last adapter is working with my PC (Windows 10) but none of my android devices is compatible with the Ethernet adapter.

    I attached a couple of photos which are showing the adapter attached to my Mibox, my Nexus 10, my PC and a "test" of the USB port of the Mibox.
     

    Attached Files:

  2. bico70

    bico70Members

    Dec 9, 2016
    15
    0
    11
    Male
    Many thank's Toot for you report anyway...i have the same problem, thinking to buy a Nvidia Shield and move the MiBox on sale
     
  3. Dave Deluria

    Mar 1, 2017
    27
    1
    5
    Male
    I have also gone this route of trying USB to Ethernet adapters. You will find out the USB of the Mi Box is just too slow.

    Your best solution as what I did is to buy a new Wifi router that supports dual band (2.4Ghz & 5Ghz). My ISP also put a restricted wifi device BUT I just bridged the new router to the existing one and disabled the wifi completely on my ISP provided box. 5Ghz wifi connection of the Mi Box will yield 50~80Mbps while USB to Ethernet will max out at 25Mbps.

    There is a reason why wifi routers can be cheap while others exhorbitantly expensive. In my case I bought a mid-level TP-Link C7 Archer that works well on 5Ghz to stream data to the Mi Box
     
  4. Dave Deluria

    Mar 1, 2017
    27
    1
    5
    Male
  5. Vispen74

    Vispen74Members

    Mar 16, 2017
    2
    0
    1
    Male

Share Our Site