Could someone help me with my bricked Mi A3?


DokiDokiMagikku

Members
Jan 1, 2020
1
3
I tried to install Pixel Expirience. I messed very many things up, and when I did install that ROM, the sound, Wi-Fi, mobile data, and the microphone all stopped working. So I formatted my Mi A3 using fastboot -w (or something similar) and I when I try to boot it, it shows Android One screen for like a half a second (it doesn't show Mi logo) and then it boots up to Fastboot screen with the Mi Bunny... My phone was before the brick on December security patch. I tried: flashing everything manually with fastboot, I tried Mi Flash, and I tried the flashall.bat. Could someone please give me any tips on what to do?

~Jakub. Sorry for bad English.
 

tsongming

Members
Feb 12, 2019
77
30
just now seeing this, if you still have the issue let me know and I will give you instructions.

If you are hard bricked, and have corrupted partitions: You just need to flash the stock rom, the easiest method is flashall.bat. Let me know if you need specifics.

If you have fastboot, simply flash TWRP, boot to TWRP recovery, do a full wipe, including formatting using data. Reboot to TWRP ( check boxes to install TWRP manager - if you see that screen)

Once rebooted to TWRP Recovery, Flash Rom of Choice, Gapps if needed, Flash Magisk again. Boot to system and setup.
 
  • Like
Reactions: Besoz

Besoz

Members
Mar 15, 2020
9
3
Boot in fastboot and flash stock rom again. Don't forget to check *clean all*, not *clean all and lock*. After installing stock rom, you can install twrp and pixel again