Do I need magisk hide props for latest magisk canary version?


Dec 3, 2020
868
182
[I'm "moving" this post here as it seems to fit better in this section rather than mi general section.]

Hello, I'm thinking of updating magisk to the latest canary version after staying for a long time on the May version. Does anyone know if I'll have to use magisk hide props? Currently I ~don't need it (because the xiaomi.eu team already ~"fixes" it for us in the rom) and I'm passing safetynet.



I also have some extra questions I posted on reddit, which I'm copy pasting them below in case anyone wants to answer anything:

1) Magisk hide has been downgraded to magisk denylist. But with the latest universal safetynet fix module and zygisk support, it seems like hiding magisk is even better now. Is that correct?

2) Will zygisk cause any issues with lsposed and riru? I think I read that they recently got updated to be compatible with latest magisk version, but wanna verify it first.

3) What about the magisk modules repository? Newer versions ~don't have that anymore. Is there any module I can use to bring it back? How am I going to know when a module has an update? Will I have to check the github page of ~every module? (Btw, the repository still appears on older versions and seems to be available also here: https://magisk.download/category/guide ).

My installed modules are:

1controller
ACC (advanced charging controller)
Busybox (ndk)
DJS (daily job scheduler, for ACC)
Lucky Patcher module
Riru
Riru - lsposed
Sui (I have it deactivated)
Systemless hosts (for adaway)

In LSPosed I also use those modules:

Lucky Patcher
Customiuizer
XprivacyLua
 

katerpanne

Members
Apr 19, 2014
2,141
332
if you pass safety net already why to use the props?

the other questions I cant answer, I am on v23 :)

@Poney70 wrote something to the new features
 
Dec 3, 2020
868
182
if you pass safety net already why to use the props?

the other questions I cant answer, I am on v23 :)

@Poney70 wrote something to the new features
I'm asking if I can avoid using them on the latest canary version. (Haven't tried updating and seeing myself cuz it may take me sometime to downgrade and have it ~as it was.):emoji_sweat_smile: