Invalid Fastboot loop with MI 8 SE


FireJeff

Members
Sep 7, 2018
86
20
Hello everyone,

I tried to update the new stable version of xiaomi.eu (10.2) using the updater app.
After that, the phone doesn't want to start and is stucked in fastboot. I can't ever boot with twrp.
Could you help me ? I'm not the only one with this issue.

Thanks
 

FireJeff

Members
Sep 7, 2018
86
20
[02:13:04 63bbd6ac]:MiFlash 2017.4.25.0
[02:13:04 63bbd6ac]:image path:C:\Users\Jeremy\Desktop\sirius
[02:13:04 63bbd6ac]:env android path:"C:\XiaoMi\XiaoMiFlash\Source\ThirdParty\Google\Android"
[02:13:04 63bbd6ac]:script :C:\Users\Jeremy\Desktop\sirius\flash_all_except_storage.bat
[02:13:04 63bbd6ac]:physical Memory Usage:2019328 Byte
[02:13:04 63bbd6ac]:$fastboot -s 63bbd6ac getvar product 2>&1 | findstr /r /c:"^product: *sirius" || echo Missmatching image and device
[02:13:04 63bbd6ac]:'findstr' n'est pas reconnu en tant que commande interne
[02:13:04 63bbd6ac]:flash done
[02:13:04 63bbd6ac]:flash done
[02:13:04 63bbd6ac]:process exit.
[02:13:04 63bbd6ac]:flashSuccess True
[02:13:04 63bbd6ac]:isFactory False CheckCPUID False
[02:13:04 63bbd6ac]:before:flashSuccess is True set IsUpdate:True set IsDone True
[02:13:04 63bbd6ac]:after:flashSuccess is True set IsUpdate:false set IsDone true
 

FireJeff

Members
Sep 7, 2018
86
20
from your log report, you are not flashing the "good" rom version.
I see that. I've downloaded here : the china stable rom V10.0.1.0.OEBCNFH | Fastboot

Maybe it's because of 'findstr' ? I don't know what is it ?

Edit : I got the same with your rom...
 
Last edited:

FireJeff

Members
Sep 7, 2018
86
20
Maybe I found the solution here.
I removed with gvim the two first lines of the .bat files. Seams to work for now.

fastboot %* getvar product 2>&1 | findstr /r /c:"^product: *sirius" || echo Missmatching image and device
fastboot %* getvar product 2>&1 | findstr /r /c:"^product: *sirius" || exit /B 1
 
Last edited:
  • Like
Reactions: waullsm22

LOLO9393

Members
Feb 8, 2016
599
82
That's why you can't flash TWRP as well. Vendor partition has may been corrupted and doesn't reflect the good product numbering.
This would be good to be understood for our knowledge.
Confirm if solved.
 

FireJeff

Members
Sep 7, 2018
86
20
Hello LOLO9393,

I can flash twrp now, but after installing xiaomi eu, I'm stuck with MI logo. (I swipe everything, but not working anyway)
I've got the same after having flash the stable version of mi ui. I don't know what to do...
 

FireJeff

Members
Sep 7, 2018
86
20
Ok. I succeeded to install the china stable rom V10.0.1.0.OEBCNFH Recovery version with twrp.
It worked well after formating everything and reparing system file.
I'm trying right now with xiaomi eu...
 

LOLO9393

Members
Feb 8, 2016
599
82
Ok. I succeeded to install the china stable rom V10.0.1.0.OEBCNFH Recovery version with twrp.
It worked well after formating everything and reparing system file.
I'm trying right now with xiaomi eu...
STOP!
issue are reported on main thread.
In meantime I tested Mirum and Masik1.9. they are both OK but you have to stay in english at daily use
 

FireJeff

Members
Sep 7, 2018
86
20
Ok, I will wait a little bit then before updating. Thanks.
Sorry I didn't wait. I did the update, and it work well. No bug for now. No fastboot loop.
I had to download manually the rom from xiaomi.eu to copy it inside internal storage, and then I used updater app.
 
  • Like
Reactions: LOLO9393

biessea

Members
Dec 12, 2018
26
5
I updated from the settings of the phone, having downloaded the 10.2.2 MIUI Stable and then update by the package.
It seemed to work but then when it enters for the first time phone gave me 2 errors and then rebooted automatically and then the only thing I can see is the fastboot logo, I tried everything manually but every time that boots phone came in fastboot logo.
How can I exit from this bad bad situation?

I'm really sad and angry that ROM not perfectly bug-free can developed in official EU sites.
 

LOLO9393

Members
Feb 8, 2016
599
82
I updated from the settings of the phone, having downloaded the 10.2.2 MIUI Stable and then update by the package.
It seemed to work but then when it enters for the first time phone gave me 2 errors and then rebooted automatically and then the only thing I can see is the fastboot logo, I tried everything manually but every time that boots phone came in fastboot logo.
How can I exit from this bad bad situation?

I'm really sad and angry that ROM not perfectly bug-free can developed in official EU sites.
If nothing is bootable, just fastboot, only solution is official fastboot rom via MIFLASH.
Then try again to flash your rom with 1227 twrp. Not sure that work well. In this case you've better to go with DEV rom 9.2.15 as starting point.
If you turn back again to fastboot only solution is to go back to earlier rom version as done here:
https://xiaomi.eu/community/threads/9-2-28-9-3-1.49424/page-16
Post 393
 

biessea

Members
Dec 12, 2018
26
5
Unofertunately I don't know why but TWRP 3.2.3 doesn't work on my phone.

I flashed, I booted and nothing appears.

My device is unlocked, I just checked through Mi unlock.

The only way I can do is flashing EU version through fastboot. Any link???

I just flashed the CN version of MIUI 10.2.2 and it works. But I don't want the CN version.

I really hope someone can find my links for MIUI 10.2.2 or 10.2.1 EU version for FASTBOOT.
 

LOLO9393

Members
Feb 8, 2016
599
82
Unofertunately I don't know why but TWRP 3.2.3 doesn't work on my phone.

I flashed, I booted and nothing appears.

My device is unlocked, I just checked through Mi unlock.

The only way I can do is flashing EU version through fastboot. Any link???

I just flashed the CN version of MIUI 10.2.2 and it works. But I don't want the CN version.

I really hope someone can find my links for MIUI 10.2.2 or 10.2.1 EU version for FASTBOOT.
You say twrp 3.2.3 but what version? 1227? may be.
You must use 1102 or 1217 with late stable!
https://drive.google.com/drive/folders/1IeCtb6vRO4CRe76s0BD_5TQiSnymPBTT
Note: EU rom are for TWRP use only. read first page at download.