Fresh twrp asking for password


ElGris

Members
Jul 17, 2021
4
13
hello, I am having some teething issues with my new phone.
It is a k20 pro, I installed the 12.5 version of the eu rom and magisk. I found out that banking apps dont work with magisk, at least for me they didnt, even when both magisk itself was hidden and I added the bank app to "magiskhide" list.

I removed magisk as my banking app is something I need to be able to access.
Removing magisk worked and things seemed fine.

I found a cool boot animation and wanted to install that. The most simple guide I found was to install it using twrp. When I booted into twrp it asked for password to decrypt data. I have had my phone less than 3 full days and been on this rom less than 30 hours. The only 2 passwords of any kind on my phone are the lockscreen pin and my mi account password. Neither of those work nor did the suggestions I found searching online myself ( password/default_password)

I used the "MiTool v2" to do a fresh install, ensuring I had the latest version of twrp and the same problem exists. Even on a fresh install of twrp it still asks me for a password. As mentioned I havent had this phone long so I dont stand to lose that much if I need to format it but the first things I have done with my phone are get the banking app working and registered and created my own custom theme and my own layout with nova launcher. Not a huge deal but ideally I would like to avoid having to start from scratch again. Thanks
 

LOLO9393

Members
Feb 8, 2016
2,905
322
hello, I am having some teething issues with my new phone.
It is a k20 pro, I installed the 12.5 version of the eu rom and magisk. I found out that banking apps dont work with magisk, at least for me they didnt, even when both magisk itself was hidden and I added the bank app to "magiskhide" list.

I removed magisk as my banking app is something I need to be able to access.
Removing magisk worked and things seemed fine.

I found a cool boot animation and wanted to install that. The most simple guide I found was to install it using twrp. When I booted into twrp it asked for password to decrypt data. I have had my phone less than 3 full days and been on this rom less than 30 hours. The only 2 passwords of any kind on my phone are the lockscreen pin and my mi account password. Neither of those work nor did the suggestions I found searching online myself ( password/default_password)

I used the "MiTool v2" to do a fresh install, ensuring I had the latest version of twrp and the same problem exists. Even on a fresh install of twrp it still asks me for a password. As mentioned I havent had this phone long so I dont stand to lose that much if I need to format it but the first things I have done with my phone are get the banking app working and registered and created my own custom theme and my own layout with nova launcher. Not a huge deal but ideally I would like to avoid having to start from scratch again. Thanks
If i well understand your issue:
Password for TWRP access is the same as your main PW. pin.
 

gkalen

Members
Oct 23, 2020
425
87
hello, I am having some teething issues with my new phone.
It is a k20 pro, I installed the 12.5 version of the eu rom and magisk. I found out that banking apps dont work with magisk, at least for me they didnt, even when both magisk itself was hidden and I added the bank app to "magiskhide" list.

I removed magisk as my banking app is something I need to be able to access.
Removing magisk worked and things seemed fine.

I found a cool boot animation and wanted to install that. The most simple guide I found was to install it using twrp. When I booted into twrp it asked for password to decrypt data. I have had my phone less than 3 full days and been on this rom less than 30 hours. The only 2 passwords of any kind on my phone are the lockscreen pin and my mi account password. Neither of those work nor did the suggestions I found searching online myself ( password/default_password)

I used the "MiTool v2" to do a fresh install, ensuring I had the latest version of twrp and the same problem exists. Even on a fresh install of twrp it still asks me for a password. As mentioned I havent had this phone long so I dont stand to lose that much if I need to format it but the first things I have done with my phone are get the banking app working and registered and created my own custom theme and my own layout with nova launcher. Not a huge deal but ideally I would like to avoid having to start from scratch again. Thanks
You have to use pattern on fingerprint , not a pin number cause twrp cannot decrypt storage .. just change your pin numbers to a pattern ..
 
  • Like
Reactions: LOLO9393