Google Maps not working


Sep 3, 2018
9
6
5
#1
Hello,

since a few weeks (approximately 2 or so) Google Maps isn't working properly anymore. Everything is fine opening the App and panning and zooming around. But the moment I try to start the navigation to a destination (no matter what) it freezes and force closes. I already tryed to reinstall the app with no success.

Is anyone facing the same problem and has a solution?

It would be really nice if Google Maps started working again as I use it with Android Auto to get around in car.

Im on the latest Weekly Xiaomi.eu MUI 10.1 ROM.
 
Dec 2, 2017
516
135
82
#2
I've had this exact problem since a few versions back, and also on my Mi Note 2, and folks have had it on the Mi5.
All sd 821 phones of the same generation.
Except for me Maps just freezes, no fc.

It works for me sometimes, no obvious trigger.
Sometimes it works directly, sometimes after a few tries, sometimes never.
It will always work if I choose "pedestrian"

Someone even posted a logcat a few versions back, but the devs have never reacted.

It works fine in my old Max1 Prime helium, which is the one I use anyway for maps in the car, so I have not been handicapped.
 
Likes: speedst3r
Sep 3, 2018
9
6
5
#3
I also observed that it sometimes works but most of the time it doesn't. I tried pedestrian and it works perfectly fine as you said. That's a really weird behavior. Maybe it has something to do with the kernel if it's present on all the QSD 821 Phones.

The weird thing is, that it worked fine before. So something must have been changed, either on Googles site or on the ROM's side.

Do you know how I can get in contact with a dev to help fix this issue? I mean if it's a problem on all the QSD 821 Phones it has to be something bigger. Also it kinda ruins the experience running the otherwise incredibly good ROM.
 
Dec 2, 2017
516
135
82
#4
I also observed that it sometimes works but most of the time it doesn't. I tried pedestrian and it works perfectly fine as you said. That's a really weird behavior. Maybe it has something to do with the kernel if it's present on all the QSD 821 Phones.

The weird thing is, that it worked fine before. So something must have been changed, either on Googles site or on the ROM's side.

Do you know how I can get in contact with a dev to help fix this issue? I mean if it's a problem on all the QSD 821 Phones it has to be something bigger. Also it kinda ruins the experience running the otherwise incredibly good ROM.
There is no guaranteed way to get the attention of a dev.

You could start a thread in the Bugs section, but the few times I have done that no-one has reacted.

I did try doing a clean install once on my Note 2, not this curremt version.
That did not help,
 
Sep 3, 2018
9
6
5
#5
There is no guaranteed way to get the attention of a dev.

You could start a thread in the Bugs section, but the few times I have done that no-one has reacted.

I did try doing a clean install once on my Note 2, not this curremt version.
That did not help,
Okay, i'll try this on the weekend when I have time to do a detailed post in the bugs section.

But im really thanful for your advice!
 
Dec 16, 2016
4
2
15
#7
I am having the same Issue with Maps, you can set the destination and as soon as you start driving it's not responding and close. I have Mi Mix and having the same Issue on my Samsung Note 9 as well. All the other apps Sygic and Waze working fine.
 
Sep 3, 2018
9
6
5
#8
I am having the same Issue with Maps, you can set the destination and as soon as you start driving it's not responding and close. I have Mi Mix and having the same Issue on my Samsung Note 9 as well. All the other apps Sygic and Waze working fine.
Yeah, Waze works fine for me too. But if you face the same problem with your Note 9 it may be a issue on Google's site. I wonder if Google is trying to fix this problem...
 
Likes: cobben
Dec 6, 2018
2
0
3
#9
I have the same problem in my mi5s, and I found that the problem appear when connect maps to Spotify for control music. I delete maps to Spotify connection and maps is working again, also Spotify can play music in background with no problem and for change tracks I use the notification panel.
 
Dec 16, 2016
4
2
15
#10
I have the same problem in my mi5s, and I found that the problem appear when connect maps to Spotify for control music. I delete maps to Spotify connection and maps is working again, also Spotify can play music in background with no problem and for change tracks I use the notification panel.
I have Spotify as well let me unlink it and see if it makes any difference.
 
Sep 3, 2018
9
6
5
#12
After the newest ROM Version it works fine again so it seems to be fixed. I still have my Spotify Account linked and it works like a charm again
So after working once, in the next app start it wouldn't work again and crash as soon as i start the navigation, so it was a false positive... would be really nice if this could be fixed!
 
Sep 3, 2018
9
6
5
#14
I just update today the maps are working its not crashing even with spotify linked, now have to go out n actually drive somewhere to actually test it.
It was the same behavior on my end. Driving to work it worked perfectly fine. But driving home it did crash again. I downloaded a offline map while being at work, maybe it's because of that, idk? But for me this is just not wirking because sometimes you need guidance to be reliable and working. So until this is fixed I have to use Waze instead, their app is working perfectly fine and reliable.
 
Likes: sakura10