[GUIDE][JB 4.1.2/JB 4.2.2/Common] Definitive FAQ for newest miui porting

tal noah

Oct 11, 2012
Stage 1. Initial port
Let's start with first step - bases choice.
Under base I will mean rom which could be used to port miui and also miui release you choose.
Let's assume - just "Base" will mean rom for your device with Jelybean 4.1.2/4.2.2, such as Cyanogen Mod, AOKP or AOSP and their variations (I don't know if it is possible to use stock rom for porting and wouldn't recommend it), "MIUI base" means any miui rom you prefer (my preference and advice - MiuiAndroid Mako [Nexus 4] or MiuiAndroid maguro (Galaxy Nexus) release). Or if on 4.1.2 use a device such as MiuiAndroid Crespo (Nexus S)
In the guide I will describe steps right for you with mark "4.1.2 or with 4.2.2".
If for you version number is crucial - stop reading this guide and just use PatchROM (though rom will be based on Stock rom).
There is third variant, but it needs a device with nearly same specs:
you might just replace some files in miui-supported device rom with files from your stock rom.

When base choosen, start to port:
Copy unpacked base rom (so set of folders) to any folder you prefer (let's name it "MIUI"), it usually contains:
  • system - folder on which we will work more often
  • data - may contain something necessary such as first boot scripts, config files etc.
  • META-INF - contains certificates and signature for signcheck, updater-script(we also will work on it) update-binary (updater-script command processor)
  • boot.img, kernel and ramdisk packed together.
Starting with system:
  • app
  • framework
  • media
  • fonts
then open miui base and extract those folders to base. Don't close archive.
Open lib folder in system to add the following files to base from miui base:

  • content-types.properties
  • libFreqFilter.so
  • libaudiofp.so
  • libffmpeg_xm.so
  • libffplayer_jni.so
  • libimageutilites_jni.so
  • libjni_resource_drm.so
  • liblbesec.so
  • liblocSDK_2.5OEM.so
  • liblocSDK_2_5OEM.so
  • libmp3lame.so
  • libpatcher_jni.so
  • libphotocli.so
  • libshell*.so
Open etc folder in system to add to base:


go to permissions folder in etc to add:

  • com.nxp.mifare.xml [NFC]
  • com.google.android.media.effects.xml [gallery]
  • com.google.widevine.software.drm.xml [something also related to google may affect play market]
  • com.google.android.maps.xml [gmaps]
Open xbin folder in system to add to base:
  • su [replace, don't even use base one!]
  • shelld [Important for shell services] Also Devices which don't have NFC(Near Field Communication chip) also shouldn't have Nfc.apk in app folder! Devices that do use your own!
Let's modify build.prop of the base, add:

ro.build.version.incremental points to MIUI you port, so specify it.
At your base you will most likely see these lines

are filled with ringtones that only base have, soo just change them as MIUI do have different ringtone set.
Initial port done, in system part, let's talk about Updater-script:
any release of miui you port should have that line:
set_perm(0, 0, 06755, "/system/xbin/shelld");​

for example you have that bunch of code [which is mostly common for CM10/10.1 releases]:
set_perm_recursive(0, 0, 0755, 0644, "/system");​
set_perm_recursive(0, 2000, 0755, 0755, "/system/bin");​
set_perm(0, 3003, 06755, "/system/bin/ip");​
set_perm(0, 3003, 02750, "/system/bin/netcfg");​
set_perm(0, 3004, 02755, "/system/bin/ping");​
set_perm(0, 2000, 06750, "/system/bin/run-as");​
set_perm_recursive(1002, 1002, 0755, 0440, "/system/etc/bluetooth");​
set_perm(0, 0, 0755, "/system/etc/bluetooth");​
set_perm(1000, 1000, 0640, "/system/etc/bluetooth/auto_pairing.conf");​
set_perm(3002, 3002, 0444, "/system/etc/bluetooth/blacklist.conf");​
set_perm(1002, 1002, 0440, "/system/etc/dbus.conf");​
set_perm(1014, 2000, 0550, "/system/etc/dhcpcd/dhcpcd-run-hooks");​
set_perm(0, 2000, 0550, "/system/etc/init.goldfish.sh");​
set_perm_recursive(0, 0, 0755, 0555, "/system/etc/ppp");​
set_perm_recursive(0, 2000, 0755, 0644, "/system/vendor");​
set_perm_recursive(0, 2000, 0755, 0755, "/system/xbin");​
set_perm(0, 0, 06755, "/system/xbin/librank");​
set_perm(0, 0, 06755, "/system/xbin/procmem");​
set_perm(0, 0, 06755, "/system/xbin/procrank");​
set_perm(0, 0, 06755, "/system/xbin/su");​
set_perm(0, 0, 06755, "/system/xbin/tcpdump");​
set_perm_recursive(0, 0, 0755, 0644, "/system/vendor/firmware");​
set_perm(0, 2000, 0755, "/system/vendor/firmware");​
set_perm_recursive(0, 0, 0755, 0555, "/system/etc/init.d");​

So line I pointed should be somewhere there, for example:
set_perm(0, 0, 06755, "/system/xbin/librank");
set_perm(0, 0, 06755, "/system/xbin/procmem");
set_perm(0, 0, 06755, "/system/xbin/procrank");
set_perm(0, 0, 06755, "/system/xbin/shelld");
set_perm(0, 0, 06755, "/system/xbin/su");
set_perm(0, 0, 06755, "/system/xbin/tcpdump");

IF you have problems with SU, that line may help:
symlink("/system/xbin/su", "/system/bin/su");​

paste it somewhere after

symlink("busybox"[later big code bunch like "/system/xbin/[" etc]

but before


Finally the Boot.img (Different for 4.1.2 and 4.2.2)

For 4.1.2 and 4.2.2 you will have to know how to unpack and repack your boot.img so you can edit your ramdisk.
Use dsixda's Android Kitchen located here: http://forum.xda-developers.com/showthread.php?t=633246. Once unpacked, you will have to make edits in your init.rc file and default.prop

For 4.1.2 and 4.2.2 there are two common edits needed. One is adding shelld to your main class located at the end of the file. Another is editing your default.prop. You will see where it goes when you open the file. Add the following to your init.rc at the end with other main classes:

service shelld /system/xbin/shelld
class main

For the second edit, you will need to modify your default.prop. Change your ro.secure line to:


Then, you will need to delete the following line:


Thats all for 4.1.2!! Repack your boot.img and your good to go!!
If you are 4.2.2 you will need one more edit in your init.rc bootclasspath.
You will have to add the following in between two references:


Add that in between :/system/framework/android policy and :/system/framework/mms-common

so it should look like this:

:/system/framework/android policy:/system/framework/framework_ext.jar:/system/framework/mms-common

And your 4.2.2 boot.img is done!!!!

**Remember you need two edits in 4.1.2 and three edits in 4.2.2**
Your own MIUI is now ready to be flashed, but only if your device is SOOO near on hardware part with MIUI base.

For those who dont meet the rule I prepared the next part - framework mods and common debugging and troubleshooting. See next the two posts.

tal noah

Oct 11, 2012
Stage 2. Framework mods to make it boot
Rom not booting? - that is most likely a framework issue, that is remained from Nexus S/Galaxy Nexus. But don't run to base to grab all framework and paste it to base, else you will have a base rom instead of miui

My suggestion is port.
For those who are new in apktool disassembling, I suggest to read something like that http://forum.xda-developers.com/show....php?t=1511730 or that http://forum.xda-developers.com/show....php?t=1752201 or google it to understand common principles of work.
For framework-res.apk mods we will use Connor-apktool and scripts for ease of use: http://code.google.com/p/android-apktool/downloads/list. However you will need the new MIUI aapt located here http://miui.connortumbleson.com/other/aapt/. Always choose latest apktools!
Let's assume again:
  • disassemble something - usually means issuing
    apktool d [full name of apk or jar]​

    command on file I specify if more info not specified
  • assemble something - usually means issuing
    apktool b [disassembled apk or jar folder without .apk in name or with ".out" at the end for jars ]​

    command on file I specify
    better way to assemble is drag assembled classes.dex(or resources.arsc and xmls at rest folders in case of assembling framework-res.apk) from [file you modified]/build/apk to original file, opened as archive (in windows you also have to check out a compression rate to make it the same as there were before dragging, which prompts to you as compression method like "Normal" and "Store")
  • smali - piece of code on dalvik bytecode language, are part of nearly any disassembled file
  • smali tree/just "tree"/"*.smali" - usually means set of files with the same name in the beginning but with different end(usually with $ before), for example
RIL*.smali means:





Let's start with framework mods:
All frameworks are located at system/framework.
Mostly issues are produced there.
Disassemble framework.jar from MIUI port you are working so you will see framework.jar.out. Go to smali folder in it. Later all actions we will produce from there (except assembling).
First replace some files from your base framework.jar (fist disassemble base rom's framework.jar and move all files I will specify, replace if asked).
Listing all smali I had to replace in framework.jar:

Jellybean 4.1.2:




android/net/wimax/Wimax*.smali (IF WIMAX BASED DEVICE ONLY)


android/nfc (I normally use the entire folder. This means your nfc corresponds with your nfc libs, needs nfc.apk and com.android.nfc_extras.jar. My method however.)








JellyBean 4.2.2:



android/net/wimax/Wimax*.smali (IF WIMAX BASED DEVICE ONLY)



android/nfc (I normally use the entire folder. This means your nfc corresponds with your nfc libs, needs nfc.apk and com.android.nfc_extras.jar. My method however.)







I highlighted those could be common for all chips, not only for Qualcomm ones.
But some of smalis are not following common rules.
The weirdest exception of that - WebviewCore. If you replace only WebViewCore tree, Gmail, Facebook, Browser, HTML viewer and all that is using this class WON'T WORK. What was my solution is to replace Webview*.smali tree, so I met all dependencies that class may work with.

>>Common Remark about patching smalis
Patching (usually named diffing, diff, that means "find differences and eliminate them") in our context is a process of comparing two files and adding contents of one of them to another and not replacing anything. Our diff process will consist of base->miui content addition so smali we modify could live in dual life - for your base and for MIUI remained framework. For start of diff you should have both base and miui files you want to modify, and a diff tool (in windows - beyond compare,total commander, winmerge or notepad++), my preference - Meld diff viewer[really simple and visual-oriented], the only thing - it's running on linux environment and I don't know if there is a windows version. Then just open files in tool and start adding. Sometimes you have to add all entries are not present in miui one from base, sometimes you should be smart enough to mod only part which needed and nothing more and also sometimes to replace pieces of code which are actually safe to do so. That's a whole process.
Example - our SystemProperties.smali:
Actually after opening you see it is full of differences from base:
you see those green blocks? Each of them signs a missing part of code you should add, in Meld it's just about of clicking little arrow that represents that block. As for windows tools, they should have something like "add all" and many other things could do it in a batch way.
A little piece of smartness:
that file is the only one I discovered which allow replacing .line with big code pieces, see that:
do you see ".line 126" and HUGE code block against it? you may forget about ".line 126" and copy block against it with no doubt. Note that line numbers etc could change, always check before doing something.
That line also became a dealbreaker on JellyBean, that's why we decided it would be better to just replace it. Ecample will give you a clue just about common patch process.
Another file has to be modified in same way - AssetManager.smali, which is located at android/content/res.
Beware of replacing anything on it[only add, as stand before], if something went wrong, it might produce awful logcat nobody could understand so you have to re-port rom again to catch a causer.
Another interesting patch you should perform if you have different than RIL telephony class.
To determine which ril class you have, seek for following line in your build.prop:

If you don't have such, mostly it means you are using RIL class and don't need a patch.
in my case it was:

so I'll describe a process for it, pointing what is common.
All ril classes located at com/android/internal/telephony, so go to it.
LGEqualcommRIL have a single smali, so copy only that one[if your class also have another smali with the same name, for example LGEStarRIL$1.smali, copy them too], Also, unlike most classes in CM, LGEQualcommRIL have a dependency - QualcommSharedRIL, which tree you should also move to that folder near LGE one.
Classes that are also have that dependency:
  • LGEQualcommUiccRIL
  • HTCQualcommRIL
  • SamsungQualcommUiccRIL
Others are dervied from RIL and don't have any dependencies like that. As CM involves more and more devices, to determine what dependencies you actually need, ask source code:
public class LGEQualcommRIL extends QualcommSharedRIL implements CommandsInterface​

extends means your dependency you have to also add to MIUI, if it is "RIL", go ahead and continue porting.
To make your class work instead of RIL, you should modify MIUI' PhoneFactory.smali located at the same folder in following way:
.line 136
new-instance v8, Lcom/android/internal/telephony/RIL;

invoke-direct {v8, p0, v4, v0}, Lcom/android/internal/telephony/RIL;-><init>(Landroid/content/Context;II)V​

.line 136
new-instance v8, Lcom/android/internal/telephony/LGEQualcommRIL;

invoke-direct {v8, p0, v4, v0}, Lcom/android/internal/telephony/LGEQualcommRIL;-><init>(Landroid/content/Context;II)V​

it changes a constructor of RIL class to LGEQualcommRIL class. If my lines incorrect, just type RIL in search in Phonefactory, it will show you exactly 2 defines with "RIL" involved.

Many devices now have LTE. The following is needed to sucessfully get LTE:


You must look for defines of:


Another case for patching is android/media/AudioFormat.smali.
Copy all missing lines from base to miui, it would be enough. I have decide to not replacing it coz of constructor that is differ and might one day turn into bomb.
The most complicated smali case, WebSettingsClassic. It do contains lines that should be added, also lines that should be slightly modified.
Let's try to make the process bit easier with these steps:
first of all, find those fields:
.field private mMediaPreloadEnabled
.field private mWebGLEnabled:Z​

they are at the beginning of file, marked as green blocks. Attention: then there is a listing that asks you about default value, like that:
.line 91
iput-boolean v2, p0, Landroid/webkit/WebSettingsClassic;->mMediaPreloadEnabled:Z​

DON'T EVEN TOUCH THEM! Even if you know what are you doing - it will fail on boot if you placed that lines in miui file.
interesting place here.. when you will search for webgl from the beginning, you will hit such block, marked as blue (incompatible):
goto/16 :goto_1
.end method

.method private native nativeIsWebGLAvailable()Z
.end method​

while miui file will show just that:
goto :goto_1​

and ".end method" after. "You f***n kiddng?" - will you ask.. yeah, pure cheat. Let's fix it up:
paste only:
.end method

.method private native nativeIsWebGLAvailable()Z​

before ".end_method" but after "goto :goto_1", so that full block will be instantly turned to whie:
goto :goto_1
.end method

.method private native nativeIsWebGLAvailable()Z
.end method​

except "goto", which will show as differ, but who cares?

After searching "webgl" on your base file you will possibly see a code block starting with:
.method public declared-synchronized isWebGLAvailable()Z​

add it without thought. You should do the same with the following methods:
.method public declared-synchronized setMediaPreloadEnabled(Z)V
.method public declared-synchronized setWebGLEnabled(Z)V​

btw, those methods are so-called "setters" - methods in class that intended to adjust value to class field.

Framework.jar port done!
the only thing to do - assemble it.

Unlike 4.1.2, telephony-common.jar is present in 4.2.2 bases. Simply port your telephony/ril smalis as you have done previously in other ports with the framework.jar. AS NOTED ALL EDITS IN TELEPHONY-COMMON MUST BE DONE TO FRAMEWORK.JAR AS WELL OR VICE VERSA UNLESS TOLD OTHERWISE. :p

Unlike framework.jar, there are lesser things to do. But they are also significant for porting process.

On jellybean 4.1.2/4.2.2 porting is more trivial:


Then you will find nativeCPUBoost is missing. You will have some defines in base file. Use search by keyword "cpuboost" in base file to determine where they are and just add them to miui one.
defines will be:

.method private static native nativeCpuBoost(I)V​

-method definition.
.method public cpuBoost(I)V​

-method code block.
and nothing extra.
Assemble new services.jar.out to services.jar when complete.

for some roms you will need to do some porting to your framework-res.apk

Open your apk, and go into res/xml. Use the following files from you base:

eri.xml (should only be needed for cdma devices)

Remember, to get an miui fully working, trial and error is key with miui. Not all devices are the same.

You may have to decompile your framework-res.apk as well to get small things fixed such as getting rid of navigation bar, getting mms working, etc. Especially with CDMA devices as not supported officially by MIUI. This will be covered in the tweaks section of guide.

Done those but still not boots or boots but functions improperly? see next Stages- 3 and 4, I will enlighten all moments of debugging what's wrong and also additional tweaks for specific devices that faced problems with porting [It's just impossible to do that for each device, so there is a great thread you could always ask what's wrong if my advices didn't help].

tal noah

Oct 11, 2012
Third part mostly touches cases where tuto above didn't resolved boot problems, also cases where there is no confidence 2nd stage will work/cases when people are trying to investigate themselves but mostly not xperienced in such(the most respectable case). To understand what's going on with your build it would be better to be CM/AOSP/AOKP dev, so you will most likely know where to find an answer. But if it is not about you, let me point on some moments could help.
Stage 3. Understanding logs and debugging
Yes, exactly understanding. Most likely people are going to forum and just posting logcat (that might contain common error). My goal is show you - logcat is not shuch thing you should fear to investigate!
First of all, let's assume something:
  • adb - powerful tool, in our case the must have thing to make a log. Article on android devs most likely describes all the moments about adb power:http://developer.android.com/tools/help/adb.html
  • logcat/log - one of the android advantages that allows you to debug what's going on with your system. by "make log" I will assume issuing

    adb logcat >log.txt​

    command, last argument - log.txt is a text file with log system provided to you (you could use any name).
    sometimes we need an answer about things that are going on with baseband (so-called radio). In those cases I usually asking to take radiolog. That's how it could be produced:

    adb logcat -b radio >log.txt​

    reading it might be a pain, as terms of it are too much hardware-specific, but it anyway complies with principles I will put below.
  • debug/debugging - process of analyzing code which helps to eliminate bugs (that's why de-bug)
Some people experiencing problems with log, most common are:
-wrong MIUI base which prevents usb subsytem to start (nexus S base most likely allows you to use log)
-no/corrupted/wrong usb drivers on PC
most likely is about new usb subsystems etc, so advice is the only one - try on ubuntu (not working without udev rules)
-somewhat corrupted/inconsistent usb port
-lack of "persist.sys.usb.config= mass_storage,adb" in build.prop, specifically "adb" in this line.
Note: if your log only consists of:

link system/bin/sh failed: no such file or directory​

or something like that, you should contact a CM dev, else, you are most likely know what happened ;]
Alright when we got a log, it consist of many many lines that are looping if your system not boots. That's why that kind of situation is sometimes called bootloop. System may repeat a error eternal time it lives, so log might be huge.
To parse what's going on there are some advice:
search in log you got some keywords, that might be useful on debugging boot issue;
most common keywords are:
  • "E/" - error
  • "E/dalvikvm" - possibly crucial system error
  • "No such file or directory" - says it all
  • "couldn't" - android likes that, mostly shows faulty things.
  • "fail"/"failed" - mostly crucial error
  • "W/"/"warning" - says it all, but not always warn could be a boot failure cause
  • "exception"(especially NullPointerException) - points you that something went wrong in framework or application work
I/ tags could be also useful at debugging, but most helpful are errors and warnings.
Most common constructs:
"couldn't find native method", the most common reason of a bootloop.
For instance:

E/dalvikvm( 100): ERROR: couldn't find native method
E/dalvikvm( 100): Requested: Landroid/view/GLES20Canvas;.nStartTileRendering:(IIIII)V
E/JNIHelp ( 100): RegisterNatives failed for 'android/view/GLES20Canvas', aborting​

Let's parse that construct to extract parts we will fix.
First of all. smali path might be extracted from that line:

E/JNIHelp ( 100): RegisterNatives failed for 'android/view/GLES20Canvas', aborting​



that's it, smali we are looking for is GLES20Canvas.smali. But.. android/view.. where it is? Answer comes from android source, it took some time to analyze frameworks.. Just let's assume: all that starting with "android" in path belongs to framework,jar.
What if path doesn't contain "android" at the beginning?
Again the answer is in source. Paths like"org/" are belong to framework.jar.
"com/android/server" - services.jar (there is the same folder at framework.jar but most likely you don't need to touch it).
another place we could be mixed up:
"com/android/internal" - framework.jar
"com/android/internal/policy/impl/" - android.policy.jar
for framework.jar path ends up on internal, which represents telephony folder. policy/impl is the only android.policy.jar folder.
Other frameworks are actually not used in port as they contain core android functionality which is common.
Note about smali you found:
  • it might be not smali you are looking for, most likely when code points you to android functionality and widgets (control elements) like combobox or listview, it's a sign to think twice what have you done on your system to port it
  • it might be tree of smali(remember 2nd stage assumes?), to ease of use, always replace smali with its tree, and only if error becomes worse, think about single smali or about diff(2nd stage assumes again

E/dalvikvm( 100): Requested: Landroid/view/GLES20Canvas;.nStartTileRendering:(IIIII)V​

we could extract a method which is missing - nStartTileRendering. In some cases only that method should be added and nothing more.
" android.content.res.Resources$NotFoundException: Resource ID #XXX"

E/AndroidRuntime( 3047): *** FATAL EXCEPTION IN SYSTEM PROCESS: WindowManagerPolicy
E/AndroidRuntime( 3047): android.content.res.Resources$NotFoundException: Resource ID #0x3060008
E/AndroidRuntime( 3047): at android.content.res.Resources.getValue(Resources.j ava:1022)
E/AndroidRuntime( 3047): at android.content.res.MiuiResources.getValue(MiuiRes ources.java:56)
E/AndroidRuntime( 3047): at miui.util.ResourceMapper.resolveReference(Resource Mapper.java:9)
E/AndroidRuntime( 3047): at miui.util.HapticFeedbackUtil.updateSettings(Haptic FeedbackUtil.java:109)
E/AndroidRuntime( 3047): at miui.util.HapticFeedbackUtil$SettingsObserver.obse rve(HapticFeedbackUtil.java:92)
E/AndroidRuntime( 3047): at miui.util.HapticFeedbackUtil.<init>(HapticFeedback Util.java:75)
E/AndroidRuntime( 3047): at com.android.internal.policy.impl.MiuiPhoneWindowMa nager.init(MiuiPhoneWindowManager.java:108)
E/AndroidRuntime( 3047): at com.android.server.wm.WindowManagerService$PolicyT hread.run(WindowManagerService.java:733)​

Wrong MIUI base, mostly. Appears when something changed by previous porter (miui) which affects resources you won't have, banal link error.
" Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1)"
Hope all of you heared about C language. That error is a form of C "exceptional case"(in other words - exception).
You will see if it happen:

F/libc ( 2698): Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1)
I/DEBUG ( 130): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
I/DEBUG ( 130): Build fingerprint: 'tmous/htc_doubleshot/doubleshot:4.0.3/IML74K/275847.101:user/release-keys'
I/DEBUG ( 130): pid: 2698, tid: 2698 >>> zygote <<<I/DEBUG ( 130): signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr deadbaad
I/DEBUG ( 130): r0 deadbaad r1 00000001 r2 a0000000 r3 00000000I/DEBUG ( 130): r4 00000000 r5 00000027 r6 4086fbfd r7 00000036
I/DEBUG ( 130): r8 40253f04 r9 40233a7e 10 0000904c fp 00009062
I/DEBUG ( 130): ip 4028b240 sp befcfa60 lr 401043c1 pc 40100adc cpsr 60000030
I/DEBUG ( 130): d0 2f64696f72646e61 d1 2f746e65746e6f63
I/DEBUG ( 130): d2 657373412f736572 d3 726567616e614d74
I/DEBUG ( 130): d4 0000d4cc0000d4b1 d5 0000d4e80000d4cd​

yaa.... ENORMOUS code block, build fingerprint, fatal signal and stack trace....welcome to hell
One little thing: error is right above that block, don't even try to parse its contents, ignore it.
WE ALL DIE!!!111
yaa, series of "died" errors:

I/ServiceManager( 1478): service 'media.audio_flinger' died
I/ServiceManager( 1478): service 'media.player' died
I/ServiceManager( 1478): service 'media.camera' died
I/ServiceManager( 1478): service 'media.audio_policy' died​

IGNORE them, it's a result of exception right above(no matter C exception or java one), it's better to see it instead of posting "WE ALL DIE!!!111"
"Unable to extract+optimize DEX from '/system/framework/framework.jar'" and other WTF cases

D/dalvikvm( 103): DexOpt: --- BEGIN 'framework.jar' (bootstrap=1) ---
E/dalvikvm( 172): Duplicate class definition: 'Landroid/media/MediaRecorder;'
E/dalvikvm( 172): Trouble with item 2900 @ offset 0x17a86c
E/dalvikvm( 172): Cross-item verify of section type 0006 failed
E/dalvikvm( 172): ERROR: Byte swap + verify failed
E/dalvikvm( 172): Optimization failed
W/dalvikvm( 103): DexOpt: --- END 'framework.jar' --- status=0xff00, process failed
E/dalvikvm( 103): Unable to extract+optimize DEX from '/system/framework/framework.jar'
D/dalvikvm( 103): Unable to process classpath element '/system/framework/framework.jar'
E/JNIHelp ( 103): Native registration unable to find class 'android/debug/JNITest', aborting​

05-30 14:15:15.970: E/NetworkLocationRealOs(2304): no android ID; can't access encrypted cache
05-30 14:15:15.970: E/NetworkLocationRealOs(2304): java.io.IOException: no android ID; can't access encrypted cache​

1012: 07-03 03:28:21.350: E/System(1538): ************ Failure starting core service
07-03 03:28:21.350: E/System(1538): java.lang.NullPointerException
07-03 03:28:21.350: E/System(1538): at com.android.server.pm.PackageManagerService.grantPermissionsLPw(PackageManagerService.java:4299)
07-03 03:28:21.350: E/System(1538): at com.android.server.pm.PackageManagerService.updatePermissionsLPw(PackageManagerService.java:4247)
07-03 03:28:21.350: E/System(1538): at com.android.server.pm.PackageManagerService.<init>(PackageManagerService.java:1170)
07-03 03:28:21.350: E/System(1538): at com.android.server.pm.PackageManagerService.main(PackageManagerService.java:858)
07-03 03:28:21.350: E/System(1538): at com.android.server.ServerThread.run(SystemServer.java:167)
07-03 03:28:21.350: I/SystemServer(1538): Input Method Service07-03 03:28:21.360: W/SystemServer(1538): ***********************************************1021:
07-03 03:28:21.370: A/SystemServer(1538): BOOT FAILURE starting Input Manager Service1022:
07-03 03:28:21.370: A/SystemServer(1538): java.lang.NullPointerException1023:
07-03 03:28:21.370: A/SystemServer(1538): at android.app.PendingIntent.getBroadcast(PendingIntent.java:293)1024:
07-03 03:28:21.370: A/SystemServer(1538): at com.android.server.InputMethodManagerService.<init>(InputMethodManagerService.java:548)1025:
07-03 03:28:21.370: A/SystemServer(1538): at com.android.server.ServerThread.run(SystemServer.java:271)1026:
07-03 03:28:21.400: E/AndroidRuntime(1538): Error reporting WTF1027:
07-03 03:28:21.400: E/AndroidRuntime(1538): java.lang.NullPointerException1028:
07-03 03:28:21.400: E/AndroidRuntime(1538): at com.android.internal.os.RuntimeInit.wtf(RuntimeInit.java:345)1029:
07-03 03:28:21.400: E/AndroidRuntime(1538): at android.util.Log$1.onTerribleFailure(Log.java:103)1030:
07-03 03:28:21.400: E/AndroidRuntime(1538): at android.util.Log.wtf(Log.java:278)1031:
07-03 03:28:21.400: E/AndroidRuntime(1538): at com.android.server.ServerThread.reportWtf(SystemServer.java:77)1032:
07-03 03:28:21.400: E/AndroidRuntime(1538): at com.android.server.ServerThread.run(SystemServer.java:274)​

mostly likely is about way assembling framework files. Also some of them might be just corrupted by accident. Sometimes these errors caused by wrong smali replacement or wrong diff methodology. Or it might be just banal reason - no place in system or cache partitions.

Most log parts are in mere, not technician English,log might be read as little book with bright characters. Find what you are looking for and fix it..
Source code is your best friend in porting
I'd recommend to have an android source code [from internet or on your local PC] to port something that outstands of rules I listed. For example CM frameworks source could be found here:https://github.com/CyanogenMod/android_frameworks_base .
That mostly affect cases in which hardware that is not working/working but not perfect/working incorrect on MIUI but worked like a charm on base.
Any log line represents a line of code in source, that one could search and debug from there (as source is mostly common, that miui ports possibility proove). Each smali represents a java source code or its part(- subclass which signed by $), each java is in frameworks folder on source (mostly frameworks/base). Log line is a message, which formed with C rules about these rules, so you have to avoid ciphers or guess how could code represent that message. You may search guessed line in source to locate java file, or locate it manually according to smali location and my advice and search in it.

Happy debugging {:1_1:}

tal noah

Oct 11, 2012
Last part. We recently ported miui, all is great and mostly functions, But.. am I the only one or that one looks incomplete? One could make its port complete by following next stage:
Stage 4. Advanced tweaks and specific hardware fixes
Cache Symlinking
Are you apps crashing on boot? this may be because your cache will not load. To fix, you will need to to do some symlinking in your init.rc which is located in your boot.img. To begin, unpack your boot.img like you did before and navigate to your init.rc file.
You will need to edit four lines to sucessfully symlink your cache. Find the following line:

mkdir /cache 0770 system cache

the value "0770" is the value that is needed. It may have a value such as 0771 or some other. Change to look like above.

Next, find this area:

# create dalvik-cache and double-check the perms, so as to enforce our permissions

you should see three lines below this, add the following line at the end of that code block:
symlink /data/dalvik-cache /cache/dalvik-cache

Next, find this line which was close to the previous method

mkdir /data/resource-cache 0777 system system

just like before your value will be different than "0777". Change line to look like above.

And finally, the last edit. You should find a line about two lines after your previous edit. It should look like this:

chmod 0777 /data/resource-cache

edit your line to produce the "0777" value shown in the line above.

USB subsystem(mass storage/tether/debugging sign)
First of all, little self - check:
you have to be on old USB Gadget framework kernel source. Those you could clarify by talking with cm dev. Also I'm not rejecting it could work for others but in slightly modified sequence.
Starting from framework-res.apk.
You have to disassemble it first, but before you use actual "apktool d", you should also issue:

apktool if framework-res.apk

that is necessary for decoding internal resources correctly.
Disassemble base and MIUI frameworks and leave base one as we will work with MIUI one and will use base as a reference.
After disassembling, let's go to res/values in it:
As old usb gadget needs old mass storage path which was applicable to gingerbread, we should add that path to strings.xml.
If you only disassembled that file, you should see something like that:
<string name="launchBrowserDefault">Launch Browser?</string>​
<string name="SetupCallDefault">Accept Call?</string>​

exact line to add at the near end:
<string name="config_legacyUmsLunFile">/sys/devices/platform/usb_mass_storage/lun0/file</string>​

so that you will get something like that:
<string name="launchBrowserDefault">Launch Browser?</string>​
<string name="SetupCallDefault">Accept Call?</string>​
<string name="config_legacyUmsLunFile">/sys/devices/platform/usb_mass_storage/lun0/file</string>​

that case is the only applicable to devices which have old kind SD card only. Look at the framework-res on your device, it also might have different LUN file path(actually it is a file, which collects all your SD data to be mounted as usb drive), that you should always replace in mind my defines with yours to make actual usb work.
Devices with flash memory(also called EMMC or embedded SD on flash) and SD[or without SD support at all], should be treat in custom way unfortunately I don't know, consult with your device CM devs for more details. And hey, most of these devices are on new usb gadget, so don't need my guide at all

After addition, save strings.xml and go to res/xml in the same framework-res.That's where you also should use base framework-res.
copy from base to miui storage_list.xml and replace when prompted. That file provides only your device-specific SD support, not nexus S or whatever miui base you use.
Assemble miui framework-res.apk and, attention! disassemble it again. That action allows you to see resource ID-s for each line exactly in manner they will be used in living rom.
Each resource-drawable, string, boolean switcher etc is treated by its ID - personal identificator. Resources are used in other frameworks and APK to identify something necessary for them. framework-res.apk is a resource storage, which handled by android.content.res package classes like ResourceManager.
USB subsystem also uses some resource to provide to user actual USB status and right mass storage.
Make sure you have both base and miui framework-res, then open both: res/values/public.xml.
Now, we could start the main part - services.jar mod
After adding line "config_legacyUmsLunFile" there will be its id in public.xml after compiling. That's why I stand you should disassemble assembled framework-res again. Remember both ID-s from base and from miui.
Also you need ID-s from both base and miui for following resources:
  • "stat_sys_adb" - usb debugging icon
  • "adb_active_notification_title" - usb debugging short message
  • "adb_active_notification_message" - usb debugging long message
  • "config_oemUsbModeOverride" - usb mode override flag
public.xml is a resource dictionary, example of line:
<public type="drawable" name="stat_sys_adb" id="0x010804f8" />​

means as follows: public type="drawable", drawable - mere picture for different resolution, drawn on the screen, public type subsequently is a type of resource. name="stat_sys_adb" - name of resource, that may be name of acual file or string or bool define etc. id="0x010804f8" - hexadecimal resource identifier. Important note: most resource users are treat resource name without leading zero, for example, 0x010804f8 in usb smalis presented as 0x10804f8, that fact will be necessary on finding and replacing resources(I'd call it matching process), exactly what we are going to do with USB folder smalis.
Open USB folder in miui services.jar (smali/com/android/server/usb), you will see smalis, as usual. Replace its contents with those in base services.jar' usb folder.
Then we are going to match resources: each ID you found in public.xml should be bound to resource call in smali. Let's start:
we will work with miui usb folder smalis. Open UsbService.smali, now remember what id was bound to config_legacyUmsLunFile in base public.xml, for example it was 0x01040029, eliminate leading zero and search file contents for resource 0x1040029, so you will find its entry. Replace that entry with resource you got from public.xml in miui, again, without leading zero. Search for the same ID in LegacyUsbDeviceManager.smali and replace it to miui one.
If you got how that process work, remaining task is match other resource id-s that listed above (usb debugging icon, long and short message). They will be in following files
  • LegacyUsbDeviceManager$LegacyUsbHandler
  • UsbDeviceManager$UsbHandler
For JellyBean
UsbDeviceManager.smali also contains necessary switch - config_oemUsbModeOverride, also match ID-s with miui framework and here you go.

USB debugging message is not so necessary as mass storage [coz if resource of mass storage file not found, you won't get usb subsystem to work].
After matching is done, assemble services.jar.
Done! USB subsystem now works.
Another moment could be necessary is to change USB tether interface device to usb0 (as Nexus S is using rndis0 instead, and base whatever you choosed may also have another tether interface)
To change it, you again need a disassembled framework-res.apk(don't forget "apktool if") In it navigate to res/values/arrays.xml.
find the following:
<string-array name="config_tether_usb_regexs">​

in nexus S full block will look like that:
<string-array name="config_tether_usb_regexs">​

Look, I highlighted interface name for you! So the only part you should do it is just replace it to yours. Example for usb0:
<string-array name="config_tether_usb_regexs">​

Interface name could be seen in the same file but in base rom.
By The Way, do you see
<string-array name="config_tether_wifi_regexs">​

right after usb one? That is the interface for wifi tether, that you also should change to yours (one your base needed) and that is it! I saw somewhere following interface variant:
<string-array name="config_tether_wifi_regex[/B]">​
which is for Sony [Ericsson] devices with Texas Instruments wifi chip, just see yours in base to check this out. It is smart to use meld or other diffing tool to find your proper config_tether_wifi_regex and diff it over.
In the same file you may also fix Autobrightness levels, I mean those ones:
<integer-array name="config_autoBrightnessLevels">​
<integer-array name="config_autoBrightnessLcdBacklightValues">​
<integer-array name="config_autoBrightnessButtonBacklightValues">​
<integer-array name="config_autoBrightnessKeyboardBacklightValues">​

MIUI doesn't have autobrightness tweaks so that is the only way those levels could be applied.

To fully close framework-res and don't come back no more, let's see other things you could do with it:
Minimal brightness too low
There is a bug with brightness: when you regulating it to minmal, screen comes black and won't come back until wipe.
Reason is banal - screen highlight couldn't handle so low value (in nexus S it's 10), first of all find a line at res/values/integers.xml:
<integer name="config_screenBrightnessDim">10</integer>​

in most cases value "20" will be reliable, so change "10" to "20":
<integer name="config_screenBrightnessDim">20</integer>​

Fix "Network won't automatically picks up"
The problem on some devices like HTC on 7x30 QC architecture, is in one little switch [res/values/bools.xml] :
<bool name="skip_restoring_network_selection">true</bool>​

just change it to "false":
<bool name="skip_restoring_network_selection">false</bool>​
and network will come up.
Fix MMS from not sending or receiving on CDMA Devices
[res/values/bools.xml] :

<bool name="config_mms_content_disposition_support">true</bool>

change to "false"
<bool name="config_mms_content_disposition_support">false</bool>

and mms should be fixed

Fix navigation bar showing up after porting from GNEXUS

<bool name="config_showNavigationBar">true</bool>

just change value to "false"
<bool name="config_showNavigationBar">false</bool>

No Wimax Enabled?
you may need to enable it in res/values/bools.xml:

<bool name="config_wimaxEnabled">false</bool>

change to "true"
<bool name="config_wimaxEnabled">true</bool>

Fix "Deep sleep issue on some devices"
Problem reported Wildfire S users resolved by that little define [res/values/bools.xml] :
<bool name="config_bluetooth_adapter_quick_switch">true</bool>​

change it to "false":
<bool name="config_bluetooth_adapter_quick_switch">false</bool>​

and issue will be resolved.

Also, it might be interesting to check out all bools.xml defines to see if something should be changed.

Next questions will be related to various APK fixes:
before we start you need to know that all apk are depend on framework-res resources, so before you start disassembling them, let's clarify steps: "apktool if" each framework with resources you have in miui, in stock there are two:

apktool if framework-res.apk

apktool if framework-miui-res.apk

then each apk could be disassembled as usual. Getting rid of MIUI start screen
Have you mentioned it? Ya, that annoying setup wizard.. In the end it suggests you to input your XIAOMI account which some users may never had and won't create. Keep them out of stress - get rid of that wizard!
Let me show how:
there are 2 ways, one - fully infiltrate that wizard from user's eye, second - will let you choose a language(useful in multilanguage releases) and setup wifi, then go right to homescreen.
Common moment: disassemble Provision.apk and go to smali contents - com/android/provision and choose DefaultActivity.smali
First method - codename "infiltration":
we will modify contents of "isProvisioned" method.
Kill all except "const/4 v1" and "return v1" in it, change const/4 v1 to 0x1 so you will get something like that:
.method private deviceIsProvisioned()Z​
.locals 3​
const/4 v1, 0x1​
return v1​
.end method​

actually, we are just saying to setup wizard that device is already passed its steps and don't need them anymore. So that setup wizard won't even be showed.
Second method - codename "multilang":
it is based on exploit, which is as follows: one could bypass xiaomi account prompt if before flashing miui he pull off sim card and then on setupwizard won't set up wifi. Wizard will send you to "sim not found" dialog, which then will allow one to "dismiss" account request.
Line which asks about SIM state is as follows:
invoke-virtual {v1}, Landroid/telephony/TelephonyManager;->getSimState()I​

move-result v1​
const/4 v2, 0x5​

some variable now consists of returned value.
To initialte that value to fail a check, I've just changed constant value to one that telephony manager will never return: -0x5
const/4 v2, -0x5​

Now its time to point fail to logical end of wizard, we are going to change label..
if-ne v1, v2, :cond_5​

if not equals v1, v2 (if (v1!=v2) in С manner ) go to label cond_5. As we stated, v1 won't be equal v2,so it will go to cond_5, which is not a place we wish to go (coz of unbelieveable hardcode). But there is a wishable place - cond_6:
invoke-direct {p0}, Lcom/android/provision/DefaultActivity;->finishSetup()V​

yyyyeah, right to finish

so we are changing cond_5 to cond_6:
if-ne v1, v2, :cond_6​

that's it! In the end you will get: language selection->wifi setup->homescreen, almost briliant!

Whether you choosed first or second method - assemble apk you got after all things done.

Fixing not working mic in calls
Disassemble Phone.apk and navigate to res/values/bools.xml to change:
<bool name="send_mic_mute_to_AudioManager">false</bool>​

<bool name="send_mic_mute_to_AudioManager">true</bool>​

Fixing pin code prompt on xperia devices
Disassemble Phone.apk and navigate to res/values/bools.xml to change:
<bool name="ignore_sim_network_locked_events">false</bool>​

<bool name="ignore_sim_network_locked_events">true</bool>​

Enabling hidden settings
Did you know that you may activate LEDs settings? Or maybe use camera key to trigger some useful functions? If not, follow the next little tuto.
Disassemble Settings.apk, navigate to bools.xml in res/values.
Activating LED settings
It would be enough to change
<bool name="has_led">false</bool>​

<bool name="has_led">true</bool>​

As you may got, other hidden settings are also there, I'll just list them and assume all of them needs just replacement false to true to make them activated
Multitouch gestures
Still didn't mentioned how they works, but, xiaomi wouldn't make something just for its appearence in settings.

<bool name="has_multi_touch">false</bool>​

MI button
Mi button on any device that has camera button!
What is MI button? It's a tweak that allows dedicated button to do something instead of its mere function (for example-issuing camera app as for cam button). You may adjust any app in rom to be executed, any switch from miui switchers and also trigger some actions like "menu", "call", "screen off toggle"(allows you to switch screen on and off, so possibly replace power button which is mostly weak) and "screenshot".
how to activate it? - the same:
<bool name="has_camera_key">false</bool>​

change to "true"
Dock settings
mere dock station settings dialog.
<bool name="has_dock_settings">false</bool>​

Trackball settings
for devices such as nexus one with active trackball.
<bool name="has_track_ball">false</bool>​

"Black bar" fix
Is your statusbar a black bar and not transparent like it is supposed to be?
Let's get MiuiSystemUI.apk and disassemble it.
Locate to res/values/drawables.xml and delete first line:
<item type="drawable" name="notification_header_bg">#ff000000</item>​

it might vary but always contains black colour (#ff000000). Recompile modified systemUI.

Last but not least, lets hope this guide will help fill up the latest and greatest from MIUI devices, users, and porters around the world.
Also on a side note I would like to thank Notorious and blackwing182 for helping me get me up to date on some of the new miui changes. Thanks!!


Nov 27, 2010
Shees this is a huge guide. But this will make me understand porting even more. Thank you for the time spent on this guide


Nov 27, 2010
The very first steps get a little confusing man. You should leave the base ROM as "stock base" and the Miui ROM used to get files from as " miui port" . and describe better which files to be deleted and where. Your guide doesn't specify that. For example:
Open " stock base" and delete blahh blah blah then open "miui port" and transfer those files to their respective folders in " stock base".
Thank you

Sent from my Galaxy Nexus using Tapatalk 2

tal noah

Oct 11, 2012
ohh sorry. well its not supposed to be specific. the first part is more generic. all should know you are transferring all of those files into your base from miui port. from guide.....Let's assume - just "Base" will mean rom for your device with Jelybean 4.1.2/4.2.2, such as Cyanogen Mod, AOKP or AOSP and their variations (I don't know if it is possible to use stock rom for porting and wouldn't recommend it), "MIUI base" means any miui rom you prefer
Jul 5, 2013
Hello sir I'm porting MIUI to grand! Using patchrom! I have diffed all frameworks! The problem is with framework.jar and framework2.jar they are not getting optimized!
Here is lil of logcating!
D/dalvikvm(  132): DEX prep '/system/framework/ext.jar': unzip in 42ms, rewrite 625ms 
D/dalvikvm(  132): DexOpt: --- BEGIN 'framework.jar' (bootstrap=1) --- 
I/ServiceManager(  131): Waiting for service broadcom.tvservice... 
E/dalvikvm(  366): Out-of-order entry types: 0x12fb then 0x12fb 
E/dalvikvm(  366): Trouble with item 611 @ offset 0x1593a8 
E/dalvikvm(  366): Cross-item verify of section type 1003 failed 
E/dalvikvm(  366): ERROR: Byte swap + verify failed 
I/ServiceManager(  288): Waiting for service media.audio_policy... 
E/dalvikvm(  366): Optimization failed 
W/dalvikvm(  132): DexOpt: --- END 'framework.jar' --- status=0xff00, process failed 
E/dalvikvm(  132): Unable to extract+optimize DEX from '/system/framework/framework.jar' 
D/dalvikvm(  132): Unable to process classpath element '/system/framework/framework.jar' 
I/ServiceManager(  134): Waiting for service broadcom.tvservice... 
D/dalvikvm(  132): DexOpt: --- BEGIN 'framework2.jar' (bootstrap=1) --- 
E/dalvikvm(  367): outsSize (6) > registersSize (4) 
E/dalvikvm(  367): Trouble with item 3051 @ offset 0x168d10 
E/dalvikvm(  367): Swap of section type 2001 failed 
E/dalvikvm(  367): ERROR: Byte swap + verify failed 
E/dalvikvm(  367): Optimization failed 
W/dalvikvm(  132): DexOpt: --- END 'framework2.jar' --- status=0xff00, process failed 
E/dalvikvm(  132): Unable to extract+optimize DEX from '/system/framework/framework2.jar' 
D/dalvikvm(  132): Unable to process classpath element '/system/framework/framework2.jar'


Dec 30, 2010
Has anyone fixed the bug where external sdcard does not appear in Gallery and Music apps?
Jul 5, 2013
I have been porting miui for a long time now can what this log means?
1. D/dalvikvm( 132): DEX prep '/system/
framework/ext.jar': unzip in 42ms, rewrite
2. D/dalvikvm( 132): DexOpt: --- BEGIN
'framework.jar' (bootstrap=1) ---
3. I/ServiceManager( 131): Waiting for service
4. E/dalvikvm( 366): Out-of-order entry types:
0x12fb then 0x12fb
5. E/dalvikvm( 366): Trouble with item 611 @
offset 0x1593a8
6. E/dalvikvm( 366): Cross-item verify of
section type 1003 failed
7. E/dalvikvm( 366): ERROR: Byte swap + verify
8. I/ServiceManager( 288): Waiting for service
9. E/dalvikvm( 366): Optimization failed
10. W/dalvikvm( 132): DexOpt: --- END
'framework.jar' --- status=0xff00, process
11. E/dalvikvm( 132): Unable to extract+optimize
DEX from '/system/framework/framework.jar'
12. D/dalvikvm( 132): Unable to process
classpath element '/system/framework/
13. I/ServiceManager( 134): Waiting for service
14. D/dalvikvm( 132): DexOpt: --- BEGIN
'framework2.jar' (bootstrap=1) ---
15. E/dalvikvm( 367): outsSize (6) >
registersSize (4)
16. E/dalvikvm( 367): Trouble with item 3051 @
offset 0x168d10
17. E/dalvikvm( 367): Swap of section type 2001
18. E/dalvikvm( 367): ERROR: Byte swap + verify
19. E/dalvikvm( 367): Optimization failed
20. W/dalvikvm( 132): DexOpt: --- END
'framework2.jar' --- status=0xff00, process
21. E/dalvikvm( 132): Unable to extract+optimize
DEX from '/system/framework/framework2.jar'
22. D/dalvikvm( 132): Unable to process
classpath element '/system/framework/

Sent from my GT-I9082 using Tapatalk 2
Jul 5, 2013
W/dalvikvm( 1734): DexOpt: --- END 'framework.jar' --- status=0xff00, process failed E/dalvikvm( 1734): Unable to extract+optimize DEX from '/system/framework/framework.jar' D/dalvikvm( 1734): Unable to process classpath element '/system/framework/framework.jar' D/dalvikvm( 1734): DexOpt: incorrect opt magic number (0xff ff ff ff) D/dalvikvm( 1734): ODEX file is stale or bad; removing and retrying (/data/dalvik-cache/system@framework@framework2.jar@classes.dex) D/dalvikvm( 1734): DexOpt: --- BEGIN 'framework2.jar' (bootstrap=1) --- E/dalvikvm( 1867): Duplicate class definition: 'Lcom/android/internal/telephony/IccConstants;' E/dalvikvm( 1867): Trouble with item 355 @ offset 0x138160 E/dalvikvm( 1867): Cross-item verify of section type 0006 failed E/dalvikvm( 1867): ERROR: Byte swap + verify failed E/dalvikvm( 1867): Optimization failed W/dalvikvm( 1734): DexOpt: --- END 'framework2.jar' --- status=0xff00, process failed E/dalvikvm( 1734): Unable to extract+optimize DEX from '/system/framework/framework2.jar' D/dalvikvm( 1734): Unable to process classpath element '/system/framework/framework2.jar'
Any one any solution?


Sep 10, 2013
Very informative tut!

I am porting 3.9.6 to htc desire and it is booting, everything seems to work fine except wifi is not turning on. I have then followed the steps described in stage 1 and stage 2 (only make minimum changes), but the issue is still present.

From logcat:
E/WifiStateMachine( 364): Failed to start supplicant!

Can anyone help?



Mar 17, 2011
Hi, I have used this guide to try to port MIUI to HTC One (M7) myself but now im getting stuck on miui boot logo and is not recognized by the pc to do a logcat I have follwed the guide step by step and tryied different kernels including CM kernel adyscorpius kernel and team 7 aosp kernel none of the make the rom boot, can i get any advice please

i use CM stable 10.1.3 for HTC One (M7) as a base and MIUI crespo build as porting rom


Nov 30, 2013
I am interested in decompiling/recompiling apps to include my own translations.
Since version 4.4.18 I am not able to do this for the new Email.apk. I am under Linux and I tried a lot of versions of apktool with no luck.
This is the same using Email.apk from multilanguage Ingbrz 4.4.25 ROM
May you share your knowledge with me (or with us) to translate new Email.apk?
Thanks a lot in advance