Helium problems with WCDMA


May 29, 2013
5
0
11
#1
Guys,

I just got my new phone. Have my backup from my other phone. Cant get Helium App to work on my Xiaomi Mi3 phone. I get a superuser error. I have my adb drivers installed and working. Any ideas?
 
May 29, 2013
5
0
11
#3
No. I am actually running my stock Rom. And the nice thing about this app is that the phone does not need to be rooted to work. I read somewhere that there was some place in the stock rom that will allow you to give root access to some processes. I just can't find it. Thanks,
 
Jan 29, 2014
30
0
16
#4
you need to flash the dev rom and activate the root permission (under security>permission)..
with stock rom, you cant activate the root permission (the root permission slider in locked)..

if you think that you have the root access, try to run other apps that need root permission to work (like lucky patcher)..
 
Feb 18, 2014
62
10
20
#8
I tried for several days to get it done on my own and to avoid this, but I guess, that I will not make it without some more hints: I also want to get root on my phone, which is a 64GB Mi3, WCDMA-version. I made sure that I installed the developer version of the latest ROM (*1) and after that to run "wipe data/factory reset". To do both of that I used CWM (*2).
So I go to the menu, settings, general settings and then to security. And now? There is neither a group with the name "Permission", nor a single button. What am I doing wrong? And where is the "Permission Manager" I am told I should go to, when I try to access any function that requires root?

(*1) http://******.d.miui.com/4.3.7/miui_MI3W_4.3.7_14adb1028c_4.3.zip
(*2) http://en.miui.com/thread-13682-1-1.html


Curtain of shame added...
 
Last edited:
Feb 18, 2014
62
10
20
#9
Now that was a tough one that took me almost a week to find. Yes, I know weeeweeen described it perfectly correct. But stupid me expected it to be under Settings and assumed that he had just skipped that step.
So for everyone who - like me - cannot find it: Take a look in the lower right on the main desktop. The name of the green icon you should see there is "Security". It shows a shield with a cross in its center. Start it, then again in the lower right you will see "Permission". Open it and there - finally - you can enable root and manage permissions.
 
Last edited: