New Help! Android Auto assistant voice commands not working.


hpmp109

Members
Dec 1, 2020
27
15
Hi everyone,

My Android Auto Assistant replies with "not sure how to help with..." to the great majority of my voice commands. Yet, Google Assistant works flawlessly on my phone and will answer everything. I've already written a post on r/AndroidAuto -- but no one knows what's causing this bug...

I'm really at the end of my tether here... I've tried everything -- clearing cache, uninstalling & reinstalling Google / AA, different USB cable. Nothing works! Yet, on a stock global Xiaomi phone the AA and Assistant voice commands works perfectly. Which leads me to believe that the issue is with Xiaomi.eu's ROM.

Phone: Xiaomi Mi 10 (umi) on latest weekly (21.11.3)

Fixes tried:
- Updating my car's touchscreen firmware to the latest
- Uninstalling Google app updates to stock version + clearing cache / data
- Rolling back AA app to a working earlier version
- Different USB-C cable
- Stock global ROM Xiaomi phonw

Any suggestions? Thanks in advance.

UPDATE:Under 'My activity' in my Google account, all of my voice requests from AA seem to be pushed through 'Search' instead of 'Assistant'. This means the following voice commands seem to work:

- What time is it
- Where am I
- What's the weather
 

acci_ts

Members
Jan 12, 2022
7
5
Hello! I have a similar problem with my Mi11Pro with 12.5.20 stable and 13.0.5 stable: Android Auto in my car (Alfa Stelvio 2019) works fine, but the voice commands do not lead for example to the navigation start. When I say "hey google", then "navigate to XXX" all my words are recognized correctly (and are shown in the car disply) but finally only a "pling" can be heared and nothing happens. Questions to "how is the weather" (or simalar) are correctly answered. Only the navigation commands do not work. Writing messages (whatsapp) via voice command also work but sometimes I hear the confirmation tone (pling) two times. Is there any fight between Android Auto Navigation and the Assistant or Driving mode? Played with switching the driving mode on and off didn't help.

I am writing here, because with my old Mix 2s with last xiaomi.eu-rom everthing went fine.
 

JiaiJ

Members
Jun 11, 2020
917
257
I can't help but be worried that nobody outside Google can help with such specific issues.
 

acci_ts

Members
Jan 12, 2022
7
5
strange... sometimes I got no answer to the question "navigate to XXX" and get only a confirmation "pling". When I ask, "hey google, XXX" (wirthout "navigate"), then two answers to my voice command accur: first "I can not find any results to your question" (or similar, translated from german" and then "I found one destination with adress XXX". Seems that first the "google search" answers and then the "android auto map navigation" answers. Oh google, what is going on here? seems like internal fight between google-assistant and android-auto (or maps).
This is anoying...
 

acci_ts

Members
Jan 12, 2022
7
5
bad news with the new 13.0.9: the effect is still there with the voice commands: "hey google..." leads to correct recognition of the commands following. But there are two answers: The first one from "google search" and the second from "android auto". Effect explained above...
How to avoid that the voice commands are answered by google search instead of android auto?

After that no further "hey google" is possible.
 

acci_ts

Members
Jan 12, 2022
7
5
bad news with the new 13.0.9: the effect is still there with the voice commands: "hey google..." leads to correct recognition of the commands following. But there are two answers: The first one from "google search" and the second from "android auto". Effect explained above...
How to avoid that the voice commands are answered by google search instead of android auto?

After that no further "hey google" is possible.
and now the good news: it works! Suddenly the double-anserws disappeared. The day before there was an update of the "google"-app., Maybe this was the reason. Sadly the voice recognition does not work reliably, then I have to use the button for voice commands in my car.

P.S. and no other problems with this build on my 11Pro.
 

adgellida

Members
Mar 15, 2022
2
3
Hi, I've the same problem, in my case with 13.0.3 on F3, Android 12.
My wife with Android 11 doesn't have this problem with Global on X3 Pro.
"google"-app update didn't fix it.
"not sure how to help with..." if I use "call to x contact" or "go to x location" command
I can answer Telegram messages with my voice, so... what happens with calls and GMaps?
Is the only way out to wait from Google to solve it or is this MIUI related? Thanks.
 
Last edited:

barbace

Members
May 2, 2017
108
30
Hi, I've the same problem, in my case with 13.0.3 on F3, Android 12.
My wife with Android 11 doesn't have this problem with Global on X3 Pro.
"google"-app update didn't fix it.
"not sure how to help with..." if I use "call to x contact" or "go to x location" command
I can answer Telegram messages with my voice, so... what happens with calls and GMaps?
Is the only way out to wait from Google to solve it or is this MIUI related? Thanks.
On my F3 I solved it by turning off the developer options.