[Help] Bootloop - Stuck on MI logo and Can't Get into Recovery

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by Nigelinux, Aug 14, 2014.

  1. Nigelinux

    NigelinuxMembers

    Sep 1, 2013
    5
    1
    13
    I was using an app called Backup Text for Whats to export my chat history, and while it was exporting it suddenly started bootloop.

    It is now stuck on the MI logo, or more precisely it is keep showing black screen (should be screen off, totally dark) and the MI logo alternatively.

    I tried removing the battery for a few minutes but once I plugged the battery back, without hitting the power button, the same thing happened again, keep flashing the MI logo.

    I tried entering the recovery mode by hitting the volume up button but it just didn't work.

    What can I do? Please help.

    P.S. I was using WIUI 4.4 but I don't think it is related.
     
  2. XperianPro

    XperianProMembers

    Oct 26, 2013
    648
    217
    80
    Male
    Corruped eMMc?
     
  3. can you enter fastboot mode? if yes try "fastboot boot recovery.img"
     
  4. Yes....hold vol Dow+pow until u get a fastboot screen and then flash ROM using miflash :)
     
  5. Marnix.

    Marnix.Members

    Feb 18, 2015
    6
    1
    13
    Male
    Hello guys,

    It's a very old thread, but maby someone reads this anyway. you never know ;)

    I have the same problem as above: A flashing MI logo which won't go away, not even after removing the battry.
    When I hold the down + power button the fast boot logo starts flashing, but nothing happens. When I release the button the MI logo pops up again.

    Any idea what to do?
    Thnks a lot
     

Share Our Site