[help] Error: Can't Mount /storage/sdcard0

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by Baggoz, Apr 25, 2015.

  1. Baggoz

    BaggozMembers

    Feb 25, 2015
    15
    3
    13
    Male
    Hi guys, I'm new on this forum and I'm italian, so I apologize for my bad english.

    I have a problem with my Mi2s: i tried to clean it all with Mi Flash but i had some problem (actually don't know where cause there wasn't no errror signaled) and now i can't do nothing with my internal storage.
    I tried everything but i'm not expert, here I will write what I did:
    - I tried to reinstall an old stable ROM with MiFlash selecting : Flash all, but I get this error: (remote: partition table doesn't exist)
    - I tried to turn on my device and the rom was okay but i can't save or download anything so I can't even change ROM or recovery
    - I tried Mi Tools and i was able to put CWM 6.0.4.7, so i tried a full wipe but i get this "error: can't mount /storage/sdcard0" and "can't mount storage/sdcard0/.android_secure

    I don't know what to do. I'm in panic mode :|
    If u need any other infos let me know, I hope there's someone able to help me
     
  2. Baggoz

    BaggozMembers

    Feb 25, 2015
    15
    3
    13
    Male
    Hi guys, here I tried to collect the most infos I can up to now.
    First of all I want to show what I have in Internal Storage:
    Internal Storage.PNG
    As u can see: nothing. If I try to copy something with MiPcSuite it didn't fail, but it also didn't copy anithing.
    If I try to copy just dragging something in it, it says errror

    I wrote what CWM says when i try Wipe/Data reset:

    -Wiping Data-
    Formatting /data...
    Formatting /cache...
    Formattig /sd-ext...
    E:unknown volume for path [/sd-ext]...
    Formatting /storage/sdcard0/.android_secure!...
    Error mounting /storage/sdcard0/.android_secure!...
    Skipping format...
    Data wipe complete

    And then I used the cmd mount to see what I have mounted, here the results (I am not able to understand anything reading them)

    shell@android:/ $ mount
    mount
    rootfs / rootfs ro,relatime 0 0
    tmpfs /dev tmpfs rw,nosuid,relatime,mode=755 0 0
    devpts /dev/pts devpts rw,relatime,mode=600 0 0
    proc /proc proc rw,relatime 0 0
    sysfs /sys sysfs rw,relatime 0 0
    none /acct cgroup rw,relatime,cpuacct 0 0
    tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
    tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
    debugfs /sys/kernel/debug debugfs rw,relatime 0 0
    none /dev/cpuctl cgroup rw,relatime,cpu 0 0
    /dev/block/platform/msm_sdcc.1/by-name/system /system ext4 ro,relatime,data=orde
    red 0 0
    /dev/block/platform/msm_sdcc.1/by-name/userdata /data ext4 rw,nosuid,nodev,relat
    ime,noauto_da_alloc,data=ordered 0 0
    /dev/block/platform/msm_sdcc.1/by-name/cache /cache ext4 rw,nosuid,nodev,relatim
    e,noauto_da_alloc,data=ordered 0 0
    /dev/block/platform/msm_sdcc.1/by-name/persist /persist ext4 rw,nosuid,nodev,rel
    atime,noauto_da_alloc,data=ordered 0 0
    /dev/block/platform/msm_sdcc.1/by-name/modem /firmware vfat ro,relatime,fmask=01
    33,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixe
    d,errors=remount-ro 0 0
    /dev/fuse /storage/sdcard0 fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=1
    023,default_permissions,allow_other 0 0
    shell@android:/ $

    That's all I thought would help u and me, if need anything else, just let me know
     
  3. Baggoz

    BaggozMembers

    Feb 25, 2015
    15
    3
    13
    Male

Share Our Site