New Hotspot Connects But Doesn't Transmit Internet

Discussion in 'Bugs' started by tonirai, May 14, 2015.

  1. tonirai

    toniraiMembers

    Apr 28, 2015
    278
    114
    65
    Male
    Device: Redmi 2 2Gb (HM2014813)
    ROM: xiaomi.eu v6 5.4.24 Beta
    (had two previous ROMs before that - 5.4.10 and 5.4.17, the problem also existed)

    I'm attaching a sendlog, hoping that someone is able to read it and understand why this happens, in order to find a solution.

    This is a problem that seems to affect several devices and/or several ROMS, but I've tried everything I have found in the internet, without any luck.
    Some considerations and things I've done:
    - Correctly setting the APNs;
    - Editing "setting.db" in "/data/data/com.android.providers.settings/databases/", to add an entry "tether_dun_required = 0";
    - Deleting folder "/data/misc/wifi";
    - Internet still works on the device while the hotspot is connected to the computer.

    I understand this isn't most likely a translation problem, and I understand that the ROMs available here are translations from miui.en... but I bring the question here, because it's a ROM available here.
    Any help will be greatly appreciated.
     

    Attached Files:

  2. tonirai

    toniraiMembers

    Apr 28, 2015
    278
    114
    65
    Male
    Update: Problem continues, but workaround found.

    Tested an Elephone android 4.4.2 with the same carrier network and same APNs configuration as mine, and hotspot works perfectly...

    Checked with my carrier that I had the proper authorization to tether on their side (wasn't really doubting it, because if I put the SIM in my previous phone, it tethers perfectly).

    Found out that the problem is the way the phone deals with the iptables and then does NAT - it appears it simply doesn't do NAT when using hotspot.
    Someone at MIUI should really take a good look at this!

    One workaround (among some others) is using a tether App that reconfigs iptables and corresponding NAT, like this one:
    https://play.google.com/store/apps/details?id=org.jaconet.fixtether&hl=pt-PT

    You just turn on your data connection, and open the App - it will turn on your hotspot itself, and you will see the log of activity in the first seconds, showing it re-configuring the iptable/NAT stuff;
    Then you can use internet on the tething device (it might take some 30 seconds to open stuff in the first time).

    I pray for the day I won't be needing a third party App to do something my phone should be able to do naturally.
     
  3. tonirai

    toniraiMembers

    Apr 28, 2015
    278
    114
    65
    Male
    Almost 2 months later, I come to give some following to the issue:

    I had found a workaround by using an app that re-writes ip tables and nat, but wasn't happy that I had to use a 3rd party app to tether;

    Well, on the miui forum from my country, a recent buyer of this phone stated that he tried the "change settings.db" procedure, and it worked for him...
    So I did it again, and, to my surprise, this time it caused no bugs and, more important, it worked!!

    So, I don't know what happened the first time I did it... I can imagine only 2 reasons why it didn't work and caused bugs:
    - My APN configuration, at that time, was different. I had 2 APN, one for internet, another for MMS. Both working normally. Later, I changed to only 1 APN, because I found out I could use the same for both purposes;
    - Something went wrong with the update or reboot, that caused the bugs.

    I just hope it sticks and keeps working!
     

Share Our Site