Hotspot works on Android phones, not on Win or Mac?


middleage

Members
Apr 11, 2020
3
3
Hi All,
The problem is that the hotspot (2.4 GHz, Device identification:default, security WPA2-Personal) is correctly seen by the laptops but there is no internet connection. I received the Mi 9T last week and it's a great phone except for the hotspot not working properly. I received it with the global version installed, I did all the usual updates up to MIUI V11.0.4 (QFJMIXM).
On the Macbook Pro (Retina 2015, Mojave 14.6) there is a very slow, barely usable, connection which is confirmed by the MCS index = 0, despite the strong signal (RSSI= -26 dBm). Under the WiFi information on the Mac, the country code is missing and the transmission channel is usually an unusaul value (3, 7 or 8 I noticed). For comparison, when using the hotspot function in another Android phone (Honor 8X with stock ROM) with the same SIM card , the MCS index is 7, the country code is correct, the transmission channel is 6 or 11, and the download/upload is around 20 Mbps.

When using a Dell laptop (Windows 10), the laptop connects to the MI 9T hotspot and has an IP but the pages are not even loaded. Funny enough, when both laptops are connected to the wifi created by the MI 9T, they can ping each other correctly.
rolleyes.gif


The data rates on the Mi 9T over 4G are really fast (>40 Mbps). The Honor 8X works perfectly when connected to the MI 9T, with rates > 20Mbps.

Reading other discussions online, someone fixed it with
Code:
adb shell settings put global tether_dun_required 0
I checked the correct value after rebooting (zero as expected) but still no/slow internet on the laptops. Same with adding DUN in the APN type. I also tried to change the SIM from slot 1 to 2, no difference at all.
biggrin.gif


As a last desperate chance, I unlocked the boootloader and flashed the European version (QFJEUXM) with TWRP. The flash was perfect, but the problem is still there exactly as described above with the Global ROM.

Is anyone else having a similar problem? Do you think that other ROM (Pixel Experience, LineageOS, etc.) may fix this?

I'd really like to keep the phone because the hardware is amazing, but the overall experience is quite a pain with such a limitation on the hotspot function.
eek.gif


Hope someone can finally fix this
smile.gif


29055
 

middleage

Members
Apr 11, 2020
3
3
Is there any way to change the Country code in the MIUI EU 11.06? On my Macbook it returns "Country code: X3" (System information/Wifi) whereas the other android phone with the same SIM and same APM settings returns the correct code!

Thanks
 

LOLO9393

Members
Feb 8, 2016
2,891
322
Is there any way to change the Country code in the MIUI EU 11.06? On my Macbook it returns "Country code: X3" (System information/Wifi) whereas the other android phone with the same SIM and same APM settings returns the correct code!

Thanks
you tested stock rom? Right?
why not to test stable or weekly eu custom cooked here?
 

middleage

Members
Apr 11, 2020
3
3
Yes, I tested the stock ROMs 11.0.4.0 (both Global and EEA) downloaded from here, and since last week I'm using the latest MIUI 11 EU stable, the xiaomi.eu_multi_HMK20MI9T_V11.0.6.0.QFJCNXM_v11-10

Update: I have upgraded to the latest weekly ROM (MIUI 11.2 20.3.26), unfortunately the country code is still X3 when using the hotspot, both at 2.4 GHz and 5.0 GHz. The only difference is that at 2.4 GHz the MCS level is 0 (even if internet works normally) and with the 5 GHz setting the MCS is 7 or 8. In both cases internet works fine, but the country code is an issue with the firewall on other devices.

Any suggestion or help is greatly appreciated as I really need the hotspot function to work as per the other Android phone!
 
Last edited: