Issue connecting Xiaomi smart pet water fountain, which is already listed in Xiaomi Home app device list


Mar 7, 2022
Hello everyone hopefully someone will have some advice for my situation..

I ordered the Xiaomi smart pet water dispenser (off Ali Express) because I saw it in my list of addable devices in the Xiaomi Home app for IOS. (My region is Croatia, Europe)
It arrived today and my cat absolutely loves it but I still haven’t been able to connect it to my app.
What happens is, I go through the connection steps succesfully -> select the pet water dispenser, turn on the bluetooth on the device, find it on my phone in wifi and connect, after that it completes connecting and finally the app takes me to my devices… but the device is nowhere to be found in my device list…
So basically the app acts as if it connected the device…but it didn’t in the end… I tried multiple times…

Is this possibly a problem with the region? And is that fixable without messing up my previously connected devices?
Also, the manual is in Chinese, I assume, so I don’t even know how to reset the device… I tried to scan the QR code to connect, but it only shows some text also in Chinese that I don’t understand.

I haven’t had luck finding any information on connection issues with the pet water dispensers specifically…
Any suggestions are very welcome

Sent from my iPhone using Tapatalk


May 20, 2022
I’m also having the exact same problem! Bought this as I saw the pet water dispenser on the Mi Home app as a device I could add (use to not be available in my region- South East Asian country). I still can’t figure out how to connect it. Would be great if someone could reply Desperate for it to work


Aug 12, 2022
Same problem here. One addition, after completing the setup, I checked my router, and the water dispenser connected to it successfully, it just does not show up in the app...

SOLVED: After experimenting a bit, I changed the app region to 'Chinese mainland', and did the pairing again, and it worked.
Last edited:


May 10, 2019
Still got a similar problem. The app wont even see the fountain while scanning. If i want to connect in manually i have to connect to its WiFi but search progress starts again.