1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues With Casting To Mi Box 3 (int'l)

Discussion in 'Xiaomi Mi Box / Mi TV' started by sappy404, Mar 20, 2017 at 8:12 PM.

  1. sappy404

    sappy404 Members

    Trophy Points:
    3
    Hi guys

    I'm having trouble casting to my Mi Box 3 (international version) for the last while. I'm specifically referring to DLNA/uPNP-style casting - Google Cast/netflix etc seems to work fine.

    I got the box in November and was able to cast to it easily using both BubbleUpnp and AllCast - it just showed up as a renderer on my network - but now in BubbleUpnp, the Mi Box disappears and reappears in the renderers list every few seconds. Casting to it when it appears results in an 'internal error' on the app, and in AllCast it stays 'loading' and goes nowhere. Nothing appears on the box. This is the same when running these apps on all of my devices.

    I ran an OTA update last week and was hoping for a bug fix, but no luck. Over the weekend I ran a factory reset and the casting worked fine - no problem just like when I first got it at the end of last year - but then the following day it was back to having the casting issue. I have a Chromecast Audio on the same network that I can cast to OK, and bypassing my router by setting up a wireless AP on my phone results in no change - I still can't cast. I have also tried using a USB ethernet adapter that I know works, but I get the same issue.

    Yesterday I installed a 3rd-party DLNA receiver app from the Play store and it receives OK, but it's full of ads and is prompting me to pay for a premium version. However, this box should - and previously has - acted well as a receiver when I am casting. So why does it have this problem?

    Has anyone else had this issue?
     
  2. Dave Deluria

    Dave Deluria Members

    Trophy Points:
    3
    IMHO it's just the way things are in computing. Sometimes things don't work.

    Now it's up to you to decide how much effort you want to put into fixing what seems to be some incompatibility that crept in either from an update or some changes that happened within your computing environment.

    Personally if the paid app works and it doesn't cost much I would just buy it and avoid the long hours to diagnose and isolate how to get the old setup working (if it's even possible). It's just not worth my time to spend 4-5 hours fixing an issue when a paid app can solve it faster, easier and quicker.
     
  3. sappy404

    sappy404 Members

    Trophy Points:
    3
    Well considering it worked for months, began misbehaving, then worked again after a factory reset before reverting to the same state, I'm hopeful it's just a bug. To that end I'd like to see if anyone else has seen it or heard about it, or better yet, has a fix.

    After looking around about it I found someone say they had seen something similar after coming out of standby. I'll try a cold boot later and report back. I wish I was the kind of person who could put this down to 'shit happens' and move on contently, but I'm afraid I'm not.
     

Share Our Site