Massive Problem on Mi10 with stable Miui 12 Rom


Jonkree

Members
May 5, 2014
11
23
I'm really stuck here and I need some help.
I have a Mi 10 unlocked and flashed with the stable xiaomi.eu Rom version 12.0.8.0.
In the past few weeks I had the problem that when I accepted a call I and the person that called me couldn't hear anything. So I thought maybe it's time for a firmware update.
So I installed version 12.2.2.0 via the Updater app. Worked in the past, so why shouldn't it now? Everything seemed alright, but after a day I noticed, that some apps lost the connection to the internal sdcard. It even went so far that apps like Solid Explorer couldn't find the internal storage.
When I tried to get into the recovery to flash the xiaomi.eu Rom I downloaded myself it instantly went into fastboot and it couldn't boot into the system afterwards, only fastboot.

So I flashed the Stock Rom with MiFlash, unlocked, flashed recovery, format data and tried installing the stable Rom again only to have the same problem as before. No access to the sdcard and fastboot boot loop afterwards.

Sad thing is I couldn't make a twrp backup because I use Dual Apps.

Is this a known problem with 12.2.2.0 or did I do something wrong? Should I install another stable or is there a weekly someone can recommend?
I can't just use the Stock Rom since I need the second Sim Slot and Xiaomi disabled it in Europe.

Thanks in advance and if something is unclear it might be the language barrier (non-native speaker here).

Update:
I got 12.0.8.0 installed and I can go into recovery again. I will now try to update version by version while creating a backup on an usb stick after every succesful update.

Update2:
The update from 12.0.8.0 to 12.1.5.0 seem to work, but once I updated to 12.2.2.0 again, the problems came back. The phone is stuck in fastboot and flashing or booting directly into a recovery image is not possible (remote: Failed to load/authenticate boot image: Load Error)
I will have to flash the Stock Rom again and until someone can clear things up I will remain at 12.1.5.0 for now.

Update3:
I found out that MIUI 12 and Android 11 seem to have a problem with Dual Apps and their storage access. I'm back at 12.0.8.0 again and I hope that I don't have to do the whole procedure (Stock Rom, Flash Recovery, Flash xiaomi.eu Rom) again in the next future.
@moderators You can delete this thread or leave it be. I don't have a problem with either.
 
Last edited:

m@c|-|oR

Members
Sep 5, 2020
340
67
I because I use Dual Apps.
This is the root cause of your problem.
A11 builds seem to have problems with dual apps.
It messes up the whole device.
After reading the experience of other users I also decided to stick to 12.0.8. until this is resolved.
An user reported in another thread that the last weekly, has this issue fixed.

Послато са Mi 10 помоћу Тапатока
 

Jonkree

Members
May 5, 2014
11
23
I browsed through the 20.12.9/10 thread and multiple user on multiple devices (Mi 10 included) said that dual apps work. I'm still hesitant to switch over, because it's still a weekly and with dual apps you can't make a twrp backup.