Menus Open Slowly/jerky With 6.4.21


Dec 12, 2015
100
10
30
#1
Most menus (3 points menu at the upper right) open slowly/jerky for me. For example in Hangouts, Google+, Google Drive. This was not the case in China Dev ROM 6.4.14.

The only one that is still fast/smooth, is in Chrome.

I am using Xiaomi.eu version 6.4.21. Is anyone seeing this also or seeing it not with China Dev ROM 6.4.21?

I want to find out, if it is version 6.4.21 in general or the Xiaomi.eu version.

Thanks!
 
Dec 12, 2015
100
10
30
#3
I am certain that this was not happening on China Dev ROM 6.4.14, only a week earlier.

I can fix this by setting "Window animation scale" in Developer Option to "Animation off". Menu animations in the mentioned apps then look normal again (not instant, but smooth). Only some MIUI popup window animations are off now.

But that is not normal, right?
 
Last edited:
Likes: Jemeljsh
Dec 12, 2015
100
10
30
#5
I am glad, I am not the only one. Saves me from trying Factory Reset. If it is still the same in the next weekly, I'll create a bugreport in the Xiaomi forum.
 
Oct 4, 2012
51
35
30
#8
I am certain that this was not happening on China Dev ROM 6.4.14, only a week earlier.

I can fix this by setting "Window animation scale" in Developer Option to "Animation off". Menu animations in the mentioned apps then look normal again (not instant, but smooth). Only some MIUI popup window animations are off now.

But that is not normal, right?
Thanks for finding this solution. I was experimenting with changing the multiplier in those animation scale settings but did not try switching it off. Thanks agan.. I quite often use whatspp 3 dot menu and it annoyed the hell out of me seeing that jerky animation ever since moving from I dunno which china dev rom version.

known issue.. we are working on it...
any progress on it? I see the same jerky animations in 3 dot menus in latest stable (v7.3.3.0) and weekly (v6.5.12.) versions. Apps like BetterBatteryStats and Whatsapp is the easiest and most evident examples. Switching "Window animation scale" in Developer Option to "Animation off" fixes it though, but I am not sure what am I missing out then with that option set to off in other parts of the os.