Resolved [Mi 10 Ultra] Camera watermark bug in weekly 21.1.20 timestamp incorrect


Alexbo

Members
Dec 13, 2015
27
15
I have been checking on the camera app, when I activate the option to Add time stamp on photos. It doesn't follow the Locale settings of the phone. I have set Central European Time and and Region set to Spain, so the normal configuration would be: dd/mm/yyyy.

Instead I get the American/Chinese version of the date (MM/DD/YYYY). This did not happen on the stable version. So I presume it hasn't been changed for the weekly.

Could someone correct this for future versions?

Thanks
Regards
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,962
322
It doesn't follow the Locale settings of the phone. I have set Central European Time and and Region set to Spain, so the normal configuration would be: dd/mm/yyyy.
That's not how it works. Locale and timezone are two separate things. Locale = display language. Which one are you using?
 

Alexbo

Members
Dec 13, 2015
27
15
My config is:
Region: Spain
Languages: English (United Kingdom) --> to have a normal dd/mm/yyyy format in everything else
Date & Time: Network provided GMT+1 (hence should be Spain which is: dd/mm/yyyy)

It must be some default seeting of the camera (like with the Supermoon or the AI Watermark) which all have chinese options....

But as I mentioned, in the Stable version, the date format goes according to the OS format.

Thanks anyway for looking into it.
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,962
322
Date & Time: Network provided GMT+1 (hence should be Spain which is: dd/mm/yyyy)
Like I said, that's not how it works for the camera. The watermark is defined as a locale-specific resource, in case of en-GB locale it's set as:
Code:
    <string name="time_stamp_date_format">dd/MM/yyyy</string>
So I'm not quite sure what the issue is.
Just tried setting "English (United Kingdom)" locale and taking a photo on a Mi 10, the resulting timestamp is "29/01/2021 15:05", so I see no issue there.
 

Alexbo

Members
Dec 13, 2015
27
15
Like I said, that's not how it works for the camera. The watermark is defined as a locale-specific resource, in case of en-GB locale it's set as:
Code:
    <string name="time_stamp_date_format">dd/MM/yyyy</string>
So I'm not quite sure what the issue is.
Just tried setting "English (United Kingdom)" locale and taking a photo on a Mi 10, the resulting timestamp is "29/01/2021 15:05", so I see no issue there.

Then in my case, there is something strange, look at the sample im sending you now....

Is there any logcat I can get to check the string on mine? Maybe on the 21.1.28 is not having the same issue (once im able to download it, i'll let you know it)

34505
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,962
322
Just compared the Camera app from 21.1.20 with the one from 21.1.28, it looks like the missing formats for locales (like en-GB) were added somewhere between these two releases, that's why I don't have the issue (I'm already on 21.1.28). Pretty sure that updating to our latest release will solve this for you.
 
  • Like
Reactions: Alexbo