Mi 11 Ultra (star) issues when flashing MIUI 14 [solved]


TyraVex

Members
Feb 1, 2023
4
5
Mi 11 Ultra (star) issues when flashing MIUI V14.0.6.0


Hello,

My Mi 11 Ultra was on MIUI 13 V13.0.12.0 (https://sourceforge.net/projects/xi...3.0.12.0.SKACNXM_v13-12-fastboot.zip/download) (flashed with fastboot), and I decided to update to MIUI V14.0.6.0 (https://sourceforge.net/projects/xi...11Ultra_V14.0.6.0.TKACNXM_v14-13.zip/download)

To do so, I put my phone in fastboot mode, and I connected it to my PC. The device was recognized in fastboot devices.
Then, I did fastboot boot twrp.img (from https://eu.dl.twrp.me/star/twrp-3.7.0_11-0-star.img). The device loaded twrp without any issues, until I use the install option.
I was in the /sdcard folder, but nothing was shown. I did some research, removed the password, refreshed MTP, tried different versions of twrp, but it wasn't able to read my device storage.

So to work around this issue, I put the rom in a usb stick, and verified its integrity after using sync on linux. I loaded the otg usb on twrp, and selected the rom zip file, and swiped to install.

The flash fails (I don't have the error in mind), but I know that it happened after a few seconds. I reboot to check what happened, but the devices fails to boot : It shows the xiaomi, android and unlock logos, then shows the loading dots and goes blank 30 seconds later. Another 30 seconds later, the phone is stuck with an oversized uncentered mi logo.

From this point I tried to download the original MIUI 13 fasboot rom to recover my device. But when I tried to boot it in fastboot mode, I was surprised to see a weird version of twrp showing up (there is a weird logo during loading).

But this time, the install option was showing all my files, including the miui 14 rom file. So I flashed it without changing any options. The process goes well, I get the blue confirmation message that the flash succedded. But just after that I get 3 errors showing that twrp failed to mount 3 folder/entries I can't remember the name of.
I will send a picture of the terminal with these errors when I get back home tonight.

For now I let my device in this state in charge, waiting for advice. I don't really know what I did and I would like more information before going any further.

Thanks for your help.

Sent from my Redmi K20 Pro using Tapatalk
 
Are you joking? "twrp-3.7.0_11-0-star.img" was built for Android 11.
Read the guide, and a link to recent TWRP versions is in there too:
 
  • Like
Reactions: JakSpoon
Are you joking? "twrp-3.7.0_11-0-star.img" was built for Android 11.
Read the guide, and a link to recent TWRP versions is in there too:

That's embarrassing, my bad.

After the first flash with the wrong twrp version, I ended up with twrp 3.7.0_12-Mi11Ultra_v6.8_A13.
But after flashing miui 14 with this twrp version, getprop ro.build.version.release returns 12.
At the end, if I try to reboot to system, twrp warns me : "No OS installed! Are you sure you want to reboot?", which apprently means that my system partition was wiped.

Is there anything I can do to recover my device ?

Also here is the terminal pic about the errors I get when flashing.
 

Attachments

  • errors.jpg
    errors.jpg
    286.7 KB · Views: 144