Mi 8 Pro issues


josephg

Members
Sep 11, 2021
3
5
Hello everyone,

I didn't have any issues with stock rom other than not being able to restrict data use. I have very limited data now.

I finally managed to unlock, flash twrp and install a custom rom. I briefly tried PA Quartz 5 which had sim issues. I now have xiaomi.eu 12.5.1 stable with these issues:

1. Auto rotate does not work. My phone is stuck in portrait mode.

2. Auto screen brightness does not work. I can manually change brightness.

3. Compass does not work.

I don't know if I have other issues. I am still exploring this rom.

I thought this rom was stable with no issues. I like this better than stock rom. If I cannot fix these issues, I should go back to stock rom. But I don't know how to do that.

If not, is there any other stable custom rom?

Any help appreciated. Thanks in advance.
 

gabrielo

Members
Jun 8, 2013
164
30
Hi @josephg i have an mi8pro and i can't get 12.5.1 working.

unlock boot loader
flash twrp -- twrp-3.5.2_10-0-equuleus-TeamWin
wipe data
flash rom -- xiaomi.eu_multi_MI8Pro_V12.5.1.0.QECCNXM_v12-10
Stuck on "miui" boot start

Do you hve similiar issues to flashit?
 

dannejanne

Members
Aug 21, 2011
75
30
Sounds like you have a corrupt persist partition (can happen if you flash GSI etc). Simply going back to stock will probably not fix it.

Try this:


Sent from my V2056A using Tapatalk
 
Last edited:
  • Like
Reactions: Poney70

josephg

Members
Sep 11, 2021
3
5
i have an mi8pro and i can't get 12.5.1 working.

unlock boot loader
flash twrp -- twrp-3.5.2_10-0-equuleus-TeamWin
wipe data
flash rom -- xiaomi.eu_multi_MI8Pro_V12.5.1.0.QECCNXM_v12-10
Stuck on "miui" boot start

Do you hve similiar issues to flashit?
@gabrielo, Yes I had similar issues flashing it. After data, I wiped user and persist partitions, thinking that flashing a rom would reset them. Then I formatted data in twrp. After that flashing xiaomi.eu worked. Try that. First boot takes a long time. Then OTA updated to 12.5.1.

Sounds like you have a corrupt persist partition (can happen if you flash GSI etc). Simply going back to stock will probably not fix it.

Try this:

@dannejanne Thank you. That might indeed be the problem. I am downloading stock rom now.