Mi Box Youtube Not Playing Videos


Sep 30, 2017
5
0
1
#1
I have strange problem with my YouTube app, almost every second video is not playing.... it seems like there is no rule which one is problematic, it happens randomly and often. It just stucks at loading spinner and won't play. It makes youtube app unusable, all other apps are working perfectly.

Anyone else has the same problem?
 
Oct 22, 2016
8
0
13
#4
I have seen this you can fix it by clearing the youtube cash then uninstall updates to youtube reboot play yourube once then update back to newer version it appears that somthing get corrupt during one of the updates to the youtune app.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 
Sep 30, 2017
5
0
1
#5
I have seen this you can fix it by clearing the youtube cash then uninstall updates to youtube reboot play yourube once then update back to newer version it appears that somthing get corrupt during one of the updates to the youtune app.

Sent from my SAMSUNG-SM-G935A using Tapatalk
Tried suggested but with no luck, situation is the same. YouTube app randomly doesn't play videos...
 
Sep 30, 2017
5
0
1
#6
Any other suggestion? It's quite frustrating not managing to watch YouTube on official Android device.... could it be that I have some hardware issue?

I haven't seen any problem on other apps, but on the other hand YouTube is maybe specific somehow...it's strange that it plays sometimes, but rarely, more often it gets stucked on video loading. And also, there is no pattern that I can notice, sometime it plays the same video and sometimes it doesn't.
 
Oct 22, 2016
8
0
13
#7
Just guessing here since the original suggestion did not work it could be somthing with you router and dns try to set a manual dns in your router such as 8.8.8.8 and 8.8.4.4 witch are google dns reboot mibox and see if that smooths things out.
I had problems with youtube not playing videos and the solution in the first post fixed it for me.
I dont think it is hardware as a last resort you can always try a factory rest witch is what i recommends if you mibox has done a system update.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 
Sep 30, 2017
5
0
1
#12
@Greg-ka , yes, your problem seems the same as on my device, video is normally playing on my other devices connected to the same network, but from some reason on Mi Box is not working...

@Rhayes I didn't managed to switch DNS on my router since I have one with factory default settings of my ADSL Internet provider, but I really doubt that this is the reason behind the problem since my other devices are playing youtube normally connected to the same network. I even tried to connect the device on my mobile phone network using mobile phone as hotspot , and outcome is the same.... also factory reset of mi box didn't helped.

Since there are more of us with the same problem, I guess that there is some more general problem behind this. I am running out of ideas, any other advice would be highly appreciated.
 
Dec 31, 2017
1
0
1
#23
Hello new mi box owner here. I bought mi box for youtube and kodi and youtube does not work, from beggining. I think we all deserve to get info from xiaomi what the problem is since it is clearly a general problem and when can we expect them to resolve this issue. Do old system versions work ok?

Please let us know what Xiaomi is doing about this problem?
Tnx
 
Jan 17, 2018
1
1
1
#24
What is happening with that s....!!! Its absolutely ridiculous to buy a Tv Box that doesnt manage to play YOU TUBE(???) and so many users, waiting so long for a solution. Xiaomi seems a huge dissapointment after all.
 
Likes: H3llK33p3r