Mi Tv Clinic (all Version) - We'll Try To Fix Your Problems

Discussion in 'Xiaomi Mi Box / Mi TV' started by Kaitozaki, Oct 28, 2015.

  1. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    #1Kaitozaki,Oct 28, 2015
    Last edited: Jul 11, 2017
    This thread is open to all models/versions of Mitv ( Millet tv )
    In which case when posting do stated your version of which models.

    As to help those without knowledge and to gain experience on the following:

    1. Rooting ( Root Tools / ADB wireless )
    2. Installing of ( GAPPS ) Google Play Store and all other google apps
    3. Upgrading/Downgrading for firmware
    4. Mitv apps/apks ( Sideload or Xiaomi featured apps )
    5. Iptv ( Free Only ) no paid subscriptions are to be posted.
    6. Fix issues ( Please repost the comment that helped you so others are able to find )
    7. And any other things related to MiTV
    This thread will be updated from time to time,
    those sending links for downloading please help to keep the links up.

    The use of direct download and torrent download for better experience.

    Hopefully this thread will answer all questions if and whenever possible.

    Those who have Firmware links to downgrade or beta updates do post without dead links, as many of the links online are dead.


     
    Lyuben and Be6i4 like this.
  2. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    #2Kaitozaki,Oct 28, 2015
    Last edited: Jan 16, 2017
    GOOGLE APPS

    PrebuiltGmsCorePano

    GoogleServicesFramework


    GooglePartnerSetup

    YouTube for Android TV apk (YOUTUBE LEANBACK)
    ( An alternative youtube for android tv )

    Google Play Store Android TV apk
    Not working...

    Others
    Sound Bar app apk

    ( To be installed on your android phone )

    Popcorn Time apk
    ( Watch & stream latest movies )

    Root Tools

    For Version 1.1.78 and above
    Mine on 1.3.8 android 5.1.1 working root


    http://www.kingroot.net/

    After installing kingroot - remove to install superSU
    https://mega.nz/#!98tH1YLB!0bgraC5E6auEd15ZYacq0Fo47ROkNqqjlj4eNLAUYl8



    Install Xposed on 5.1.1 SDK 22 without custom recovery
    https://mega.nz/#!RtFCGbRT!3v9EUaUUhDzZzgNJPt-K1kGISE4RuT74Jp8DmZXSsps



    Unlock ADB


    MITV Recover Tool
    ( Restore MITV to original firmware, removes root, to be us on windows only )

    Mitv firmware

    47" model

    48" model

    currently none to be found ( if there is one do let me know )

    49" model

    55" model
    thanks to @pspeter of "hardwarezone singapore" for the firmware
    LINK IN THE DESCRIPTION



    Mitv3 firmeware

    60" model
    thanks to @alferseet of "hardwarezone singapore" for the firmware

    How to boot into recovery


    Enter recovery with the remote,
    Turn on your TV while holding "HOME" & "MENU" button together.


    Inside my Mitv 2 55"

    [​IMG]

    [​IMG]

    WEBSITES FOR SPARE PARTS

    https://www.englishtaobao.net/

    http://www.offerany.com/

    http://www.yoycart.com/

    ***************************************************************************
    Anyone care to edit the boot image file?
    Bootanimation.zip
     
    jarntag and Be6i4 like this.
  3. lechchut

    lechchutMembers

    Dec 9, 2010
    4
    0
    11
    Thank you, can I use MITV Recover Tool for my miTV 55"? I have messup the firmware 1.1.70 it can't boot anymore, but can't find any link to download firmware for miTV 55"
     
  4. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    Not sure if its possible as the recovery tool needs abd to connect

    Likewise I havent gotten the firmware for 55", as im also using 55" and wanting to downgrade or wait for a root tool to update for firmware 1.1.82.

    But since you mitv wont boot maybe you can try the 49" firmware to see if it is possible to boot up and use abd settings if it does, still looking around for other firmwares.

    And I cant make a .img file with my 55" yet. So sorry...

    Can you boot into recovery? Hold home and menu button while you boot the tv up. Wipe all data and try, if you do get it working possible to pack an img file of your 1.1.70.
     
  5. lechchut

    lechchutMembers

    Dec 9, 2010
    4
    0
    11
    Thanks@ Kaitozaki

    My MiTV still boot up, but only if I boot to firmware 1.1.82.

    If I choose 1.1.70 it will not boot up (yes i can boot in to recovery so i can select which system i like to boot), if wipe all data in recovery, the 1.1.70 will boot up and working normal, but if I turn off the TV by use remote, it will not boot up anymore. Don't know if i screwed up somewhere.

    The problem is i dont want to use firmware 1.1.82, course it unrootable, it also can't play youtube video, it also force show up a stupid ADS every time when I turn on the TV (it countdown in 5 seconds then hide the ADS, I dont know why Xiaomi do this, it is a pain to see the ADS 4,5 time everyday when turn on the TV)

    I'm worries about use 49" firmware, if it orverwrite the recovery, there will be a brick TV for me :p
     
  6. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    Yes the ads are abit a disappointment, as such as the unrootable 1.1.82.

    Could it be your remote?

    If so try to reconnect your remote there is an option in thw settings, if it doesnt work then its best to try a full wipe to regain factory settings.

    And also 1.1.82 does not have adb settings, dont know why they took that away. I tried connecting a usb type A to my imac but it doesnt connect so cables are useless.
     
  7. lechchut

    lechchutMembers

    Dec 9, 2010
    4
    0
    11
    No im sure it is not my remote problem.

    I think it is because i have delete some app in my 1.1.70 ROM (ex: MiScreensave) I think, if you have that app please send me :(

    Or if you can access your 1.1.70 ROM please zip the folder system/priv-app if possible :(

    Thanks
     
  8. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    Sorry bro im on 1.1.82, I have no root to access the file you need. Hopefully others will attend to you.
     
  9. jarntag

    jarntagMembers

    Oct 2, 2013
    1
    0
    23
    Male
    Bangkok, Thailand
    My MiTV 3 55" struck in this Page .I think it is because i have delete some app in my 1.2.0 ROM . Any one can help.
     

    Attached Files:

  10. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore

    What app did you delete?
     
    jarntag likes this.
  11. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    1.2.0 firmware on mitv 2 55" can be rooted...I used the latest version of kingroot, it stated cannot root...but after trying a few times still the same...till I reboot my mitv...and it was rooted...

    Now trying to install gapps...
     
  12. lechchut

    lechchutMembers

    Dec 9, 2010
    4
    0
    11
    I think root by use kingroot have many problem, like some time screen flash (turn off then turn on in a second), kodi work strange, sometime is pause the movie when playing, sometime the volume is down. I hate it
     
  13. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    Root

    Root just helps to unlock system privileges... I dont think it effects kodi...maybe you could try to reinstall...

    So far no problems for me...only finding the right google play store and chrome...I updated my working chrome with another app...now I need to find the same app version to get it working...
     
  14. Flying Octopus

    Apr 27, 2016
    6
    5
    15
    is there an official release of MiTVbox firmware download site?
     
  15. Activeboy

    ActiveboyMembers

    Aug 21, 2016
    1
    0
    11
    Male
    Hi guys,
    My MITV 40 inches have a MI logo stop problem. Please help me. How to enter into recovery mode? Motion method and holding home+menu method are not work. if you have any ROM for mitv 40 inches,please give me download link and instruction guide.thanks all.
     
  16. bmg002

    bmg002Members

    Jan 21, 2016
    29
    4
    15
    #16bmg002,Aug 23, 2016
    Last edited: Aug 23, 2016
    I have the Mi TV 2S 48". I had rooted it (kingroot) and started getting the google apps installed, ran into an issue with it, so booted into the second system (via recovery) which booted up no problem. Second system was out of date (which is expected based on how the TV works), so I clicked to update it. 30 minutes of downloading and doing stuff, it gets to 95% then stops but I cannot figure out what it is saying (I don't have the second system in english, it is a factory setup).
    If I try to boot into the second system, the second one sits there with a big black screen for a few seconds then boots into recovery again.

    Anybody know how I can fix this? My thoughts are to root the first setup, install terminal emulator, mount the second system's /system partition and remove su and possibly copy all of the stuff from the working /system overtop of the broken /system (dd perhaps?). My fear is then I will have both partitions rooted which I have read is a bad idea.

    Any thoughts before I begin this adventure?

    EDIT: my bad... should have snooped on the forums a bit more. Found a post that says to install kingroot on system1 followed by super su and super sume then uninstall kingroot, super sume and lastly super su. Then install update and system 2 should boot updated and system1 will be old still.
    sorry for the broken link, I'm still a newb on the site so I can't post links.
     
  17. Melvin Chia

    Sep 14, 2016
    1
    0
    11
    Male
    #17Melvin Chia,Sep 14, 2016
    Last edited: Sep 14, 2016
    Oh you have the problem too? I rooted my Xiaomi TV2 55" with kingroot and since then my tv also flashes (screen goes black, for a second or two, then comes back), sometimes the TV doesn't turn on after going into Standby mode (have to physically flip the power switch on and off to resolve), and some Xiaomi stock apps crash on launch for video content.

    I've since un-rooted using Kingroot, and even done the in-menu Factory Reset, I haven't seen the screen flashing recently, but the stock apps still crash.

    I am also unable to get into Recovery mode to try the Full Wipe (does the in-menu Factory Reset do the same thing?), and am stuck with a 80%-functioning Xiaomi TV2 55". The same stock video apps on my TV2 40" works without crashing, but I never rooted that one.

    Help, anybody?
     
  18. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    I'm not having problems with rooting...my tv seems to be ok...though I've also gotten xposed installed without custom recovery...its on android 5.0.1...
     
  19. WillSmitY

    WillSmitYMembers

    Nov 21, 2014
    5
    0
    11
    Male
    #19WillSmitY,Nov 27, 2016
    Last edited: Nov 27, 2016
    Hi community ,
    Can someone give a suggestion where to buy a MI TV in europe ?
    i can't manage to find a seller in europe , who will ship Mi TV
     
  20. Dottorfox

    DottorfoxMembers

    Nov 27, 2016
    2
    0
    11
    Male
    Hello, I am writing for a vital information on the international version box me. I would use the xiaomi mi box tv (latest version whit dts/dolby and 4k) only to see films from external harddrive. Do you know if the box reads harddrive formatted ntfs of magnitude 4.5 terabytes with an external power supply? otherwise I will be forced to cancel tonight.
     
  21. saalmaan

    saalmaanMembers

    Jun 11, 2016
    5
    0
    11
    Male
    #21saalmaan,Dec 16, 2016
    Last edited: Dec 16, 2016
    Hello All,

    @Kaitozaki
    I really need this group's advise and help. My MiTV 3 60'' is not turning on. [stuck on Mi logo]

    TV version:
    Model = MiTV3 60''
    Software version = 1.2.0

    Problem:
    TV is stuck on Mi Logo and I see black screen.

    What I have tried already:
    1) Tried to boot into recovery removed all data. restarted but still stuck on Mi logo screen
    2) Tried to boot into recovery switch to system 1. restarted but still stuck on Mi logo screen
    3) Tried to boot into recovery switch to system 2. restarted but still stuck on Mi logo screen

    What did I do before TV broke:
    1) I changed build.props file and when I restarted the TV it got stuck on Mi logo screen

    What do I need now:
    1) Recovery image or compatible original firmware to flash the TV to its original state.
    2) Access TV through ADB to restore original build.props file
    3) Any other suggestions

    I really can not send the TV back to china to get it fixed so any help from this community will be highly appreciated.

    Many thanks
     
  22. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
    @saalmaan

    sorry my mitv 2 55" is also have the same issue as yours...but mine can boot in system one but nable to install anything...

    waiting for firmware...
     
  23. Kaitozaki

    KaitozakiMembers

    Oct 28, 2015
    49
    8
    20
    Male
    Singapore
  24. rrapa

    rrapaMembers

    Sep 12, 2015
    20
    1
    13
    Male
    Warsaw / Poland
    Which version of Gaps have u installed ? I'm having issues with them ..
     
  25. stevemaddensf

    Jan 10, 2017
    1
    0
    11
    Male
    Hi Kaitozaki, great post, unfortunately all the Megasink links require a decryption key ?!?!? ... maybe they changed something since this thread is more than 1 year old...
    Anyway can not download anything, is it only me ?
    Thanks !
    Steve
     

Share Our Site