Mi2 reboots only into fastboot

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by ale_gallagher, Oct 22, 2014.

  1. ale_gallagher

    Nov 15, 2013
    106
    30
    38
    Male
    I've always been happy with latest WIUI, until yesterday :(

    I did a normal reboot and the phone rebooted into fastboot.
    So I unplugged the battery, plugged it in and pressed the power botton: it booted into fastboot.
    Then I entered the cwm by pressing power+volume up, rebooted the phone and it still booted into fastboot.
    I performed every possible wipe in both partitions since I've TDB enabled, but there was no solution.

    I couldn't save save a backup and the files from internal storage to my pc because I was not able to mount usb storage (windows 7 suggested to format the disc).
    Well nevermind, I run miflash and everything seemed fine until the end, but when miflash automatically reboots the phone guess what?? it rebooted into fastboot

    I tried several time with v6 and v5 images, but nothing new happened.

    Now I can only enter the original recovery, but volume buttons don't work when it's time to select language and only power button work

    I don't know if it's a hardware problem that volume buttons don't work, but I don't think so because the combination power+volume up let me enter the recovery.

    What do tou guys think?
     
  2. ale_gallagher

    Nov 15, 2013
    106
    30
    38
    Male
    Little update

    I tried linuxx aries toolkit and flashed cwm.
    Volume down key doesn't work :(

    But I don't see why it boot into fastboot when the phone is off and I plug the battery charger (so no plugged into a pc)
     
  3. RadarNyan

    RadarNyanMembers

    Sep 10, 2013
    101
    44
    38
    Male
    Because hold volume down while boot = boot into fastboot on aries. Since your volume down key is broken, just fix it.
     
    ale_gallagher likes this.
  4. ale_gallagher

    Nov 15, 2013
    106
    30
    38
    Male
    Thanks, I'll try ;)
     
  5. ale_gallagher

    Nov 15, 2013
    106
    30
    38
    Male
    Well at the end I removed the button and everything in fine now, except for the missing botton of course :)
     

Share Our Site