Mi2s Stuck At Bootlogo (not That Simple, Tried Everything)

Discussion in 'Xiaomi Mi 2 / Mi 2S' started by Robse, Jun 18, 2015.

  1. Robse

    RobseMembers

    Jan 11, 2014
    3
    0
    13
    Male
    #1Robse,Jun 18, 2015
    Last edited: Jun 18, 2015
    Hey Guys,

    To make it short, my MI2s won't boot into the System anymore. Here is what happened.

    I wanted to flash the new V6 Rom through Fastboot and got an error. I tried again and it worked, but the phone got stuck at the Bootlogo. This though, was nothing new to me, cause whenever I tried a V6 rom, my phone never booted the system.

    So I decided to go back, but here comes the problem. I tried every rom based on 4.1 4.4 etc through Fastboot, but the phone just always stuck at the Damn logo!

    It got so far that I flashed a very old rom (JB4.0) and the phone was complete BRICK.

    So I had to use the "two gold pins method" to revive the phone.

    Also flashing through Fastboot including reflashing the partitions didn't work.

    I tried several MiFlash versions and roms (normal, developer, beta..) and also through flashing from CWM afterwards including sideloading.

    Nothing works!

    Does anyone has an idea?!?

    It would be great, thanks in advance!

    Also, the phone worked perfectly fine before all that.

    So again, the phone boots, shows the logo and after a while the second on the bottom. In some cases it turns orange, but that's rom related I guess. After that, nothing happens anymore.
     
  2. paulrlz

    paulrlzMembers

    Nov 23, 2013
    584
    167
    80
    Male
    try to manually flash all these files:

    fastboot flash tz tz.mbn
    fastboot flash dbi sdi.mbn
    fastboot flash sbl1 sbl1.mbn
    fastboot flash rpm rpm.mbn
    fastboot flash aboot emmc_appsboot.mbn
    fastboot erase boot
    fastboot flash misc misc.img
    fastboot flash modem NON-HLOS.bin
    fastboot flash modem1 NON-HLOS.bin
    fastboot flash system system.img
    fastboot flash system1 system.img
    fastboot flash cache cache.img
    fastboot flash recovery recovery.img
    fastboot flash boot boot.img
    fastboot flash userdata userdata.img
    fastboot flash boot1 boot.img
    fastboot reboot
     
  3. Bucci

    BucciMembers

    Dec 16, 2014
    40
    2
    18
    Male
    I don't believe your status is final, always is the way, maybe the problem is you tried everything mixed together...

    1st at all check your partitions via ADB - if they're correct, just go step by step with rom install via ADB or fastboot....
    In some case I'll tell you, just send me the phone I'll play with it, but this is not real situation...
     
  4. Robse

    RobseMembers

    Jan 11, 2014
    3
    0
    13
    Male
    Flashing manually didnt work. Also I dont think its cause I mixed everything, not even sure what is there to mix :).

    I checked the partition table in the beginning and parted it manually and later on also through miflash by addin a line of code I found (The guy wanted to go back from V6 to V5 but had issues with the partition table).

    So thanks so far, but stil doesnt work :(
     
  5. Bucci

    BucciMembers

    Dec 16, 2014
    40
    2
    18
    Male
    maybe silly question, did you use correct stuff? mean for example if you use data for Mi2A or another phone type, it could be a cause of problem...
     
  6. paulrlz

    paulrlzMembers

    Nov 23, 2013
    584
    167
    80
    Male
    have you tryed to flash m1cha's bootloader?
     

Share Our Site