Mi4c No Pc Connection, No Usb-otg

Discussion in 'Xiaomi Mi 4C' started by cris2d2, Jan 7, 2017.

  1. cris2d2

    cris2d2Members

    Dec 31, 2016
    23
    5
    15
    Male
    Hello everybody!

    I have a 3gb/32gb mi4c, no warranty, with the following problem: it wont connect anymore to pc, I uninstalled the drivers but right after reconnecting the phone to pc, windows 7 shows a device is found but wont install it, the proccess ends with Unknown Device in Device Manager. Also, it wont accept my otg drive (kingston microduo 3C), nothing appears at USB Storage in settings.

    I checked with another cable, anoter usb port, even on another computer, but with no luck.

    Also, the charging time from adapter is over 5 hours, from about 10% battery (the phone reports USB charging). If I turn off the phone, it wont charge, nothing appears on the screen, the led is off.

    As I found on the web, people with similar problem tried to change the USB charging board with a new one. I replaced it myself with a brand new one, but it didn't resolve the defect. The only difference was with the new usb board, the phone could charge if it's turned off, but with the same slow speed.

    So, do you think the mainboard is faulty? Or other part, like a flat cable maybe?

    I guess ROM version isn't quite important, since not even in TWRP it wont connect to pc or to otg drive.
     
  2. ipolit

    ipolitMembers

    May 2, 2016
    17
    6
    15
    Male
    Hello, I have similar issues with my - it is 2 GB version. My is in warranty and I was offered by the seller to return it. I am still searching for solution. I also replaced the USB module, but nothing changed. As last hope I purchased Deep Flash Cable, but I don't have huge expectations. Since my is with official chinese dev ROM, my hope was I will be able to flash new fastboot ROM or something to fix it, but when you say it doesn't work with TWRP, maybe I have to return it and to live 2 months without phone.
     
  3. cris2d2

    cris2d2Members

    Dec 31, 2016
    23
    5
    15
    Male
    I'm sure mine had (i sold it since first post) motherboard issues, because I found some weird thick liquid over the Qualcomm chip (Qualcomm PM8994 power management chip) when I dismantled it. Maybe some kind of charging electric shock fried the chip and/or other small parts. Maybe something else was the problem, but I really cant figure it out.
     

Share Our Site