New Mi4c Push & Wlan Still Bugged

Discussion in 'Bugs' started by ralle_h, Jan 6, 2016.

  1. ralle_h

    ralle_hMembers

    Jan 2, 2016
    15
    2
    13
    Male
    #1ralle_h,Jan 6, 2016
    Last edited: Jan 21, 2016
    Hey guys,

    I'm really happy with my Mi4C and the EU Rom, but one issue is really driving me nuts.

    When I'm connected to my home WLAN (IPv6 over a Fritz!Box 7490) I receive PUSH Notifications severely delayed. In other WLANs (at University or at friends houses) or when using 4G/LTE, I don't have any problems/delays with the PUSH Notifications at all.

    Background Info: I use the App "Pushover" and a bunch of self-made scripts on some servers to send me Push notifications that I really need to see instantly... and on all my other mobile devices (Samsung S4 and a bunch of other devices I tried) they arrive instantly as they should, only on my Mi4C with the EU Rom they are 3-4 Minutes delayed (only in my WLAN, otherwise I have no problems, as explained above) or not at all - at least before I wake up my phone and check the app manually.

    I tried 3 workarounds:

    1) Lock the Pushover App:

    [​IMG]

    2) Change the Settings for the Pushover App to be allowed to maintain a background connection:

    [​IMG]

    3) Disable IPv6 on the phone.

    Sadly all workarounds had no positive effect at all. I recorded a video as well:



    /edit:

    I did some further testing on other WLANs and I also tried the official version of MIUI and CM 12.1. Here are the results:

    - Other WLANs: Same problem
    - Official EN Miui: Same problem
    - CM 12.1: No problems at all.

    I'm pretty sure there is still a severe Bug in latest EU Rom, regarding WLAN and Push notifications whilst being in sleep-state.

    Any ideas what else I could try or how to report this bug to be reviewed?

    Kind regards,
    Ralf

    P.S: My device is a Mi4c and I'm on 5.12.31
     
  2. Namaless

    NamalessMembers

    Feb 6, 2012
    57
    15
    18
    Sorry but you talk about with external network all working fine, you don't think the problem come from your home network?
    Plus this, you have tried the official en.miui.com version? If the problem persist in the official version you need to report the bug in the official site because is related to miui directly and not to this rom version.
     
  3. ralle_h

    ralle_hMembers

    Jan 2, 2016
    15
    2
    13
    Male
    I don't think it's my home network tbh, for 2 reasons:

    1) It's only when the MiC4 is sleeping for 10 mins+, otherwise the Push notifications are arriving instantly.

    2) All other devices work fine in my home network (Samsung S4 and other Windows Phones and Tablets I tested) - no matter how long they are sleeping. Sadly I don't have the chance to try another IPv6 home network, all other networks I tried were IPv4 - maybe that's a part of the issue here.

    I recorded a video as well:

     
  4. Namaless

    NamalessMembers

    Feb 6, 2012
    57
    15
    18
    Omg so sexy voice :p

    Btw yes I think is a bug but come from miui official directly because this problem come when the device is in deep mode, I don't think the xiaomi.eu edit the rom and add features into the deep mode, you tried to use a official version of en.miui.com ??
     
  5. ralle_h

    ralle_hMembers

    Jan 2, 2016
    15
    2
    13
    Male
    Thanks ;)

    I tried another workaround: Disable IPv6 on the phone. Doesn't help as well. :(

    I will try on official version this weekend and update my post/see if it is the same.
     
    Namaless likes this.
  6. ralle_h

    ralle_hMembers

    Jan 2, 2016
    15
    2
    13
    Male
    Okay, today I did some further testing on other WLANs and I also tried the official version of miui and CM 12.1. Here are the results:

    - Other WLANs: Same problem
    - Official EN Miui: Same problem
    - CM 12.1: No problems at all.

    So it seems like this is a bug of the official MIUI.

    What's the best place to report it, so the devs take a look at what I found out?
     
  7. alboz83

    alboz83Members

    Jul 16, 2013
    78
    19
    18
    Male
    Hi..wow so after about 3 years this bug is always present. Anyway the problem is the Miui rom because i red that many many people have this and there are many thread for this bug. I would buy a xiaomi phone but not with this bug. Also i red many solutions and options to set on Miui rom, a lot of people has resolved, other not. It's very strange!!

    Inviato dal mio ASUS_Z00AD utilizzando Tapatalk
     
    Chinrzu78 likes this.
  8. ralle_h

    ralle_hMembers

    Jan 2, 2016
    15
    2
    13
    Male
    Even though the bug is from the official ROM, maybe the Devs here can take a look and check back with the devs of the original one?

    Or where would be the best place to report this bug?
     
  9. Sergeyb76

    Sergeyb76Members

    Jan 19, 2016
    56
    17
    20
    Male
    Try 2 enter this app on star up settings. Other programms like whatsapp pr wiber have same problems? You can enter 2-3 phones to same group with same wifi and test push speed.
     
  10. ralle_h

    ralle_hMembers

    Jan 2, 2016
    15
    2
    13
    Male
    Sorry, what do you mean with your suggestion "star up"?

    WhatsApp doesn't have any problems. Facebook neither (only small delays). But all other not so popular apps don't work properly, like (Steam, Pushover, Amazon and other apps.

    I also noticed: When the power cable is plugged for loading the phone, push works normally on all apps. So I'm not sure if this is only related to the WLAN, I think this is some stupid/bugged energy saving rule in the system and Xianomi did add a white list for popular apps like WhatsApp and Facebook.
     
  11. Sergeyb76

    Sergeyb76Members

    Jan 19, 2016
    56
    17
    20
    Male
    No *start up*(wrong rom), in battery you have power settings for app and notification. Maybe change priority.
     
  12. ralle_h

    ralle_hMembers

    Jan 2, 2016
    15
    2
    13
    Male
    Nothing helped, still same problem :(
     

Share Our Site