New Mi4c Rom 6.1.14 Problems Switching Between Wifi And Network No Internet

Discussion in 'Bugs' started by Juan Gaudiano, Jan 20, 2016.

  1. Juan Gaudiano

    Jan 18, 2016
    8
    0
    11
    Male
    Good morning

    I'm having problems when I move out from WiFi coverage to my network connection.

    I will get no internet connection and it tales a while until the network connects again, sometimes I hace to do it manually.

    I thin with ROM 6.1.1.7 it was working well.

    Anyone else has this problem, or someone can help me solve it?

    Thank you very much un avance and keep up your excelente work.
     
  2. panhans

    panhansMembers

    Jan 15, 2016
    11
    0
    13
    Male
    Sometimes I'll get no mobile connection when turning off wifi. Then just a restart helps.
     
  3. Martin_Spilovsky

    Jan 5, 2016
    9
    0
    11
    Same issue, matches your description tomorrow I yesterday my phone, went to work all the time using 3G, no issue at all, then went home, where phone switched to wifi, again no issue, went out for 2 hours, somehow all stopped working, yes reboot solves the problem, but pls :), this aint a solution maybe a temp. workaround, hope it will be fixed with 6.1.17
     
  4. Robbie13

    Robbie13Members

    Jan 24, 2016
    43
    1
    18
    Male
    I think I have the same problem. After rebooti the phone, mobile data works normally for maybe several hours - maybe until turning on Wi-Fi ? Then it seems like mobile data stops working but only for some applications, for others it works but very slow.

    Mi4c
    MIUI 7 by xiaomi.eu 6.1.21 beta
    Android 5.1.1
     
  5. Martin_Spilovsky

    Jan 5, 2016
    9
    0
    11
    Persists with 6.1.21 Beta ROM on Mi4c,
     
  6. spielerman

    spielermanMembers

    Jan 25, 2016
    34
    6
    18
    Male
    Maybe I had the same, but after the I've switched to 3G everything is OK.

    Sent from my Mi-4c using Tapatalk
     
  7. Martin_Spilovsky

    Jan 5, 2016
    9
    0
    11
    for me only reboot works, doenst matter what speed I select 2g/3g/4g
     
  8. spielerman

    spielermanMembers

    Jan 25, 2016
    34
    6
    18
    Male
    Well I'm on a fresh installed last weekly. No problems. Maybe you need to clean your cache? Also try going to airplane mode instead rebooting.

    Sent from my Mi-4c using Tapatalk
     
  9. Martin_Spilovsky

    Jan 5, 2016
    9
    0
    11
    I did perform sofar Divik and Cache cleanup after every DEV ROM Upgrade after using TWRP, even airplane mode doesnt fix it.
     
  10. Robbie13

    Robbie13Members

    Jan 24, 2016
    43
    1
    18
    Male
    does 6.1.28 fix problems for you guys ?

    Sent from my Mi-4c using Tapatalk
     
  11. Martin_Spilovsky

    Jan 5, 2016
    9
    0
    11
    seems with that with the latest rom the problem was fixed and some other stuff

    Sent from my Mi-4c using Tapatalk
     
  12. Juan Gaudiano

    Jan 18, 2016
    8
    0
    11
    Male
    Hello Martin,

    Could you please indicate the rom that fixed the problem for you?
     
  13. Juan Gaudiano

    Jan 18, 2016
    8
    0
    11
    Male
    I have installed the latest rom and still getting the same problem, when i leave my home and the wifi coverage is over there is no automatic switch to the network until a while
     
  14. Martin_Spilovsky

    Jan 5, 2016
    9
    0
    11
    Hi Juan did you tried the developer or the stable rom

    Sent from my Mi-4c using Tapatalk
     
  15. Juan Gaudiano

    Jan 18, 2016
    8
    0
    11
    Male
    Hi Martin,

    Sorry for the late response I used the weekly developer rom currently on 6.3.3, I have two MI4C with different sim providers and both get the same problem.
     
  16. Gosta

    GostaMembers

    Mar 23, 2016
    26
    1
    15
    Male
    Spain
    Yea, I can confirm that the error persists on 6.3.3. I have this issue since I started using the phone last month. Thanks God I'm not the only one at least.

    I couldn't post the problem earlier since I got a message error whenever I tried to sign up, but it got fixed by itself.
     
  17. Juan Gaudiano

    Jan 18, 2016
    8
    0
    11
    Male
    Does anyone knows a rom were this problem is solved?
     
  18. madctol

    madctolMembers

    Jan 20, 2016
    4
    0
    11
    Hello!

    Last OTA fix this problem on a friend's mi Mi4c.

    uploadfromtaptalk1459359837965.jpg
     
  19. Juan Gaudiano

    Jan 18, 2016
    8
    0
    11
    Male
    Hi I keep having this issue, with all the weekly roms I have updated, even the stable one. I have two mi4c with different network operators and I have the problema with both. Have to change to airplane mode to connect again to the network.
     

Share Our Site