New Mi4i Bricked - Fastboot Never Completes

Discussion in 'Bugs' started by Nico W., Aug 26, 2015.

  1. Nico W.

    Nico W.Members

    Dec 16, 2012
    34
    6
    18
    Male
    Hi people,
    I have some serious issues going on right now. I'll elaborate as clearly as possible below.
    As everyone knows it took forever for the servers to keep up with is downloading MIUI 7.
    Eventually I went for a proposal by a German stating a clean German/English lightning fast MIUI 7 ROM was waiting on a german forum.
    I downloaded it and first downloaded and used Mi4i toolkit v3 to first install twrp and then root. Both seemed succesfull, only after I checked to confirm twrp didn't work after all. Although root might still have.
    This time downloaded Mi4i toolkit v4 and redid the twrp recovery flash. This time it worked. I placed the downloaded ROM on my phone storage from my PC and performed a nandroid backup as well.
    As I couldn't find anything anywhere on anyone proposing a clean install for this ROM (v7 dev) coming from stock v6 stable, I started flashing the ROM through TWRP and all hell broke loose.
    TWRP froze up and only thing that worked was vol up+power. Phone rebooted straight back into twrp without my wanting, second time the same.
    I saw no other option than to wipe factory reset, without touching storage containing backup.
    Retried to flash the ROM without success.
    After some reading decided to use Fastboot as a last resort. Followed everything exactly (i tried to save my nandroid to my pc, but i believe cyclic redundance witheld me from doing that. Not specifically mentioned but the behavior of the malfunction sure reminded me a lot of my mi2) as described in all the guides. Flash_all.bat is present in the v7 unstable tgz I first managed to get downloaded. Started up the flashing process and it seems to work fluently just up until the point where it gets stuck on fastboot.blablabla.FLASH SYSTEM.blablabla, below it says device is busy...
    I tried that 3 times. one time I rebooted PC to press f8 and disable signature verification for drive installations. That didn't help.
    Today I redid the Fastboot flashing process with the finally acquired tgz for v6 stable as this is what everybody is proposing (although I belive it isn't the latest version I found), and you guessed it: it didn't work.
    I seem to be screwed no matter what here.
    Can someone PLEASE PLEASE PLEASE help me? You could save a MIbro and he will remember your name in eternity... :)

    Forgot to mention that I effectively used the Miflashtool for the fastboot job and i used the correct adb package. And it's inside the flashing process in the miflashtool that it gets stuck on the afore mentioned point for over 3000 seconds and it just stays there not moving... Forgot to mention as well that within these several attempts my mirecovery has come back, but that's it really....
     
  2. agungjuanda

    Jul 29, 2015
    9
    1
    13
    many ways to overcome it, the easiest way is to make sure fastboot drivers are already installed, the second if the devices are already in a state of your fastboot mode instead of pc typing cmd (fastboot devices) then enter, if the pc detecting means there is no problem with your devices fastboot

    Sent from my MI 3W using Tapatalk
     
  3. agungjuanda

    Jul 29, 2015
    9
    1
    13
    #3agungjuanda,Aug 27, 2015
    Last edited: Aug 27, 2015
    Step 1. Download and install MI Flash tool app on your windows desktop here.
    [​IMG]
    Step 2. Now Switch off your phone and boot in fastboot mode. Press the Volume– key and the Power button at the same time to enter Fastboot mode. If Phone is already in fastboot mode then follow the next step.[​IMG]
    Step 3. Connect your phone to the PC with USB cable and open the MI Flash tool that you installed in step 1.

    Step 4. Now open the Fastboot ROM folder and copy its path location. See the screenshot:-[​IMG]
    Step 5. Now paste the path location in the MI Flash tool, see the screenshot:-[​IMG]
    Step 6. Now click on refresh. Your device will appear in Mi Flash Tool window if it is connected.[​IMG]
    Step 7. Now you will see three option in the Flash tool.[​IMG]
    Choose the options carefully as per your need:-
    1. Flash_all:- Clears all the data of the built-in storage, clear all user data, please be careful!(Clean Install)
    2. Flash_all_except_storage:- Will erase all user data does not clear the built-in storage data.
    3. Flash_all_except_data_storage:- Does not clear the built-in storage data does not clear user data

    Note:- It is advised to take all personal data backup on PC/Laptop


    Step 8. Click on Flash and it will start the process. Once flashing process completes, the progress bar inside MiFlash turns fully green, which means the ROM has been successfully installed. Then your device should automatically boot to the new version.
    [​IMG]
    [​IMG]

    http://bigota.d.miui.com/V6.5.6.0.L...es_V6.5.6.0.LXIMICD_5.0_global_6e1915cee0.tgz

    you have to extract first

    Sent from my MI 3W using Tapatalk
     

Share Our Site