[mi5s] Batterie Drain, Cpu Wakelock, Loss Of Network

Discussion in 'Xiaomi Mi 5S / Plus' started by Darkdir, Jun 28, 2017.

  1. Darkdir

    DarkdirMembers

    Jun 28, 2017
    8
    3
    13
    Male
    hello

    i'm French

    i use Xiaomi.eu Rom since 8 month.
    since the beginning of the year, i have problems in the title:
    Batterie Drain
    CPU Wakelock
    Loss of Mobile Network
    Sim not detected

    At the beginning the problem appeared randomly 1 day then the next day no problem.
    It is intensified then became continuous with update
    I used the Rom Dev and simply update ( with wipe Cache / Dalvik only )

    With lots of rom
    DEV 7:
    xiaomi.eu_multi_MI5S_7.6.15_v8-7.0
    xiaomi.eu_multi_MI5S_7.6.22_v8-7.0
    DEV 6:
    xiaomi.eu_multi_MI5S_7.5.4_v8-6.0
    xiaomi.eu_multi_MI5S_7.4.27_v8-6.0
    xiaomi.eu_multi_MI5S_7.4.20_v8-6.0
    Stable:
    xiaomi.eu_multi_MI5S_V8.5.2.0.MAGCNED_v8-6.0

    and more!

    Rom "xiaomi.eu_multi_MI5S_V8.2.4.0.MAGCNDL_v8-6.0" WORKS normally. I use it now.

    I live in France with coverage 3G and 4G compatible with mi5s.

    I join several screenshots of two days with two different rom:
    xiaomi.eu_multi_MI5S_V8.2.4.0.MAGCNDL_v8-6.0
    xiaomi.eu_multi_MI5S_7.6.22_v8-7.0

    Test day:
    - alarm clock
    - Disconnect charger
    - breakfast (with Facebook ) Half-hour
    - go to work
    - work 4 hour
    - Lunch ( with Hotspot for my computer ) 1 hour
    - work 3 hour
    - go to home
    - Cry and Plug the charger (with a lot of Rom)

    - Data always turn on
    - GPS always turn on but in Device mode only
    - Wifi always turn off ( Except hotspot )
    - some SMS and call

    On the screenshot 7.6.22_V8-7.0(7), after activating the wifi hotspot, network losses and CPU Awake are no longer visible but always present

    I install the rom as follows:
    - Wipe Dalvik / ART cache
    - Wipe Cache
    - Wipe System
    - Wipe Data
    - Wipe Internal Storage
    - Reboot Recovery
    - Setting Language
    - Copy of the ROM on the MI5S
    - Install Zip ROM
    - Wipe Cache/Dalvik
    - Reboot System
    - MIUI Procedure (Language, Wifi, Google Account, Xiaomi Account)
    - Setting APN ( Mobile operator :Orange )
    - Reboot Recovery
    - Copy of SuperSu
    - Install Zip SuperSu (2.82 now)
    - Reboot System
    - For test days, I did not install any other application ( Except Facebook )
    - Otherwise I install all applications (and no problem with "xiaomi.eu_multi_MI5S_V8.2.4.0.MAGCNDL_v8-6.0" Rom )

    i use TWRP-3.1.1-0-capricorn since "xiaomi.eu_multi_MI5S_7.6.15_v8-7.0" ROM

    An update from "xiaomi.eu_multi_MI5S_V8.2.4.0.MAGCNDL_v8-6.0" to "xiaomi.eu_multi_MI5S_7.6.22_v8-7.0" ( Without full wipe, just Cache / Dalvik ) do not solve the problem.

    Sorry for this long speech but I would like to know what is wrong or what I do wrong.
    Sorry for my english.

    Thanks in advance
     

    Attached Files:

    Abakan83 likes this.
  2. Abakan83

    Abakan83Members

    Jun 20, 2017
    24
    3
    13
    Male
    The same error on Mi5s
     
  3. Crazyxijan

    CrazyxijanMembers

    Oct 6, 2016
    111
    22
    30
    Male
    Should be reported into bugs
     
  4. Abakan83

    Abakan83Members

    Jun 20, 2017
    24
    3
    13
    Male
    error when trying send any bug on any rom
     
  5. hawker

    hawkerMembers

    Feb 28, 2017
    19
    7
    15
    Male
    Confirm. with latest EU developer rom - i cant use my phone more then 10 hours((
     
    incase likes this.
  6. Darkdir

    DarkdirMembers

    Jun 28, 2017
    8
    3
    13
    Male
    the problem is still present in the 8.3.29

    I add one of the many Modem Ramdump
    sometimes every 3 minutes
    when it is plugged into the transformer (or computer) there is no more ramdump
    when sharing (3G> Wifi) is activated there is no more ramdump

    if anyone understands these files I would like to know what's wrong
     

    Attached Files:

  7. incase

    incaseMembers

    Dec 3, 2016
    18
    3
    13
    Male
    #7incase,Apr 4, 2018
    Last edited: Apr 4, 2018
    Same problem since two or three last updates.
    The last one which works was 8.2.1

    EDIT: I tun off the face unlock ... now it's better

    Gesendet von meinem MI 5s mit Tapatalk
     
  8. mateevici

    mateeviciMembers

    Apr 13, 2014
    11
    1
    15
    Male
    Problem present in stable as well.
    In 9.5.1, still present.

    The main issue here, which is obvious is that there is massive activity when the screen is off...
    Why?
    You can see it clearly in the screenshots.

    What's interesting is that from a certain battery level, around 60ish, this stops.
     
  9. Darkdir

    DarkdirMembers

    Jun 28, 2017
    8
    3
    13
    Male
    Yes
    at 50% the state "awake" is no longer recognized
    but the problem continues (modem crash etc)
    there is only the display that stops (a bug overdose: p)

    (sorry for my bad english)