Resolved [MIUI 12.6][weekly][RN8] Cannot select physical keyboard layout


dexterv

Members
Jul 22, 2020
652
102
Currently I do not see a working solution to selecting a physical keyboard layout - when connected to a BT KB for example, it sticks to saying Default and always uses a QWERTY layout. It is possible to make the selection stick by holding the keyboard option but it results in no changes.
Has anyone managed to use a different layout?

Edit 1: It is mentioned here and here.
Edit 2: my sleepy me, thought that the threads were in their devices sections and not the Bugs one.
 
Last edited:

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,963
322
You're right, switching keyboard layouts doesn't get saved.
I don't have a BT keyboard, but it's the same issue with a USB keyboard.
I'll see if I can do something about it.
 
  • Like
Reactions: dexterv

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,963
322
Seems like Xiaomi didn't code it properly, so when you tap the toggle of a keyboard layout option, nothing is happening being the scene.
The only way to actually apply it is to tap the option itself (not the toggle).
 

dexterv

Members
Jul 22, 2020
652
102
Seems like Xiaomi didn't code it properly, so when you tap the toggle of a keyboard layout option, nothing is happening being the scene.
The only way to actually apply it is to tap the option itself (not the toggle).
Yes, if you tap the options itself it will save the setting visually, but the layout would still not change/work when typing in my tests. Does it change it for you?
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,963
322
Patched successfully. The toggle is working correctly now, and the enabled layouts dialog no longer shows "Default" if you enabled at least one layout.
And yes, for me it's actually applied.
If I enable and select "Swedish", for example, and type ";" - I get "ö" instead, so working fine.
 

Attachments

  • photo_2021-08-04_17-29-07.jpg
    photo_2021-08-04_17-29-07.jpg
    33.4 KB · Views: 63
  • Like
Reactions: dexterv

dexterv

Members
Jul 22, 2020
652
102
Patched successfully. The toggle is working correctly now, and the enabled layouts dialog no longer shows "Default" if you enabled at least one layout.
And yes, for me it's actually applied.
If I enable and select "Swedish", for example, and type ";" - I get "ö" instead, so working fine.
Great, thanks a lot, I will test it when it is out with the new weekly.
 

dexterv

Members
Jul 22, 2020
652
102
Well I managed to install the 21.8.11 version and I can see that the changes you made are applied, you can select the layout, but there is still something not working properly. For example I tried the Swedish layout example and I still get ; The only thing that showed me that it was doing something was that when I select German it goes to QWERTZ, so when i press Y it goes to Z but no Bulgarian (Cyrillic letters) in the Bulgarian Layout, nothing. Did they delete some of the keyboard layouts or is it only for the RN8? Can I do something to help figure out what is happening?