Miui EU Stable installation issue. Help, please! (SOLVED)


Tukan41

Members
Jan 17, 2022
14
5
Hi all:

I am trying to install MIUI EU STABLE, but I have a problem. When I run the "windows_fastboot_first_install_with_data_format" file, the command screen opens but closes in less than a second (so I can't type "y"). I have the abd drivers installed, and when I type "adb devices" in a command screen the computer detects my phone. Of course I have the bootloader unlocked. I have seen a tutorial on youtube where it is said that you have to copy the contents of the rom zip into the abd or platform tools folder and run it from there, but even so I have not succeeded. Could anyone help me please? All the best.
 
  • Sad
Reactions: BigDisplay

sunset_in_mars

Members
Apr 17, 2021
55
30
Hi all:

I am trying to install MIUI EU STABLE, but I have a problem. When I run the "windows_fastboot_first_install_with_data_format" file, the command screen opens but closes in less than a second (so I can't type "y"). I have the abd drivers installed, and when I type "adb devices" in a command screen the computer detects my phone. Of course I have the bootloader unlocked. I have seen a tutorial on youtube where it is said that you have to copy the contents of the rom zip into the abd or platform tools folder and run it from there, but even so I have not succeeded. Could anyone help me please? All the best.
What " fastboot devices " says " ? I mean, you are in fastboot mode when trying to do install.bat ?
 
  • Like
Reactions: BigDisplay

MeiGuddet

Members
Apr 29, 2016
1,167
222
Hi all:

I am trying to install MIUI EU STABLE, but I have a problem. When I run the "windows_fastboot_first_install_with_data_format" file, the command screen opens but closes in less than a second (so I can't type "y"). I have the abd drivers installed, and when I type "adb devices" in a command screen the computer detects my phone. Of course I have the bootloader unlocked. I have seen a tutorial on youtube where it is said that you have to copy the contents of the rom zip into the abd or platform tools folder and run it from there, but even so I have not succeeded. Could anyone help me please? All the best.
There is a howto installation guide. Why don't you read it? Use search function, please and don't post the same again and again.
Thank you.
 
  • Wow
Reactions: BigDisplay

Tukan41

Members
Jan 17, 2022
14
5
There is a howto installation guide. Why don't you read it? Use search function, please and don't post the same again and again.
Thank you.
I have followed how to installation guide, but when i have i arrive to the step "Run fastboot installation script from unpacked zip according your PC operating system", the scren which is supposed to open, opens only for a second and suddenly closes. And the former was my first post, i haven't posted "the same again and again". Anyway, sorry if i have done something wrong.
 
  • Like
Reactions: BigDisplay

Tukan41

Members
Jan 17, 2022
14
5
Ok, then it should work. Are you sure you are doing install from the same folder you unzipped the ROM to ? Use WinRAR and try once more.
Yes, i'm sure. I unzip the folder, for instance, on the Desktop, i open it and i try to run the file "windows_fastboot_first_install_with_data_format" even as admin, but it doesn't work. It makes like a sudden and short blink, that it to say, it opens and closes suddenly. I don't know what to do.
 

sunset_in_mars

Members
Apr 17, 2021
55
30
Yes, i'm sure. I unzip the folder, for instance, on the Desktop, i open it and i try to run the file "windows_fastboot_first_install_with_data_format" even as admin, but it doesn't work. It makes like a sudden and short blink, that it to say, it opens and closes suddenly. I don't know what to do.
Try with either https://forum.xda-developers.com/t/...sb-driver-installer-tool-for-windows.3999445/ or https://forum.xda-developers.com/t/...vers-15-seconds-adb-installer-v1-4-3.2588979/ Im using first one on Windows 10
 
  • Like
Reactions: BigDisplay

Tukan41

Members
Jan 17, 2022
14
5
Friend, thank you very much. I've seen both tutorials, but they try to solve problems that I don't seem to have. I think everything related to adb drivers is correct. Because, with my phone on, if I type "adb devices" the phone is detected, and in fastboot mode if I type "fasboot devices" (as you have indicated to me) my phone is also detected. On the other hand, in Device Manager my phone is not listed with any errors. Is it possible that there is a defect in the "windows_fastboot_first_install_with_data_format" file of the rom I downloaded? I know it's highly unlikely, but I don't know what to think anymore.
 

sunset_in_mars

Members
Apr 17, 2021
55
30
Friend, thank you very much. I've seen both tutorials, but they try to solve problems that I don't seem to have. I think everything related to adb drivers is correct. Because, with my phone on, if I type "adb devices" the phone is detected, and in fastboot mode if I type "fasboot devices" (as you have indicated to me) my phone is also detected. On the other hand, in Device Manager my phone is not listed with any errors. Is it possible that there is a defect in the "windows_fastboot_first_install_with_data_format" file of the rom I downloaded? I know it's highly unlikely, but I don't know what to think anymore.
Beats me, it can be possible that downloaded ROM is corrupted. Download again and check MD5 to be sure. Guess you have to start from scratch if no help. One more guide for drivers you could try out https://xiaomi.eu/community/threads/problems-with-updating.61957/#post-616357 Good luck.
 

katerpanne

Members
Apr 19, 2014
2,879
332
Friend, thank you very much. I've seen both tutorials, but they try to solve problems that I don't seem to have. I think everything related to adb drivers is correct. Because, with my phone on, if I type "adb devices" the phone is detected, and in fastboot mode if I type "fasboot devices" (as you have indicated to me) my phone is also detected. On the other hand, in Device Manager my phone is not listed with any errors. Is it possible that there is a defect in the "windows_fastboot_first_install_with_data_format" file of the rom I downloaded? I know it's highly unlikely, but I don't know what to think anymore.
look here… check driver, usb port, usb2.try hub, did you unlocked the device really

what is the output of the script, anny error message?
 

LOLO9393

Members
Feb 8, 2016
3,217
322
Hi all:

I am trying to install MIUI EU STABLE, but I have a problem. When I run the "windows_fastboot_first_install_with_data_format" file, the command screen opens but closes in less than a second (so I can't type "y"). I have the abd drivers installed, and when I type "adb devices" in a command screen the computer detects my phone. Of course I have the bootloader unlocked. I have seen a tutorial on youtube where it is said that you have to copy the contents of the rom zip into the abd or platform tools folder and run it from there, but even so I have not succeeded. Could anyone help me please? All the best.
HINT:
LINUX user don't put the process in the platform-tools directory.
Script is done to work out of it, not like for WINDOWS users that have to be in fastboot tool .
Big thanks to Igor!
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,476
322
HINT:
LINUX user don't put the process in the platform-tools directory.
Script is done to work out of it, not like for WINDOWS users that have to be in fastboot tool .
Big thanks to Igor!
People shouldn't move the scripts no matter what OS they're using. The scripts for Windows were also designed to work one level outside the platform-tools folder, like the other scripts.
 

Tukan41

Members
Jan 17, 2022
14
5
Beats me, it can be possible that downloaded ROM is corrupted. Download again and check MD5 to be sure. Guess you have to start from scratch if no help. One more guide for drivers you could try out https://xiaomi.eu/community/threads/problems-with-updating.61957/#post-616357 Good luck.
Guy, thx a lot for helping me. I was trying a wrong ROM... MI 11's, when I have a POCO F3. The reason was that MI 11's rom file has "F3" in his name, and i didn't realize about this. Thx and sorry for all the time you have spent helping me.
 

Tukan41

Members
Jan 17, 2022
14
5
look here… check driver, usb port, usb2.try hub, did you unlocked the device really

what is the output of the script, anny error message?
Guy, thx a lot for helping me. I was trying a wrong ROM... MI 11's, when I have a POCO F3. The reason was that MI 11's rom file has "F3" in his name, and i didn't realize about this. Thx and sorry for all the time you have spent helping me.
 
  • Like
Reactions: katerpanne

Tukan41

Members
Jan 17, 2022
14
5
HINT:
LINUX user don't put the process in the platform-tools directory.
Script is done to work out of it, not like for WINDOWS users that have to be in fastboot tool .
Big thanks to Igor!
Guy, thx a lot for helping me. I was trying a wrong ROM... MI 11's, when I have a POCO F3. The reason was that MI 11's rom file has "F3" in his name, and i didn't realize about this. Thx and sorry for all the time you have spent helping me.