MiuiSystemUI FC when recieving sms

Discussion in 'Question & Answers' started by 1982Strand, Nov 29, 2012.

  1. 1982Strand

    1982StrandMembers

    Apr 2, 2011
    204
    10
    40
    Hi everyone :)

    I'm testing my translations and have made my own tiny build system for the miui apks.
    I got almost everything worked out now and it seems that everything is working, i just got one little issue that i've been trying to fix for many days now without luck :(

    It's as the title says, when i recieve a text message, the statusbar FC's, sometimes it freezes/reboots the phone.
    I get this from the log created by miui:

    Code:
    java.lang.AbstractMethodError:
    abstract method not implemented
      at android media.IRingtonePlayer$Stub.SetOnCompletionListener(IRingtonePlayer.java)
      at android.media.IRingtonePlayer$Stub.onTransact(IRintonePlayer.java:115)
      at android.os.Binder.execTransact(Binder.java.367)
      at.dalvik.system.NativeStart.run(Native Method)
    Running out of ideas of what to look for, so i hoped someone here had some ideas..
    Testing on Galaxy S3 - 2.11.23

    Thanks :)

    Btw. using latest aapt/apktool on linux
    I did this:
    Install frameworks 1-6
    Decompile apks, no errors.
    Edit apks (add translations/images for all apks, add apktool.yml fix and array fix for framework-miui-res)
    Recompile apks, no errors (Ignored the "has no default translation" ones for other langs..)
    Then inject res folder and resources.arsc (and classes.dex if needed)
    Optimised PNGS and zipaligned the apks.
    Made flashable zip, flashed in recovery, wiped cache and dalvik, fixed permissions)
    Cleared app data for Mms.apk, still the same..
     
  2. ingbrzy

    ingbrzyXiaomi.eu Multilang leader
    Staff Member

    Post full logcat.. report miui -menu - copy
     
  3. 1982Strand

    1982StrandMembers

    Apr 2, 2011
    204
    10
    40
    Yeah well, this IS the logcat i get from miui..

    Anyways. Got it now. Dont know exactly why it worked though :) I reversed the building more or less. Instead of injecting res folder and resources. Arsc into the original apk, I injected android manifest. XML and meta-inf folder into the dist apk ;-)
    Any thoughts on which method is better? Injecting res arsc into original, or injecting meta-inf into new apk?

    @ my commodore 64
     
  4. Hi.
    I've the same issue, and the same logcat...
    How should I resolve that without decompile and recompile the apk?
    Thanks a lot.
     
  5. 1982Strand

    1982StrandMembers

    Apr 2, 2011
    204
    10
    40
    Have you edited the apks yourself? What version er you using and what language? Also on GS3?
     
  6. I haven't edited any apk yet... I use GS3 I9300, language english!
     
  7. 1982Strand

    1982StrandMembers

    Apr 2, 2011
    204
    10
    40
    Hmm! I saw on the official english forum, there's a post about bugs for the S3 and this one is mentioned.. So maybe it wasn't just me screwing something up with my editing?

    Anyways, my only suggestion is, take a backup of your stuff, wipe everything and do a clean install.. Avoid restoring system settings afterwards. Don't know if it helps, but if you STILL have the problem, then you should probably report it as a bug, if it's not already in there..
     
  8. I've reported the bug... I'll waiting the bugfix in the next release!
     

Share Our Site