No Data Mobile Connection With Fastweb And 6.5.26

Discussion in 'Xiaomi Mi 5' started by Ale984it, May 28, 2016.

  1. Ale984it

    Ale984itMembers

    May 28, 2016
    6
    0
    11
    Male
    #1Ale984it,May 28, 2016
    Last edited: May 28, 2016
    Hi guys,
    I bought a xiaomi mi5 and I installed the last release of Multilang xiaomi.eu ROM, but I've a problem with data mobile connection. My operator is Fastweb Mobile (a virtual operator of H3G Italy) and with your ROM seems isn't recognized.
    With the suspended global ROM (7.2.4.0) my mi5 was perfect and the mobile connection worked fine. In the notification bar appeared correctly the name of my operator "FASTWEB 3G" but with xiaomi.eu ROM appears "3 ITA 3G" and the connection doesn't start.
    The mobile settings are the same with both ROM.
    Can someone explain why the data connection works with the Global ROM and does not work with the xiaomi.eu ROM? Is Fastweb operator unsupported? How I fix the problem?

    Thanks a lot for your collaboration and sorry for my imperfect english.
     
  2. Cecco

    CeccoMembers

    Apr 1, 2016
    249
    27
    52
    Male
    Take a look at apn's or maybe you have roaming optional enabled. Did you tried a factory reset. Ciao e fammi sapere
     
  3. Ale984it

    Ale984itMembers

    May 28, 2016
    6
    0
    11
    Male
    Cecco, thanks for reply.
    I tried a factory reset. The roaming option is disabled in both ROM. Now I look the apn's differences between two ROMs.

    Thanks.
     
  4. Ale984it

    Ale984itMembers

    May 28, 2016
    6
    0
    11
    Male
    #4Ale984it,May 28, 2016
    Last edited: May 28, 2016
    The apn's settings are the same in both ROMs but in the 7.2.4.0 the mobile connection works fine, in xiaomi.eu ROM doesn't work.
    Any ideas?

    With the xiaomi.eu ROM appears in notification bar the wrong carrier.
     
  5. Cecco

    CeccoMembers

    Apr 1, 2016
    249
    27
    52
    Male
    With virtual operator i think it shows the major operator. But you cant go to internet as well??
     
  6. Ale984it

    Ale984itMembers

    May 28, 2016
    6
    0
    11
    Male
    No, the mobile connection doesn't start. I tried another ROM made by miui italian forum, and the connection works properly. It's very strange.
     
  7. Ale984it

    Ale984itMembers

    May 28, 2016
    6
    0
    11
    Male
    There is a file that contains the connection parameters to edit or copy from other ROM and port it on xiaomi.eu ROM?
     
  8. Cecco

    CeccoMembers

    Apr 1, 2016
    249
    27
    52
    Male
    I dont know if it works but you can only flash modem's file of a different rom. I did it on my old oneplus One and worked. I left intact the original rom but i changed modem files
     
  9. Ale984it

    Ale984itMembers

    May 28, 2016
    6
    0
    11
    Male
    It's a very good idea.

    Please, could you link me a guide on how to extract modem from the xiaomi.eu ROM?

    Thanks.
     
  10. Cecco

    CeccoMembers

    Apr 1, 2016
    249
    27
    52
    Male
    You have to extract from a working rom like you said on 7.2.4.0. download rom and then extract with winrar modem1 and modem2 files. I'm not at home so i cant see if there are 1 or 2 files or more...
     
  11. Kamrul

    KamrulMembers

    Oct 18, 2013
    17
    2
    15
    Male
    Bangladesh
    Can you please tell how to to extract those modem1 and modem2 from ROM?
     
  12. Cecco

    CeccoMembers

    Apr 1, 2016
    249
    27
    52
    Male
    Take the rom zip, unzip it and search modem files send a screenshot of rom files and we will help you
     
  13. Kamrul

    KamrulMembers

    Oct 18, 2013
    17
    2
    15
    Male
    Bangladesh
    Please see extracted files....
    http://postimg.org/image/r7i8zdc6p/
     
  14. Kamrul

    KamrulMembers

    Oct 18, 2013
    17
    2
    15
    Male
    Bangladesh
     

    Attached Files:

  15. Cecco

    CeccoMembers

    Apr 1, 2016
    249
    27
    52
    Male
    Wait answers from others but non hlos.bin is a modem file. I'm quite sure. You need to flash it with fastboot mode with a command that i dont remember but before wait confirmation from others than i will search the command
     

Share Our Site