No WLAN, No SIM management after ROM upgrade

Discussion in 'Xiaomi Redmi 1S WCDMA' started by Fickle Chortle, Aug 25, 2014.

  1. Fickle Chortle

    Aug 25, 2014
    3
    0
    11
    Hi all,

    I have an issue with the Redmi 1S. It is brand new and was equipped with MIUI ver. 23 from factory. Since it was the multi language - but did not support my language, (Danish), I went for an upgrade of the phone.

    I believe it was MIUI version 31 at the time but after flashing via the internal recovery function the phone did no longer work. Symptoms are:
    • When setting up - settings application is unable to start proberly. Have to close/skip.
    • WLAN cannot be found. Loops forever. Have to skip.
    • SIM card is not detected. Have to skip.
    I have seen elsewhere that IMEI and WLAN parameters can cause this on a Redmi 1 - and maybe it is the same here. But I cannot find a way to check or confirm that this is the case.

    When continuing without WLAN and SIM one can see that ramdump files are continuously being created on the internal storage. This will continue until all space is used up.

    Phone cannot shut down normally. It stays in the 'shutting down' picture when trying.

    I have been flashing using the method mentioned above, and by renaming/copying an update.zip onto the sd card and from there to the phone. I have also tried using the MiFlash utility - roms 23, 31, 36.

    Complete wipe using built in recovery, or wiping using TWRP flashed onto the phone does not work either.

    So - it is not bricked, but malfunctioning when it comes to the internal radio hardware as I conclude. Any help will be apriciated.

    Would another ROM - like Cyanogen - help in a case like this if it was available?

    Cheers
     
  2. gh0st3g

    gh0st3gMembers

    Aug 7, 2014
    17
    2
    13
    Male
    You said that, your phone is brand news, but you can use TWRP. so i wonder if your phone is brand why its has TWRP or you flash TWRP after buy the phone, then as your's problem, i thinks may be is your TWRP, so you must be come back miui recovery and flash fresh rom. Try and good luck
     
  3. Fickle Chortle

    Aug 25, 2014
    3
    0
    11
    Sorry, my mistake. this was just one of many steps. The sequence is:

    New phone with MIUI v. 23 -> Upgrade to MIUI 31 using internal recovery app
    Phone stops working on WiFi and SIM
    Flash MIUI 23 fastboot back to phone - still not working
    Flash TWRP 2.7.1 to be able to clean wipe phone
    Flash MIUI 31 or 36 cannot remember, no changes using update.zip

    Since I cannot get access to the phone memory via USB, I am copying ROM via SD card to internal memory as update.zip still no changes. (Following instructions from xiaomi.eu on which ROM to use.)

    After this I have tried again using MiFlash with MIUI 23 and 36 - still no change to the IMEI/WiFi problem.
     
  4. gh0st3g

    gh0st3gMembers

    Aug 7, 2014
    17
    2
    13
    Male
    how about imei number and wlan mac address, somtime lost imei or mac address will couse your's problem
     
  5. Fickle Chortle

    Aug 25, 2014
    3
    0
    11
    Hi Ghost - yes I have come to the same conclusion. I can see from these fora that this problem also happens with the Redmi 1.

    For the Redmi 1 there is an application called Mobileuncle which can fix this. But as I understand this application does not work with the Redmi 1SW.

    Any information on how to access and change these values would be very much appreciated.
     
  6. apastor

    apastorMembers

    Jul 9, 2015
    1
    0
    11
    Male
    #7apastor,Jul 9, 2015
    Last edited: Jul 9, 2015

Share Our Site