OTG & MHL issues


Jul 24, 2011
465
234
65
#1
So i got my OTG and MHL cables in the mail today but neither seem to work. Is it something i have to turn on in settings? i tired both a NTFS and FAT32 formated 16gb sd card in a card reader that came with the phone but could never get it to show up anywhere. as for MHL to HDMI i tired going direct into my tv and in my receiver from my sony speaker system but nothing ever showed up on the tv. I know i was on the right input because my tv only has 1 HDMI input. I have not tried with the official rom from xiaomi but that is my next step. I am using 3.1.19 with lang pack. Anyone able to use either of these features?

Does anyone have to official Mi2 rom from xiaomi they could share somewhere so i don't have to wait hours for it to download from xiaomi? Nevermind that. for once the download from xiaomi actually went really fast.
 
Jul 24, 2011
465
234
65
#3
i see. thanx for that one. I searched for OTG but did not search for MHL related issues. I will be flashing 3.1.19 from xiaomi and will see what happens.

None of that worked for OTG anyways. Can't test MHL right now as i am at work. Flashed official xiaomi 3.1.19 and JBL 10 but still nothing would work with OTG. I'm almost blaiming the cable at this point but since i don't have another to test with i can't be sure....
 
Likes: hadron

5ulo

Members
May 25, 2012
135
15
28
#4
OTG (USB drive, keyboard/mouse) is working perfectly. If you have any trouble with USB pen drive, format it to FAT32. I tried EXT4 but it was not recognized by android (Bad filesystem).
MHL>HDMI - this was weird.. I don't know what happened but suddenly it worked.. Turn off your phone and then turn it on again. If it doesn't work, backup your phone and try factory reset. The last chance is to full wipe and flash again 3.1.18 (or .19).
Hope it helps
 
Jul 24, 2011
465
234
65
#5
I did do a full wipe before flashing JBL10 i'm trying to read a 16gb fat32 sd card using a card reader and the phone is not even recognizing anything is plugged in. I tired a mouse did not work either. I will try MHL with JBL10 as soon as i get home. i hope it works this time. It's looking like the OTG cable i have is the problem.
 

5ulo

Members
May 25, 2012
135
15
28
#10
no, I don't know.. when I plug in keyboard/mouse, it works immediately. if you move with the mouse, you'll see mouse pointer on the screen. if there's no pointer, something is wrong.
The same with with NHL - no picture on tv means something went wrong
 
Jul 24, 2011
465
234
65
#13
i do not know anyone who has one. i wish i did. Trying to find one in a local store but so far no luck. looks like i will have to wait another month to use this feature.(that's generally how long it takes when i order from DealXtream)
 
Jul 24, 2011
465
234
65
#15
I'm in canada. Normally it's the border that holds it up. Altho last time i got something it did not take as long as usual so maybe they have gotten better.

[random]
Can i just say that this is the longest conversation i have had with just 2 participants on a forum ever.
[/random]
 
Jul 24, 2011
465
234
65
#17
well it looks like i'm going to have to shop for 2 new cables. With MHL i got sound but no video. I'm now flashing jbl using fastboot in case that somehow does something different and will try again. Somehow i almost blame my stupid tv it has issues with the raspberry pi's HDMI output as well. will update later when i get the tv back.
 
Sep 23, 2012
648
170
82
#19
i do not know anyone who has one. i wish i did. Trying to find one in a local store but so far no luck. looks like i will have to wait another month to use this feature.(that's generally how long it takes when i order from DealXtream)
If you can find a USB extension and a normal USB data cable for your phone then you can make your own otg cable. Just google "DIY otg cable " its easy and you don't have to wait long.

hadron

Sent from my Xiaomi M2
 
Jul 24, 2011
465
234
65
#22
Might have to do that. Or i might just take it to work and try it with a Dell monitor. i really hope it does not work anywhere else because if it does it means it's my tv and that would just suck...
 
Jul 24, 2011
465
234
65
#24
It looks very real. I get audio but no vid. I had found it on another store on ********** that had reviews for cheaper but i truested the seller i purchased from more since i got my Mi2 from them...
 
Jul 24, 2011
465
234
65
#25
Time for an update. I tired with my dads TV and it worked. It seemed to take a while the first time i plugged it in and maybe it had something to do with the fact that i help the power button until the shutdown menu came up but it worked. The second time i plugged it in it worked right away. The only problem i had with his TV is that as soon as i unplugged the MHL cable from the phone the phone froze up. Happened both times. What if anything could be so different about my TV that it would not work? Mine is a sharp(exact model escapes me at the moment) 26 inch tv his is a LG. i will try on my tv again tonight and see what happens...

still no go...WTF is wrong with my TV!!!!! i hope the other MHL to HDMI adapter i got from dealxtream works....but now i have my doubts....